aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-12-27 18:35:19 +0800
committerKubilay Kocak <koobs@FreeBSD.org>2015-12-27 18:35:19 +0800
commit77f1c944fc4b525961ac753e6c03a9bcb7a2b473 (patch)
tree1604ec67b15d8369f21f8d2a023a564698639168 /www
parent2994568d07c7b4d5748a7251b77270e9c884ab68 (diff)
downloadfreebsd-ports-gnome-77f1c944fc4b525961ac753e6c03a9bcb7a2b473.tar.gz
freebsd-ports-gnome-77f1c944fc4b525961ac753e6c03a9bcb7a2b473.tar.zst
freebsd-ports-gnome-77f1c944fc4b525961ac753e6c03a9bcb7a2b473.zip
www/py-gunicorn: Update to 19.4.1 & much more!
- Update PORTVERSION and distinfo checksum (19.4.1) - Match COMMENT to setup.py:description= - Add LICENSE_FILE - Options: Rename SETPROC option -> Add PROCTITLE to defaults - Options: Add GAIOHTTP async worker - Options: Update all descriptions - Options: Remove TESTS optionjs - Enable "concurrent" Python support - Add NO_ARCH (architecture independent package) - Rename test target to new conventions - Check, limit, and add BROKEN message for Option/Python version combinations that aren't supported. - Patch out non-compulsory dependencies from test requirements file - Delete requirements_dev.txt patch file (no longer necessary) - Add post-patch: target to remove _gaiohttp.py, because compileall() of this file fails on 2.x with a SyntaxError, but is not handled, so .py[co] files references are added to --record output, breaking file list generation. [1][2][3][4][5] Changes: http://docs.gunicorn.org/en/stable/news.html [1] https://github.com/benoitc/gunicorn/issues/788 [2] https://github.com/benoitc/gunicorn/issues/860 [3] https://github.com/benoitc/gunicorn/issues/982 [4] https://github.com/pypa/pip/issues/1873 [5] https://github.com/pypa/pip/issues/1954
Diffstat (limited to 'www')
-rw-r--r--www/py-gunicorn/Makefile62
-rw-r--r--www/py-gunicorn/distinfo4
-rw-r--r--www/py-gunicorn/files/patch-requirements__test.txt6
-rw-r--r--www/py-gunicorn/files/patch-requirements_dev.txt5
4 files changed, 52 insertions, 25 deletions
diff --git a/www/py-gunicorn/Makefile b/www/py-gunicorn/Makefile
index 75fcc9f3610a..9e19fec8c8c2 100644
--- a/www/py-gunicorn/Makefile
+++ b/www/py-gunicorn/Makefile
@@ -2,41 +2,67 @@
# $FreeBSD$
PORTNAME= gunicorn
-PORTVERSION= 18.0
-PORTREVISION= 1
+PORTVERSION= 19.4.1
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Python WSGI server for UNIX
+COMMENT= WSGI HTTP Server for UNIX
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
-OPTIONS_DEFINE= SETPROC TESTS
+OPTIONS_DEFINE= PROCTITLE
+OPTIONS_DEFAULT= PROCTITLE
OPTIONS_GROUP= WORKERS
-OPTIONS_GROUP_WORKERS= EVENTLET GEVENT TORNADO
+OPTIONS_GROUP_WORKERS= EVENTLET GAIOHTTP GEVENT TORNADO
-EVENTLET_DESC= Eventlet async worker support
-GEVENT_DESC= Gevent async worker support
-TORNADO_DESC= Tornado async worker support
-SETPROC_DESC= Support custom process names (setproctitle)
-TESTS_DESC= Install pytest for unit tests
+EVENTLET_DESC= Eventlet async worker
+GAIOHTTP_DESC= gaiohttp async worker (Requires Python 3.3+)
+GEVENT_DESC= Gevent async worker (Requires Python < 3.x)
+PROCTITLE_DESC= Custom process titles with setproctitle(3)
+TORNADO_DESC= Tornado async worker
EVENTLET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}eventlet>=0.9.7:${PORTSDIR}/net/py-eventlet
+GAIOHTTP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>0:${PORTSDIR}/www/py-aiohttp
GEVENT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gevent>=0.12.2:${PORTSDIR}/devel/py-gevent
+PROCTITLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setproctitle>0:${PORTSDIR}/devel/py-setproctitle
TORNADO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tornado>=2.2:${PORTSDIR}/www/py-tornado
-SETPROC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setproctitle>0:${PORTSDIR}/devel/py-setproctitle
-TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
-USE_GITHUB= yes
-USES= python
-USE_PYTHON= distutils autoplist
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
GH_ACCOUNT= benoitc
-regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3300
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+.endif
+
+.if ${PYTHON_REL} > 3000 && ${PORT_OPTIONS:MGEVENT}
+BROKEN= GEVENT requires Python < 3.x but this port is building with Python ${PYTHON_VER}. \
+ Disable the GEVENT option of change the version of Python to build with, using DEFAULT_VERSIONS
+.endif
+
+.if ${PYTHON_REL} < 3000
+
+# compileall() fails on 2.x, but .py[co] files are still in --record output
+post-patch:
+ ${RM} ${WRKSRC}/gunicorn/workers/_gaiohttp.py
+
+.if ${PYTHON_REL} < 3300 && ${PORT_OPTIONS:MGAIOHTTP}
+BROKEN= GAIOHTTP requires Python 3.3+ but this port is building with Python ${PYTHON_VER}. \
+ Disable the GAIOHTTP option or change the version of Python to build with, using DEFAULT_VERSIONS
+.endif
+.endif
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.post.mk>
diff --git a/www/py-gunicorn/distinfo b/www/py-gunicorn/distinfo
index 44cd45cd3dd8..229c35e53c43 100644
--- a/www/py-gunicorn/distinfo
+++ b/www/py-gunicorn/distinfo
@@ -1,2 +1,2 @@
-SHA256 (benoitc-gunicorn-18.0_GH0.tar.gz) = 1d2108101e3ea4712ed7760539d43f56675724cf02e6c407371bec05df51ca97
-SIZE (benoitc-gunicorn-18.0_GH0.tar.gz) = 370772
+SHA256 (benoitc-gunicorn-19.4.1_GH0.tar.gz) = 81899db60828fdd0377f1e6618859459af0cd151b70baf90ca3c76cabaf3cfe1
+SIZE (benoitc-gunicorn-19.4.1_GH0.tar.gz) = 404656
diff --git a/www/py-gunicorn/files/patch-requirements__test.txt b/www/py-gunicorn/files/patch-requirements__test.txt
new file mode 100644
index 000000000000..72a691b5c27e
--- /dev/null
+++ b/www/py-gunicorn/files/patch-requirements__test.txt
@@ -0,0 +1,6 @@
+--- requirements_test.txt.orig 2015-02-04 13:43:57 UTC
++++ requirements_test.txt
+@@ -1,2 +1 @@
+-pytest==2.6.3
+-pytest-cov==1.7.0
++pytest>=2.6.3
diff --git a/www/py-gunicorn/files/patch-requirements_dev.txt b/www/py-gunicorn/files/patch-requirements_dev.txt
deleted file mode 100644
index 014fbf677514..000000000000
--- a/www/py-gunicorn/files/patch-requirements_dev.txt
+++ /dev/null
@@ -1,5 +0,0 @@
---- ./requirements_dev.txt.orig 2012-11-20 18:50:15.000000000 +1100
-+++ ./requirements_dev.txt 2012-11-20 18:50:21.000000000 +1100
-@@ -1,2 +1 @@
- pytest
--pytest-cov