aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-01-20 21:58:51 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-01-20 21:58:51 +0800
commit788a89ea7a6b4afee2d8aa2d24840897b93ae09a (patch)
treede8b3b016f6c75448b23c33cd11cd2e3e26cc8d9 /www
parent48052c18da9a09f196dd854c34ae40835b12f8ef (diff)
downloadfreebsd-ports-gnome-788a89ea7a6b4afee2d8aa2d24840897b93ae09a.tar.gz
freebsd-ports-gnome-788a89ea7a6b4afee2d8aa2d24840897b93ae09a.tar.zst
freebsd-ports-gnome-788a89ea7a6b4afee2d8aa2d24840897b93ae09a.zip
Sinatra-ish framework on Amon2.
WWW: http://search.cpan.org/dist/Amon2-Lite/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Amon2-Lite/Makefile31
-rw-r--r--www/p5-Amon2-Lite/distinfo2
-rw-r--r--www/p5-Amon2-Lite/pkg-descr3
-rw-r--r--www/p5-Amon2-Lite/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2c4ce76392f0..16f43927d8cb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -604,6 +604,7 @@
SUBDIR += p5-AMF-Perl
SUBDIR += p5-Acme-Monta
SUBDIR += p5-Amon2
+ SUBDIR += p5-Amon2-Lite
SUBDIR += p5-Amon2-Plugin-LogDispatch
SUBDIR += p5-Any-Template
SUBDIR += p5-AnyEvent-HTTP
diff --git a/www/p5-Amon2-Lite/Makefile b/www/p5-Amon2-Lite/Makefile
new file mode 100644
index 000000000000..b57d16da919e
--- /dev/null
+++ b/www/p5-Amon2-Lite/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= Amon2-Lite
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for Sinatra-ish framework on Amon2!
+
+RUN_DEPENDS= \
+ p5-Amon2>=3.25:${PORTSDIR}/www/p5-Amon2 \
+ p5-Data-Section-Simple>=0.03:${PORTSDIR}/devel/p5-Data-Section-Simple \
+ p5-Router-Simple>=0.13:${PORTSDIR}/www/p5-Router-Simple \
+ p5-Text-Xslate-Bridge-TT2Like>=0.00010:${PORTSDIR}/textproc/p5-Text-Xslate-Bridge-TT2Like
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Text-MicroTemplate>0:${PORTSDIR}/textproc/p5-Text-MicroTemplate \
+ p5-Test-WWW-Mechanize-PSGI>0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-PSGI \
+ p5-Tiffany>0:${PORTSDIR}/textproc/p5-Tiffany \
+ p5-Plack-Middleware-ReverseProxy>0:${PORTSDIR}/www/p5-Plack-Middleware-ReverseProxy
+
+PERL_MODBUILD= yes
+
+MAN3= Amon2::Lite.3 \
+ Amon2::Setup::Flavor::Lite.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Amon2-Lite/distinfo b/www/p5-Amon2-Lite/distinfo
new file mode 100644
index 000000000000..36ddb12b9b4b
--- /dev/null
+++ b/www/p5-Amon2-Lite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Amon2-Lite-0.09.tar.gz) = 3b10512e834abd5e3c47cc9865ca0139dbebb43d78f05a3046ed9fd75c52080a
+SIZE (Amon2-Lite-0.09.tar.gz) = 22052
diff --git a/www/p5-Amon2-Lite/pkg-descr b/www/p5-Amon2-Lite/pkg-descr
new file mode 100644
index 000000000000..6be8e541df8c
--- /dev/null
+++ b/www/p5-Amon2-Lite/pkg-descr
@@ -0,0 +1,3 @@
+Sinatra-ish framework on Amon2.
+
+WWW: http://search.cpan.org/dist/Amon2-Lite/
diff --git a/www/p5-Amon2-Lite/pkg-plist b/www/p5-Amon2-Lite/pkg-plist
new file mode 100644
index 000000000000..2affb6e971c1
--- /dev/null
+++ b/www/p5-Amon2-Lite/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Amon2/Lite.pm
+%%SITE_PERL%%/Amon2/Setup/Flavor/Lite.pm
+@dirrmtry %%SITE_PERL%%/Amon2/Setup/Flavor