aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-02-15 22:34:26 +0800
committermiwi <miwi@FreeBSD.org>2016-02-15 22:34:26 +0800
commit790e7372b009ecab418d9e694794df6a87b97fce (patch)
tree921070ae859847e6ad2f11168de4014a9c3571e8 /www
parentf8b583cc4f758cfd2ed8b667d74bb0fd222e0392 (diff)
downloadfreebsd-ports-gnome-790e7372b009ecab418d9e694794df6a87b97fce.tar.gz
freebsd-ports-gnome-790e7372b009ecab418d9e694794df6a87b97fce.tar.zst
freebsd-ports-gnome-790e7372b009ecab418d9e694794df6a87b97fce.zip
Welcome php 7.0.3
Changelog: http://php.net/ChangeLog-7.php#7.0.0 http://php.net/ChangeLog-7.php#7.0.1 http://php.net/ChangeLog-7.php#7.0.2 http://php.net/ChangeLog-7.php#7.0.3 I'd like to thanks: Kurt Jaeger Matthias Breddin Rainer Duffner Victor van Vlaardingen Torsten Zuehlsdorff Franco Fichtner and all helpers and testers from ports@.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile4
-rw-r--r--www/mod_php70/Makefile16
-rw-r--r--www/php70-opcache/Makefile12
-rw-r--r--www/php70-session/Makefile10
-rw-r--r--www/php70-tidy/Makefile10
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4a8517f9904a..bb0ee85fb8e9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -491,6 +491,7 @@
SUBDIR += mod_perl2
SUBDIR += mod_php55
SUBDIR += mod_php56
+ SUBDIR += mod_php70
SUBDIR += mod_proctitle
SUBDIR += mod_proxy_html
SUBDIR += mod_proxy_uwsgi
@@ -1445,6 +1446,9 @@
SUBDIR += php56-opcache
SUBDIR += php56-session
SUBDIR += php56-tidy
+ SUBDIR += php70-opcache
+ SUBDIR += php70-session
+ SUBDIR += php70-tidy
SUBDIR += phpbb
SUBDIR += phpbb3
SUBDIR += phpgroupware
diff --git a/www/mod_php70/Makefile b/www/mod_php70/Makefile
new file mode 100644
index 000000000000..504469ea6936
--- /dev/null
+++ b/www/mod_php70/Makefile
@@ -0,0 +1,16 @@
+# Created by: marcus@FreeBSD.org
+# $FreeBSD$
+
+CATEGORIES= www devel
+PKGNAMEPREFIX= mod_
+
+MAINTAINER= miwi@FreeBSD.org
+
+PHP_PORT= lang/php70
+MASTERDIR= ${.CURDIR}/../../${PHP_PORT}
+
+OPTIONS_DEFINE= AP2FILTER
+AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+OPTIONS_EXCLUDE= CGI CLI FPM EMBED
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php70-opcache/Makefile b/www/php70-opcache/Makefile
new file mode 100644
index 000000000000..4a743d8e2206
--- /dev/null
+++ b/www/php70-opcache/Makefile
@@ -0,0 +1,12 @@
+# Created by: Martin Matuska <mm@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -opcache
+
+USE_ZENDEXT= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php70-session/Makefile b/www/php70-session/Makefile
new file mode 100644
index 000000000000..6b20fd0eda6c
--- /dev/null
+++ b/www/php70-session/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -session
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php70-tidy/Makefile b/www/php70-tidy/Makefile
new file mode 100644
index 000000000000..40f6250f1d08
--- /dev/null
+++ b/www/php70-tidy/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php70
+
+PKGNAMESUFFIX= -tidy
+
+.include "${MASTERDIR}/Makefile"