aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-05-31 17:54:18 +0800
committerohauer <ohauer@FreeBSD.org>2014-05-31 17:54:18 +0800
commit7bc4269defa369f35aaf9d803a94dc6b92c26a14 (patch)
treec8a0eb5e0a0dbeb80df658a20272901679d99022 /www
parent0fb7f25483580b87d959d1b6476b46c0c6a12035 (diff)
downloadfreebsd-ports-gnome-7bc4269defa369f35aaf9d803a94dc6b92c26a14.tar.gz
freebsd-ports-gnome-7bc4269defa369f35aaf9d803a94dc6b92c26a14.tar.zst
freebsd-ports-gnome-7bc4269defa369f35aaf9d803a94dc6b92c26a14.zip
- cleanup Makefile
- do not mix pkg-plist and PLIST_(FILES|DIRS|DIRSTRY) - MANx is wrong with staging -> correct PERL5_MAN3 in pkg-plist PR: ports/188875 Submitted by: ohauer Approved by: maintainer timeout (3 weeks)
Diffstat (limited to 'www')
-rw-r--r--www/p5-Apache-Gallery/Makefile15
-rw-r--r--www/p5-Apache-Gallery/pkg-plist33
2 files changed, 19 insertions, 29 deletions
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index aca2efd49f10..2762a03cf78c 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -28,9 +28,6 @@ USES= perl5
USE_PERL5= configure
USE_APACHE= 22+
-PLIST_DIRSTRY+= www/icons
-
-MAN3= Apache::Gallery.3
DOC_FILES= INSTALL LICENSE README TODO UPGRADE
SUB_FILES+= pkg-message
@@ -54,15 +51,7 @@ post-install:
${STAGEDIR}/${DATADIR}/templates/default/
${INSTALL_DATA} ${WRKSRC}/templates/new/* \
${STAGEDIR}/${DATADIR}/templates/new/
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}/${DOCSDIR}/
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}/${DOCSDIR}/
-.endfor
-.endif
-
-.if !defined(BATCH)
- @${CAT} ${PKGMESSAGE}
-.endif
+ @${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}/${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Gallery/pkg-plist b/www/p5-Apache-Gallery/pkg-plist
index 4114039e6e90..9aed0ee71328 100644
--- a/www/p5-Apache-Gallery/pkg-plist
+++ b/www/p5-Apache-Gallery/pkg-plist
@@ -1,6 +1,6 @@
+%%PERL5_MAN3%%/Apache::Gallery.3.gz
%%SITE_PERL%%/Apache/Gallery.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Gallery/.packlist
-%%PERL5_MAN3%%/Apache::Gallery.3.gz
%%DATADIR%%/templates/bright/README
%%DATADIR%%/templates/bright/dircomment.tpl
%%DATADIR%%/templates/bright/directory.tpl
@@ -18,11 +18,11 @@
%%DATADIR%%/templates/bright/nopictureinfo.tpl
%%DATADIR%%/templates/bright/orig.tpl
%%DATADIR%%/templates/bright/picture.tpl
-%%DATADIR%%/templates/bright/scale.tpl
%%DATADIR%%/templates/bright/pictureinfo.tpl
%%DATADIR%%/templates/bright/refresh.tpl
%%DATADIR%%/templates/bright/rss.tpl
%%DATADIR%%/templates/bright/rss_item.tpl
+%%DATADIR%%/templates/bright/scale.tpl
%%DATADIR%%/templates/bright/scaleactive.tpl
%%DATADIR%%/templates/bright/showpicture.tpl
%%DATADIR%%/templates/bright/slideshowisoff.tpl
@@ -43,11 +43,11 @@
%%DATADIR%%/templates/default/nopictureinfo.tpl
%%DATADIR%%/templates/default/orig.tpl
%%DATADIR%%/templates/default/picture.tpl
-%%DATADIR%%/templates/default/scale.tpl
%%DATADIR%%/templates/default/pictureinfo.tpl
%%DATADIR%%/templates/default/refresh.tpl
%%DATADIR%%/templates/default/rss.tpl
%%DATADIR%%/templates/default/rss_item.tpl
+%%DATADIR%%/templates/default/scale.tpl
%%DATADIR%%/templates/default/scaleactive.tpl
%%DATADIR%%/templates/default/showpicture.tpl
%%DATADIR%%/templates/default/slideshowisoff.tpl
@@ -68,15 +68,20 @@
%%DATADIR%%/templates/new/nopictureinfo.tpl
%%DATADIR%%/templates/new/orig.tpl
%%DATADIR%%/templates/new/picture.tpl
-%%DATADIR%%/templates/new/scale.tpl
%%DATADIR%%/templates/new/pictureinfo.tpl
%%DATADIR%%/templates/new/refresh.tpl
%%DATADIR%%/templates/new/rss.tpl
%%DATADIR%%/templates/new/rss_item.tpl
+%%DATADIR%%/templates/new/scale.tpl
%%DATADIR%%/templates/new/scaleactive.tpl
%%DATADIR%%/templates/new/showpicture.tpl
%%DATADIR%%/templates/new/slideshowisoff.tpl
%%DATADIR%%/templates/new/slideshowoff.tpl
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
www/icons/gallery/agfolder.png
www/icons/gallery/application-doc.png
www/icons/gallery/application-pdf.png
@@ -91,18 +96,14 @@ www/icons/gallery/video-mov.png
www/icons/gallery/video-mpeg.png
www/icons/gallery/video-mpg.png
www/icons/gallery/video-wmv.png
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Gallery
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache
-@dirrmtry %%SITE_PERL%%/Apache
-@dirrm %%DATADIR%%/templates/bright
-@dirrm %%DATADIR%%/templates/default
+@dirrm www/icons/gallery
+@dirrmtry www/icons
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/templates/new
+@dirrm %%DATADIR%%/templates/default
+@dirrm %%DATADIR%%/templates/bright
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%
-@dirrm www/icons/gallery
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Gallery
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache
+@dirrmtry %%SITE_PERL%%/Apache