aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-10-15 22:47:41 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-10-15 22:47:41 +0800
commit7ddd91683633973d8099720425f005ea4689e4bd (patch)
tree037157df0fad9965318ded82fa926b3cbbecb5f9 /www
parentcb8dba1185b441c5bd53fff3a77db01833d4d62e (diff)
downloadfreebsd-ports-gnome-7ddd91683633973d8099720425f005ea4689e4bd.tar.gz
freebsd-ports-gnome-7ddd91683633973d8099720425f005ea4689e4bd.tar.zst
freebsd-ports-gnome-7ddd91683633973d8099720425f005ea4689e4bd.zip
Coro cooperative multithread web server.
WWW: http://search.cpan.org/dist/Plack-Server-Coro/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Plack-Server-Coro/Makefile28
-rw-r--r--www/p5-Plack-Server-Coro/distinfo3
-rw-r--r--www/p5-Plack-Server-Coro/pkg-descr3
-rw-r--r--www/p5-Plack-Server-Coro/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ac5e4a6809a4..dd036899a69e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1033,6 +1033,7 @@
SUBDIR += p5-Plack
SUBDIR += p5-Plack-Request
SUBDIR += p5-Plack-Server-AnyEvent
+ SUBDIR += p5-Plack-Server-Coro
SUBDIR += p5-Plack-Server-ReverseHTTP
SUBDIR += p5-Plack-Server-ServerSimple
SUBDIR += p5-PodToHTML
diff --git a/www/p5-Plack-Server-Coro/Makefile b/www/p5-Plack-Server-Coro/Makefile
new file mode 100644
index 000000000000..089a073a3e4c
--- /dev/null
+++ b/www/p5-Plack-Server-Coro/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Plack::Server::Coro
+# Date created: 14 Oct 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Server-Coro
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for Coro cooperative multithread web server
+
+RUN_DEPENDS= \
+ p5-Coro>0:${PORTSDIR}/devel/p5-Coro \
+ p5-Net-Server-Coro>0:${PORTSDIR}/net/p5-Net-Server-Coro \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Server::Coro.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Plack-Server-Coro/distinfo b/www/p5-Plack-Server-Coro/distinfo
new file mode 100644
index 000000000000..22661c9552af
--- /dev/null
+++ b/www/p5-Plack-Server-Coro/distinfo
@@ -0,0 +1,3 @@
+MD5 (Plack-Server-Coro-0.01.tar.gz) = 2b4db435a36e12cbddb9f87fb2c8f676
+SHA256 (Plack-Server-Coro-0.01.tar.gz) = 3a8aa137a05dc30958a0b89306378fe7f24c99ea0c13de7fdc0ce7c6b1a32b73
+SIZE (Plack-Server-Coro-0.01.tar.gz) = 42249
diff --git a/www/p5-Plack-Server-Coro/pkg-descr b/www/p5-Plack-Server-Coro/pkg-descr
new file mode 100644
index 000000000000..c781ee9db2c2
--- /dev/null
+++ b/www/p5-Plack-Server-Coro/pkg-descr
@@ -0,0 +1,3 @@
+Coro cooperative multithread web server.
+
+WWW: http://search.cpan.org/dist/Plack-Server-Coro/
diff --git a/www/p5-Plack-Server-Coro/pkg-plist b/www/p5-Plack-Server-Coro/pkg-plist
new file mode 100644
index 000000000000..6a19f056f7c7
--- /dev/null
+++ b/www/p5-Plack-Server-Coro/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Server/Coro/.packlist
+%%SITE_PERL%%/Plack/Server/Coro.pm
+@dirrmtry %%SITE_PERL%%/Plack/Server
+@dirrmtry %%SITE_PERL%%/Plack
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Server/Coro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack