aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-07-11 23:43:40 +0800
committervanilla <vanilla@FreeBSD.org>2014-07-11 23:43:40 +0800
commit7fb73ab971570c33cbedf01137a9235e703f1338 (patch)
treee812cbf9744953d65e240aa3c4bc16ddf40a304f /www
parent4e87a91d3d08c53fd48319d77f9756f84d2334c7 (diff)
downloadfreebsd-ports-gnome-7fb73ab971570c33cbedf01137a9235e703f1338.tar.gz
freebsd-ports-gnome-7fb73ab971570c33cbedf01137a9235e703f1338.tar.zst
freebsd-ports-gnome-7fb73ab971570c33cbedf01137a9235e703f1338.zip
1: Upgrade to 0.10.29 [1]
2: USES=compiler to handle clang/gcc. PR: ports/191353 Submitted by: amim.knabben[1], me[2] Approved by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/node/Makefile24
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node/files/patch-node_constants.cc20
-rw-r--r--www/node/pkg-plist2
4 files changed, 42 insertions, 8 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 8dc66ea6acef..591b735bceb0 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 0.10.28
+PORTVERSION= 0.10.29
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -14,17 +14,33 @@ LICENSE= MIT
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+USES= gmake compiler
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_PYTHON= 2
-USES= gmake
CONFLICTS= node-0.[02-9][0-9]* node-devel-0.[0-9]*
ONLY_FOR_ARCHS= i386 amd64
-CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} --without-npm
+CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} --without-npm --shared-zlib
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
REINPLACE_ARGS= -i ''
+MAKE_ENV+= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX}
+
+.include <bsd.port.pre.mk>
+.if ${COMPILER_TYPE} == clang
+MAKE_ENV+= LINK=clang++
+CFLAGS+= -Wno-unused-private-field
+.if ${COMPILER_VERSION} >= 33
+CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
+.if ${COMPILER_VERSION} >= 34
+CFLAGS+= -Wno-unused-const-variable
+.endif
+.endif
+.else
+MAKE_ARGS+= strictaliasing=off
+USE_GCC= any
+.endif
post-patch:
@${REINPLACE_CMD} -e '1 s|${SETENV} python|${PYTHON_CMD}|' ${WRKSRC}/configure
@@ -44,4 +60,4 @@ post-install:
@${ECHO_MSG} "Note: If you need npm (Node Package Manager), please install www/npm."
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/node/distinfo b/www/node/distinfo
index e4873eee9e4c..995e95c2966d 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.10.28.tar.gz) = abddc6441e0f208f6ed8a045e0293f713ea7f6dfb2d6a9a2024bf8b1b4617710
-SIZE (node-v0.10.28.tar.gz) = 13554081
+SHA256 (node-v0.10.29.tar.gz) = 47379d01f765f87c1a1498b4e65de30e45201de50334954860d7375a8258b15d
+SIZE (node-v0.10.29.tar.gz) = 13480496
diff --git a/www/node/files/patch-node_constants.cc b/www/node/files/patch-node_constants.cc
new file mode 100644
index 000000000000..e80de00120ff
--- /dev/null
+++ b/www/node/files/patch-node_constants.cc
@@ -0,0 +1,20 @@
+--- src/node_constants.orig 2014-06-24 23:09:52.432840733 -0300
++++ src/node_constants.cc 2014-06-24 10:07:23.406890824 -0300
+@@ -19,13 +19,13 @@
+ // OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
+ // USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-// O_NONBLOCK is not exported unless _XOPEN_SOURCE >= 500.
+-#if defined(_XOPEN_SOURCE) && _XOPEN_SOURCE < 500
+-#undef _XOPEN_SOURCE
++// O_NONBLOCK is not exported unless _XOPEN_SOURCE >= 600.
++#if defined(_XOPEN_SOURCE) && _XOPEN_SOURCE < 600
++# undef _XOPEN_SOURCE
+ #endif
+
+ #if !defined(_XOPEN_SOURCE)
+-#define _XOPEN_SOURCE 500
++# define _XOPEN_SOURCE 600
+ #endif
+
+ #include "node_constants.h"
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index 0f5e70bf14ba..7059d4e79d2b 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -26,8 +26,6 @@ include/node/v8-profiler.h
include/node/v8-testing.h
include/node/v8.h
include/node/v8stdint.h
-include/node/zconf.h
-include/node/zlib.h
lib/node_modules/.keepme
man/man1/node.1.gz
@dirrmtry include/node/openssl