aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-19 18:40:58 +0800
committerJohn Marino <marino@FreeBSD.org>2014-08-19 18:40:58 +0800
commit80d88a60d7ed4531419f51f40fb9aca40b5bcb2c (patch)
tree1f9a121bc5d74377fba73f8f93f23e7661d61138 /www
parent2cd4c4b2389d8c002ab0ec4b874d117f6b0e132b (diff)
downloadfreebsd-ports-gnome-80d88a60d7ed4531419f51f40fb9aca40b5bcb2c.tar.gz
freebsd-ports-gnome-80d88a60d7ed4531419f51f40fb9aca40b5bcb2c.tar.zst
freebsd-ports-gnome-80d88a60d7ed4531419f51f40fb9aca40b5bcb2c.zip
Add new port www/libevhtp
PR: 191979 Submitted by: JingFeng Yan Libevhtp was created as a replacement API for Libevent's current HTTP API. The reality of libevent's http interface is that it was created as a JIT server, meaning the developer never thought of it being used for creating a full-fledged HTTP service. The maintainer is under the impression that the libevent http API was designed almost as an example of what you can do with libevent. It's not Apache in a box, but more and more developers are attempting to use it as such.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/libevhtp/Makefile40
-rw-r--r--www/libevhtp/distinfo2
-rw-r--r--www/libevhtp/pkg-descr9
4 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4a1bafbc6faa..538f9115ca9f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -381,6 +381,7 @@
SUBDIR += libapreq2
SUBDIR += libecap
SUBDIR += libepc
+ SUBDIR += libevhtp
SUBDIR += libgtkhtml
SUBDIR += libhpack
SUBDIR += libhtp-suricata
diff --git a/www/libevhtp/Makefile b/www/libevhtp/Makefile
new file mode 100644
index 000000000000..f97138c159b1
--- /dev/null
+++ b/www/libevhtp/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= libevhtp
+PORTVERSION= 1.2.9
+CATEGORIES= www
+
+MAINTAINER= yan_jingfeng@yahoo.com
+COMMENT= Flexible replacement for libevent httpd API
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
+
+USE_GITHUB= yes
+GH_ACCOUNT= ellzey
+GH_PROJECT= libevhtp
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 3886506
+
+USES= cmake:outsource
+
+CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:PATH=include/event2 \
+ -DCMAKE_LIBRARY_PATH:PATH=lib/event2
+CMAKE_BUILD_TYPE= Release
+
+PLIST_FILES= include/evhtp.h\
+ include/evhtp-config.h \
+ include/evthr.h \
+ include/htparse.h \
+ include/onigposix.h \
+ lib/libevhtp.a
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
+BROKEN= Does not build on FreeBSD 8.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/libevhtp/distinfo b/www/libevhtp/distinfo
new file mode 100644
index 000000000000..269707521edc
--- /dev/null
+++ b/www/libevhtp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libevhtp-1.2.9.tar.gz) = d980d6eb0d6fd5ee2d1123a997364c82413f6b22bd22ee2347bae2150bd435a4
+SIZE (libevhtp-1.2.9.tar.gz) = 360769
diff --git a/www/libevhtp/pkg-descr b/www/libevhtp/pkg-descr
new file mode 100644
index 000000000000..a4ad1d70740a
--- /dev/null
+++ b/www/libevhtp/pkg-descr
@@ -0,0 +1,9 @@
+Libevhtp was created as a replacement API for Libevent's current HTTP API.
+The reality of libevent's http interface is that it was created as a JIT
+server, meaning the developer never thought of it being used for creating a
+full-fledged HTTP service. The maintainer is under the impression that the
+libevent http API was designed almost as an example of what you can do with
+libevent. It's not Apache in a box, but more and more developers are
+attempting to use it as such.
+
+WWW: https://github.com/ellzey/libevhtp