aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-09-21 09:51:25 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-09-21 09:51:25 +0800
commit826395acd1c0ea0d430c5f74877572eda3852d48 (patch)
tree21427a937cbf64cf62f70280e69fed56fab1520d /www
parent752eea572d822eb69401cb02b7d67a079f799205 (diff)
downloadfreebsd-ports-gnome-826395acd1c0ea0d430c5f74877572eda3852d48.tar.gz
freebsd-ports-gnome-826395acd1c0ea0d430c5f74877572eda3852d48.tar.zst
freebsd-ports-gnome-826395acd1c0ea0d430c5f74877572eda3852d48.zip
www/squid: security update and build fix
- security update 3.5.8 -> 3.5.9 [1] - Fix TP_IPF build on FreeBSD 9 [2] PR: 203186 [1] PR: 202950 [2] Approved by: Pavel Timofeev <timp87@gmail.com> (maintainer) [1] Security: d3a98c2d-5da1-11e5-9909-002590263bf5 MFH: 2015Q3 X-MFH-With: r391555, r392222, r393602, r396106, r396185, r397215
Diffstat (limited to 'www')
-rw-r--r--www/squid/Makefile3
-rw-r--r--www/squid/distinfo4
-rw-r--r--www/squid/files/patch-src__ip__Intercept.cc2
3 files changed, 4 insertions, 5 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 387b4fb4b45d..689f237cca89 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= squid
-PORTVERSION= 3.5.8
-PORTREVISION= 2
+PORTVERSION= 3.5.9
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
http://www2.us.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 11ad75a48766..f9580160463e 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -1,2 +1,2 @@
-SHA256 (squid3.5/squid-3.5.8.tar.xz) = f402a21d4fae8b3e9df13683dc530366e4b1753df21e91c05a0a9514a1abfc62
-SIZE (squid3.5/squid-3.5.8.tar.xz) = 2295644
+SHA256 (squid3.5/squid-3.5.9.tar.xz) = 9e9a3dc16e6f97258f2c3589dc6163bec20fb9369aec1fe03612dbca76d185d3
+SIZE (squid3.5/squid-3.5.9.tar.xz) = 2296384
diff --git a/www/squid/files/patch-src__ip__Intercept.cc b/www/squid/files/patch-src__ip__Intercept.cc
index 74d72b63a1b2..818192542317 100644
--- a/www/squid/files/patch-src__ip__Intercept.cc
+++ b/www/squid/files/patch-src__ip__Intercept.cc
@@ -9,7 +9,7 @@
static int warningLevel = DBG_CRITICAL;
debugs(89, warningLevel, "IPF (IPFilter v4) NAT does not support IPv6. Please upgrade to IPFilter v5.1");
- warningLevel = ++warningLevel % 10;
-+ warningLevel = ++warningLevel % 1048576;
++ warningLevel = (warningLevel + 1) % 1048576;
return false;
#else
natLookup.nl_v = 6;