aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-09-26 19:40:27 +0800
committerolgeni <olgeni@FreeBSD.org>2015-09-26 19:40:27 +0800
commit85e5be9c13651cf5a95b61ca018105254da8ad75 (patch)
tree6bad85777191958f94e3ab2995b8e959ed196c84 /www
parentbbb9824817fa09a9eee5129e57c75e27d263af31 (diff)
downloadfreebsd-ports-gnome-85e5be9c13651cf5a95b61ca018105254da8ad75.tar.gz
freebsd-ports-gnome-85e5be9c13651cf5a95b61ca018105254da8ad75.tar.zst
freebsd-ports-gnome-85e5be9c13651cf5a95b61ca018105254da8ad75.zip
Fix dependencies for Elixir 1.1.
Diffstat (limited to 'www')
-rw-r--r--www/elixir-joken/Makefile1
-rw-r--r--www/elixir-joken/files/patch-mix.exs10
-rw-r--r--www/elixir-webassembly/Makefile1
-rw-r--r--www/elixir-webassembly/files/patch-mix.exs21
4 files changed, 18 insertions, 15 deletions
diff --git a/www/elixir-joken/Makefile b/www/elixir-joken/Makefile
index 3d47c6363c31..c510defd8a91 100644
--- a/www/elixir-joken/Makefile
+++ b/www/elixir-joken/Makefile
@@ -3,6 +3,7 @@
PORTNAME= joken
PORTVERSION= 0.15.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= elixir-
diff --git a/www/elixir-joken/files/patch-mix.exs b/www/elixir-joken/files/patch-mix.exs
index 95cdeb51d3ec..dd527fc9435c 100644
--- a/www/elixir-joken/files/patch-mix.exs
+++ b/www/elixir-joken/files/patch-mix.exs
@@ -1,8 +1,10 @@
---- mix.exs.orig 2015-07-08 12:15:58 UTC
+--- mix.exs.orig 2015-07-13 13:00:06 UTC
+++ mix.exs
-@@ -6,8 +6,7 @@ defmodule Joken.Mixfile do
- version: "0.14.1",
- elixir: "~> 1.0.0",
+@@ -4,10 +4,8 @@ defmodule Joken.Mixfile do
+ def project do
+ [app: :joken,
+ version: "0.15.0",
+- elixir: "~> 1.0.0",
description: description,
- package: package,
- deps: deps]
diff --git a/www/elixir-webassembly/Makefile b/www/elixir-webassembly/Makefile
index 53f96bf0a3b8..039944a7bcdd 100644
--- a/www/elixir-webassembly/Makefile
+++ b/www/elixir-webassembly/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webassembly
PORTVERSION= 0.5.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= elixir-
diff --git a/www/elixir-webassembly/files/patch-mix.exs b/www/elixir-webassembly/files/patch-mix.exs
index aa00830ca6ea..036b7c6beb94 100644
--- a/www/elixir-webassembly/files/patch-mix.exs
+++ b/www/elixir-webassembly/files/patch-mix.exs
@@ -1,12 +1,11 @@
---- mix.exs.orig 2015-07-03 10:57:27 UTC
+--- mix.exs.orig 2015-09-26 08:21:42 UTC
+++ mix.exs
-@@ -18,9 +18,6 @@ defmodule WebAssembly.Mixfile do
- end
-
- defp deps, do: [
-- {:excoveralls, "== 0.3.6", only: :test},
-- {:ex_doc, "~> 0.7.1", only: :dev},
-- {:dialyze, "== 0.1.3", only: :dev},
- ]
-
- defp description do
+@@ -5,8 +5,6 @@ defmodule WebAssembly.Mixfile do
+ [app: :webassembly,
+ docs: [main: WebAssembly],
+ version: "0.5.1",
+- elixir: "~> 1.0.0",
+- deps: deps,
+ description: description,
+ package: package,
+ test_coverage: [tool: ExCoveralls]]