aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2011-01-12 09:16:19 +0800
committerbrooks <brooks@FreeBSD.org>2011-01-12 09:16:19 +0800
commit86583203b95a41de1d64db95fbb439670ea50f7b (patch)
treea57ec06c0e3e3e93af5293a59fec5665d44279b1 /www
parenta6939e86a2ff2345a695bab422f9e7a12756f6eb (diff)
downloadfreebsd-ports-gnome-86583203b95a41de1d64db95fbb439670ea50f7b.tar.gz
freebsd-ports-gnome-86583203b95a41de1d64db95fbb439670ea50f7b.tar.zst
freebsd-ports-gnome-86583203b95a41de1d64db95fbb439670ea50f7b.zip
Stop using the deprecated sha module. Instead use hashlib. Since
hashlib was introduced in 2.5, change the USE_PYTHON setting to require it. Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/trac-graphviz/Makefile4
-rw-r--r--www/trac-graphviz/files/patch-graphviz_graphviz.py22
2 files changed, 24 insertions, 2 deletions
diff --git a/www/trac-graphviz/Makefile b/www/trac-graphviz/Makefile
index 9d09ce9e6317..6a550a719a08 100644
--- a/www/trac-graphviz/Makefile
+++ b/www/trac-graphviz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
PORTVERSION= 0.7.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www devel graphics python
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -22,7 +22,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/URW/fonts.dir:${PORTSDIR}/x11-fonts/urw
tracd:${PORTSDIR}/www/trac
BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
-USE_PYTHON= yes
+USE_PYTHON= 2.5+
NO_BUILD= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= graphviz
diff --git a/www/trac-graphviz/files/patch-graphviz_graphviz.py b/www/trac-graphviz/files/patch-graphviz_graphviz.py
index cb8cc3469d4b..acc7878a3989 100644
--- a/www/trac-graphviz/files/patch-graphviz_graphviz.py
+++ b/www/trac-graphviz/files/patch-graphviz_graphviz.py
@@ -3,6 +3,19 @@ $FreeBSD$
--- graphviz/graphviz.py.orig
+++ graphviz/graphviz.py
+@@ -16,11 +16,11 @@
+ __version__ = '0.7.2'
+
+
++import hashlib
+ import inspect
+ import locale
+ import os
+ import re
+-import sha
+ import subprocess
+ import sys
+
@@ -59,10 +59,7 @@
'c:\\Program Files\\ATT\\Graphviz\\bin',
],
@@ -15,3 +28,12 @@ $FreeBSD$
],
'darwin': ['/opt/local/bin',
+@@ -312,7 +309,7 @@
+ encoded_cmd = (processor + unicode(self.processor_options)) \
+ .encode(self.encoding)
+ encoded_content = content.encode(self.encoding)
+- sha_key = sha.new(encoded_cmd + encoded_content).hexdigest()
++ sha_key = hashlib.sha1(encoded_cmd + encoded_content).hexdigest()
+ img_name = '%s.%s.%s' % (sha_key, processor, out_format)
+ # cache: hash.<dot>.<png>
+ img_path = os.path.join(self.cache_dir, img_name)