aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2017-01-01 03:51:34 +0800
committeradamw <adamw@FreeBSD.org>2017-01-01 03:51:34 +0800
commit879853ef7ad88ca7155996a7f25038b418ce3764 (patch)
tree806c8bf5953aa6382a19618cd3e756386bdbf5cb /www
parent990a12edb8c95236362bee3ffed8eaa96b6d33c9 (diff)
downloadfreebsd-ports-gnome-879853ef7ad88ca7155996a7f25038b418ce3764.tar.gz
freebsd-ports-gnome-879853ef7ad88ca7155996a7f25038b418ce3764.tar.zst
freebsd-ports-gnome-879853ef7ad88ca7155996a7f25038b418ce3764.zip
Purge checks for perl < 5.20. For p5-Net, remove the IPV6 knob which only
affected 5.18 and lower.
Diffstat (limited to 'www')
-rw-r--r--www/p5-Catalyst-Action-REST/Makefile10
-rw-r--r--www/p5-HTML-FormHandler/Makefile9
-rw-r--r--www/p5-Mojolicious-Plugin-SetUserGroup/Makefile9
-rw-r--r--www/p5-WWW-Scraper-ISBN/Makefile12
4 files changed, 8 insertions, 32 deletions
diff --git a/www/p5-Catalyst-Action-REST/Makefile b/www/p5-Catalyst-Action-REST/Makefile
index f4d2f2a15ed7..419c3e9d2232 100644
--- a/www/p5-Catalyst-Action-REST/Makefile
+++ b/www/p5-Catalyst-Action-REST/Makefile
@@ -16,6 +16,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Catalyst-Runtime>=5.80030:www/p5-Catalyst-Runtime \
p5-Class-Inspector>=1.13:devel/p5-Class-Inspector \
p5-MRO-Compat>=0.10:devel/p5-MRO-Compat \
+ p5-Module-Pluggable>=0:devel/p5-Module-Pluggable \
p5-Moose>=1.03:devel/p5-Moose \
p5-Params-Validate>=0.76:devel/p5-Params-Validate \
p5-URI-Find>=0:textproc/p5-URI-Find \
@@ -30,11 +31,4 @@ CONFIGURE_ARGS= --default
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-FormHandler/Makefile b/www/p5-HTML-FormHandler/Makefile
index d40ce73e8d8f..466b81b6292c 100644
--- a/www/p5-HTML-FormHandler/Makefile
+++ b/www/p5-HTML-FormHandler/Makefile
@@ -50,11 +50,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile b/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile
index 4962c9a1ab4a..fde0b03fe091 100644
--- a/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile
+++ b/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile
@@ -22,11 +22,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= modbuildtiny
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Scraper-ISBN/Makefile b/www/p5-WWW-Scraper-ISBN/Makefile
index be5daf1ef704..7c4416dfb607 100644
--- a/www/p5-WWW-Scraper-ISBN/Makefile
+++ b/www/p5-WWW-Scraper-ISBN/Makefile
@@ -12,16 +12,12 @@ COMMENT= Retrieving information about books by ISBN number
LICENSE= ART20
+BUILD_DEPENDS= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
+RUN_DEPENDS= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
+
CONFLICTS_INSTALL= p5-WWW-Scraper-ISBN-Driver-[0-9]* p5-WWW-Scraper-ISBN-Record-[0-9]*
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>