aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-05-16 01:51:48 +0800
committerMatthew Seaman <matthew@FreeBSD.org>2016-05-16 01:51:48 +0800
commit88a81fc41d43219bf72caf0842f4a9f3f8598615 (patch)
treec3e90bcc61a25ae8a99aa8513f9edd229530593b /www
parentfc7412e71aa5c0fde854385c8e3687376a834ce4 (diff)
downloadfreebsd-ports-gnome-88a81fc41d43219bf72caf0842f4a9f3f8598615.tar.gz
freebsd-ports-gnome-88a81fc41d43219bf72caf0842f4a9f3f8598615.tar.zst
freebsd-ports-gnome-88a81fc41d43219bf72caf0842f4a9f3f8598615.zip
Graphite-API
This is a minimalistic API server that replicates the behavior of Graphite-web, pruned and simplified as much code as possible while keeping the basic functionality. WWW: https://github.com/brutasse/graphite-api PR: 208890 Submitted by: Dave Cottlehuber <dch@skunkwerks.at>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-graphite-api/Makefile29
-rw-r--r--www/py-graphite-api/distinfo2
-rw-r--r--www/py-graphite-api/pkg-descr7
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8ecf5866d995..161d93d79e4a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1636,6 +1636,7 @@
SUBDIR += py-goobook
SUBDIR += py-google
SUBDIR += py-google-api-python-client
+ SUBDIR += py-graphite-api
SUBDIR += py-graphite-web
SUBDIR += py-grequests
SUBDIR += py-gunicorn
diff --git a/www/py-graphite-api/Makefile b/www/py-graphite-api/Makefile
new file mode 100644
index 000000000000..3ca7efa429c1
--- /dev/null
+++ b/www/py-graphite-api/Makefile
@@ -0,0 +1,29 @@
+# Created by: Dave Cottlehuber <dch@skunkwerks.at>
+# $FreeBSD$
+
+PORTNAME= graphite-api
+PORTVERSION= 1.1.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dch@skunkwerks.at
+COMMENT= Graphite-web, without the interface - just the rendering HTTP API
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}Flask>=0.10.1:www/py-flask \
+ ${PYTHON_PKGNAMEPREFIX}Flask-Cache>=0.13.1:www/py-flask-cache \
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>=1.1.1:devel/py-tzlocal \
+ ${PYTHON_PKGNAMEPREFIX}structlog>=16.0.0:devel/py-structlog \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.0:devel/py-pyparsing \
+ ${PYTHON_PKGNAMEPREFIX}yaml>3.1:devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}cairocffi>=0.7.2:graphics/py-cairocffi \
+ ${PYTHON_PKGNAMEPREFIX}gunicorn>=19.4.1:www/py-gunicorn \
+ xorg-fonts-truetype>=0:x11-fonts/xorg-fonts-truetype
+
+USES= python
+USE_PYTHON= autoplist distutils
+.include <bsd.port.mk>
diff --git a/www/py-graphite-api/distinfo b/www/py-graphite-api/distinfo
new file mode 100644
index 000000000000..d0ea1b108ac3
--- /dev/null
+++ b/www/py-graphite-api/distinfo
@@ -0,0 +1,2 @@
+SHA256 (graphite-api-1.1.2.tar.gz) = bfd112cdc7ef1812429afc8b481bda38fb12d85bbabdd098be2c60e55cce1cca
+SIZE (graphite-api-1.1.2.tar.gz) = 74846
diff --git a/www/py-graphite-api/pkg-descr b/www/py-graphite-api/pkg-descr
new file mode 100644
index 000000000000..6f52618d3945
--- /dev/null
+++ b/www/py-graphite-api/pkg-descr
@@ -0,0 +1,7 @@
+Graphite-API
+
+This is a minimalistic API server that replicates the behavior of Graphite-web,
+pruned and simplified as much code as possible while keeping the basic
+functionality.
+
+WWW: https://github.com/brutasse/graphite-api