aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-30 20:19:00 +0800
committerbapt <bapt@FreeBSD.org>2013-04-30 20:19:00 +0800
commit88e2a289c1338334e9743551551e3dab5d96db87 (patch)
tree8b1e561e1226dd8c9952d61705c98f64f70ec6b4 /www
parent110962df25fd09deea1a81577140990bd9b16737 (diff)
downloadfreebsd-ports-gnome-88e2a289c1338334e9743551551e3dab5d96db87.tar.gz
freebsd-ports-gnome-88e2a289c1338334e9743551551e3dab5d96db87.tar.zst
freebsd-ports-gnome-88e2a289c1338334e9743551551e3dab5d96db87.zip
Split demos out of www/aws:
Comment out 2 demos that doesn't build LDAP demo now builds SSL demos are now switched properly Supports USES+= ada PR: ports/178164 Submitted by: John Marino <draco@marino.st>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/aws-demos/Makefile99
-rw-r--r--www/aws-demos/distinfo2
-rw-r--r--www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr11
-rw-r--r--www/aws-demos/pkg-descr4
-rw-r--r--www/aws-demos/pkg-plist34
6 files changed, 151 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 584564fa9dfa..a8e3920cf53f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -42,6 +42,7 @@
SUBDIR += autoindex2
SUBDIR += awffull
SUBDIR += aws
+ SUBDIR += aws-demos
SUBDIR += awstats
SUBDIR += axis
SUBDIR += axis2
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
new file mode 100644
index 000000000000..c83d51884b25
--- /dev/null
+++ b/www/aws-demos/Makefile
@@ -0,0 +1,99 @@
+# Created by: John Marino <draco@marino.st>
+# $FreeBSD$
+
+PORTNAME= aws
+PORTVERSION= 2.10.0
+CATEGORIES= www
+MASTER_SITES= http://downloads.dragonlace.net/src/
+PKGNAMESUFFIX= -demos
+
+MAINTAINER= draco@marino.st
+COMMENT= Adacore Ada Web Server demos
+
+BUILD_DEPENDS+= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
+ xmlada>=3.2:${PORTSDIR}/textproc/xmlada \
+ aws>=2.10:${PORTSDIR}/www/aws
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USES+= ada
+
+CONF_ARGS= PROCESSORS=1
+CONF_ARGS+= GCC=ada
+CONF_ARGS+= prefix=${PREFIX}
+
+OPTIONS_DEFINE= SSL LDAP
+OPTIONS_DEFAULT= SSL
+
+DEMO_DIRS+= auth
+DEMO_DIRS+= com
+DEMO_DIRS+= dispatch
+DEMO_DIRS+= hello_world
+DEMO_DIRS+= hotplug
+DEMO_DIRS+= jabber_demo
+DEMO_DIRS+= multiple_sessions
+DEMO_DIRS+= res_demo
+DEMO_DIRS+= soap_demo
+DEMO_DIRS+= soap_disp
+DEMO_DIRS+= soap_vs
+DEMO_DIRS+= split
+DEMO_DIRS+= test_mail
+DEMO_DIRS+= text_input
+DEMO_DIRS+= vh_demo
+DEMO_DIRS+= web_block
+DEMO_DIRS+= web_block_ajax
+DEMO_DIRS+= web_block_ajax_templates
+DEMO_DIRS+= web_elements
+DEMO_DIRS+= web_mail
+DEMO_DIRS+= wps
+DEMO_DIRS+= ws
+DEMO_DIRS+= zdemo
+
+# These don't build, fail finding "aws.ini"
+#DEMO_DIRS+= hello_wsdl
+#DEMO_DIRS+= interoplab
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSSL}
+CONF_ARGS+= SOCKET=openssl
+DEMO_DIRS+= agent
+DEMO_DIRS+= runme
+PLIST_SUB+= OSSL=""
+.else
+PLIST_SUB+= OSSL="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+CONF_ARGS+= LDAP=true
+DEMO_DIRS+= test_ldap
+PLIST_SUB+= LDAP=""
+.else
+PLIST_SUB+= LDAP="@comment "
+.endif
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@PREFIX@|${LOCALBASE}|g' \
+ ${WRKSRC}/demos/test_ldap/test_ldap.gpr
+
+do-configure:
+ ${MKDIR} ${WRKSRC}/.build/native/debug/static/obj
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${GMAKE} setup ${CONF_ARGS}
+
+do-build:
+.for dd in ${DEMO_DIRS}
+ @${ECHO_MSG} "=== BUILD ${dd} ==="
+ cd ${WRKSRC}/demos/${dd} && ${SETENV} ${MAKE_ENV} ${GMAKE}
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/examples/aws-demos
+.for dd in ${DEMO_DIRS}
+ ${FIND} ${WRKSRC}/demos/${dd} -type f -perm -0001 \
+ -exec ${INSTALL} {} ${PREFIX}/share/examples/aws-demos/ \;
+.endfor
+
+.include <bsd.port.mk>
diff --git a/www/aws-demos/distinfo b/www/aws-demos/distinfo
new file mode 100644
index 000000000000..b7a68021ea44
--- /dev/null
+++ b/www/aws-demos/distinfo
@@ -0,0 +1,2 @@
+SHA256 (aws-2.10.0.tar.bz2) = 010244129cc736d1ca415162dca79243fb243c3f0b12371a0ffc8a31c8b42f30
+SIZE (aws-2.10.0.tar.bz2) = 1384976
diff --git a/www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr b/www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr
new file mode 100644
index 000000000000..cbc1ea411623
--- /dev/null
+++ b/www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr
@@ -0,0 +1,11 @@
+--- demos/test_ldap/test_ldap.gpr.orig 2013-04-25 23:03:26.000000000 +0200
++++ demos/test_ldap/test_ldap.gpr 2013-04-25 23:03:52.000000000 +0200
+@@ -42,7 +42,7 @@
+ when "Windows_NT" =>
+ for Default_Switches ("Ada") use ("-lwldap32");
+ when others =>
+- for Default_Switches ("Ada") use ("-lldap");
++ for Default_Switches ("Ada") use ("-L@PREFIX@/lib", "-lldap");
+ end case;
+ end Linker;
+
diff --git a/www/aws-demos/pkg-descr b/www/aws-demos/pkg-descr
new file mode 100644
index 000000000000..87a478d4c111
--- /dev/null
+++ b/www/aws-demos/pkg-descr
@@ -0,0 +1,4 @@
+This is a collection of demonstrations for the Ada Web Server. The server
+itself is located at www/aws.
+
+WWW: http://libre.adacore.com/libre/tools/aws/
diff --git a/www/aws-demos/pkg-plist b/www/aws-demos/pkg-plist
new file mode 100644
index 000000000000..5d8efcbd1b39
--- /dev/null
+++ b/www/aws-demos/pkg-plist
@@ -0,0 +1,34 @@
+%%OSSL%%%%EXAMPLESDIR%%/agent
+%%EXAMPLESDIR%%/auth
+%%EXAMPLESDIR%%/com_1
+%%EXAMPLESDIR%%/com_2
+%%EXAMPLESDIR%%/dispatch
+%%EXAMPLESDIR%%/hello_world
+%%EXAMPLESDIR%%/hotplug
+@comment broken %%EXAMPLESDIR%%/interoplab_main
+%%EXAMPLESDIR%%/jabber_demo
+%%EXAMPLESDIR%%/main
+%%EXAMPLESDIR%%/multiple_sessions
+%%EXAMPLESDIR%%/res_demo
+%%OSSL%%%%EXAMPLESDIR%%/runme
+%%EXAMPLESDIR%%/soap_client
+%%EXAMPLESDIR%%/soap_cvs
+%%EXAMPLESDIR%%/soap_server
+%%EXAMPLESDIR%%/soap_server_disp
+%%EXAMPLESDIR%%/soap_svs
+%%EXAMPLESDIR%%/split
+%%LDAP%%%%EXAMPLESDIR%%/test_ldap
+%%EXAMPLESDIR%%/test_mail
+%%EXAMPLESDIR%%/text_input
+%%EXAMPLESDIR%%/vh_demo
+%%EXAMPLESDIR%%/web_block
+%%EXAMPLESDIR%%/web_block_ajax
+%%EXAMPLESDIR%%/web_block_ajax_templates
+%%EXAMPLESDIR%%/web_elements
+%%EXAMPLESDIR%%/web_mail
+%%EXAMPLESDIR%%/wps
+%%EXAMPLESDIR%%/ws
+@comment broken %%EXAMPLESDIR%%/wsdl_demo_client
+@comment broken %%EXAMPLESDIR%%/wsdl_demo_server
+%%EXAMPLESDIR%%/zdemo
+@dirrmtry %%EXAMPLESDIR%%