aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-12-23 12:34:44 +0800
committerKubilay Kocak <koobs@FreeBSD.org>2014-12-23 12:34:44 +0800
commit89c64b4445d8e13720bd832ebe990f3e9aae005c (patch)
treea4de79c71935b13a484bf87ac555bd206345f2a7 /www
parent29ddb35e4be4b8aabc2eea6fed20ab29e781b7b2 (diff)
downloadfreebsd-ports-gnome-89c64b4445d8e13720bd832ebe990f3e9aae005c.tar.gz
freebsd-ports-gnome-89c64b4445d8e13720bd832ebe990f3e9aae005c.tar.zst
freebsd-ports-gnome-89c64b4445d8e13720bd832ebe990f3e9aae005c.zip
www/py-grequests: Add TESTS option, Modernize
- Add TESTS option - Add LICENSE_FILE - Switch to the modern Python world order (USES) - Update regression-test target
Diffstat (limited to 'www')
-rw-r--r--www/py-grequests/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/www/py-grequests/Makefile b/www/py-grequests/Makefile
index 0f16b19dcf65..d5e8910b136a 100644
--- a/www/py-grequests/Makefile
+++ b/www/py-grequests/Makefile
@@ -11,22 +11,27 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Requests with Gevent to make asyncronous HTTP requests
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gevent>0:${PORTSDIR}/devel/py-gevent \
${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:${PORTSDIR}/www/py-requests
TEST_DEPENDS:= ${RUN_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+OPTIONS_DEFINE= TESTS
+
+TESTS_DESC= Install test suite requirements
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
USE_GITHUB= yes
GH_ACCOUNT= kennethreitz
GH_TAGNAME= v${DISTVERSION}
GH_COMMIT= aee3be6
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= autoplist distutils
regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>