aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-10-06 22:05:16 +0800
committerwen <wen@FreeBSD.org>2012-10-06 22:05:16 +0800
commit8af447d7ac082fd3d9fc148b4e3d0447a1b571de (patch)
treea8c27ad89028c73c6fecdfcc9631894926f3a0bd /www
parent63374f2d88f110288ee2ea03f30113c22ceae561 (diff)
downloadfreebsd-ports-gnome-8af447d7ac082fd3d9fc148b4e3d0447a1b571de.tar.gz
freebsd-ports-gnome-8af447d7ac082fd3d9fc148b4e3d0447a1b571de.tar.zst
freebsd-ports-gnome-8af447d7ac082fd3d9fc148b4e3d0447a1b571de.zip
- Convert to new Makefile format
- Convert to new options framework
Diffstat (limited to 'www')
-rw-r--r--www/moodle2/Makefile29
1 files changed, 12 insertions, 17 deletions
diff --git a/www/moodle2/Makefile b/www/moodle2/Makefile
index 9e51909ceb88..8b5913841dbe 100644
--- a/www/moodle2/Makefile
+++ b/www/moodle2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: moodle
-# Date created: 30 September 2005
-# Whom: Javier Martin Rueda <jmrueda@diatel.upm.es>
-#
+# Created by: Javier Martin Rueda <jmrueda@diatel.upm.es>
# $FreeBSD$
-#
PORTNAME= moodle
PORTVERSION= 2.3.2
@@ -24,31 +20,30 @@ USE_PHP= session gd pcre mbstring iconv tokenizer curl xml xmlrpc ctype \
soap openssl simplexml spl dom json zip zlib hash
WRKSRC= ${WRKDIR}/moodle
-OPTIONS= MYSQL "Add support for a MySQL database server" On \
- PGSQL "Add support for a PostgreSQL database server" Off \
- MSSQL "Add support for a MS SQL Server" Off \
- LDAP "Add LDAP authentication functionality" Off \
- MIMETEX "Add mimeTeX filter functionality" Off
+OPTIONS_DEFINE= MYSQL PGSQL MSSQL LDAP MIMETEX
+OPTIONS_DEFAULT=MYSQL
+MSSQL_DESCR= MS SQL Server support
+MIMETEX_DESCR= mimeTeX filter functionality support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysqli
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.if defined(WITH_MSSQL)
+.if ${PORT_OPTIONS:MMSSQL}
USE_PHP+= mssql
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_PHP+= ldap
.endif
-.if defined(WITH_MIMETEX)
+.if ${PORT_OPTIONS:MMIMETEX}
RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
.endif
@@ -87,4 +82,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>