aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2018-07-24 01:26:35 +0800
committergblach <gblach@FreeBSD.org>2018-07-24 01:26:35 +0800
commit9098f6a3e87550f9decd36c1ec5fc06799557ccb (patch)
tree7f78ba2a14ba8620f63312ffc6136b8fc89c7da4 /www
parent4c6f625b7e616673ef24258ad067fc2fba98a9b1 (diff)
downloadfreebsd-ports-gnome-9098f6a3e87550f9decd36c1ec5fc06799557ccb.tar.gz
freebsd-ports-gnome-9098f6a3e87550f9decd36c1ec5fc06799557ccb.tar.zst
freebsd-ports-gnome-9098f6a3e87550f9decd36c1ec5fc06799557ccb.zip
Add devel/py-futures to RUN_DEPENDS when python is older than 3.2
PR: 229984 Submitted by: jrm
Diffstat (limited to 'www')
-rw-r--r--www/py-tornado/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/py-tornado/Makefile b/www/py-tornado/Makefile
index dcbad25e3b5e..091d04ff054d 100644
--- a/www/py-tornado/Makefile
+++ b/www/py-tornado/Makefile
@@ -19,6 +19,10 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
+.if ${PYTHON_REL} < 3200
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures@${PY_FLAVOR}
+.endif
+
.if ${PYTHON_REL} < 3400
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>0:devel/py-singledispatch@${PY_FLAVOR}
.endif