aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2013-08-06 15:28:00 +0800
committerwen <wen@FreeBSD.org>2013-08-06 15:28:00 +0800
commit90c946987fa6b25193580894ea3f1d308a9e7914 (patch)
tree2f886f1b77cf3f5ee8fd7a9d65d11bfb7b6fecc5 /www
parent35710c4f25cfc2d71cfa4eccdfc5f923db105875 (diff)
downloadfreebsd-ports-gnome-90c946987fa6b25193580894ea3f1d308a9e7914.tar.gz
freebsd-ports-gnome-90c946987fa6b25193580894ea3f1d308a9e7914.tar.zst
freebsd-ports-gnome-90c946987fa6b25193580894ea3f1d308a9e7914.zip
Dancer2 is the new generation of Dancer, the lightweight web-framework for
Perl. Dancer2 is a complete rewrite based on Moo. WWW: http://search.cpan.org/dist/Dancer2/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer2/Makefile112
-rw-r--r--www/p5-Dancer2/distinfo2
-rw-r--r--www/p5-Dancer2/pkg-descr4
-rw-r--r--www/p5-Dancer2/pkg-plist80
5 files changed, 199 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a035c066babb..321f8f1eeefb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -855,6 +855,7 @@
SUBDIR += p5-Dancer-Plugin-ValidationClass
SUBDIR += p5-Dancer-Session-Cookie
SUBDIR += p5-Dancer-Template-Xslate
+ SUBDIR += p5-Dancer2
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-Emplacken
diff --git a/www/p5-Dancer2/Makefile b/www/p5-Dancer2/Makefile
new file mode 100644
index 000000000000..e6ca1652fee1
--- /dev/null
+++ b/www/p5-Dancer2/Makefile
@@ -0,0 +1,112 @@
+# Created by: Wen Heping <wen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Dancer2
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Lightweight yet powerful web application framework
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= \
+ p5-Capture-Tiny>=0.12:${PORTSDIR}/devel/p5-Capture-Tiny \
+ p5-Crypt-URandom>0:${PORTSDIR}/security/p5-Crypt-URandom \
+ p5-Config-Any>=0:${PORTSDIR}/devel/p5-Config-Any \
+ p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-Hash-Merge-Simple>=0:${PORTSDIR}/devel/p5-Hash-Merge-Simple \
+ p5-HTTP-Body>=0:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-Date>=0:${PORTSDIR}/www/p5-HTTP-Date \
+ p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-HTTP-Server-Simple-PSGI>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple-PSGI \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-MIME-Types>=0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-Moo>=0.09014:${PORTSDIR}/devel/p5-Moo \
+ p5-MooX-Types-MooseLike-Numeric>=0:${PORTSDIR}/devel/p5-MooX-Types-MooseLike-Numeric \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Plack>=0:${PORTSDIR}/www/p5-Plack \
+ p5-Template-Tiny>=0:${PORTSDIR}/textproc/p5-Template-Tiny \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-URI-Escape-XS>=0:${PORTSDIR}/www/p5-URI-Escape-XS \
+ p5-YAML>=0.71:${PORTSDIR}/textproc/p5-YAML \
+ p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Test-MockTime>=0:${PORTSDIR}/devel/p5-Test-MockTime \
+ p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP \
+
+PERL_CONFIGURE= yes
+
+MAN1= dancer2.1
+MAN3= Dancer2.3 \
+ Dancer2::Config.3 \
+ Dancer2::Cookbook.3 \
+ Dancer2::Core.3 \
+ Dancer2::Core::App.3 \
+ Dancer2::Core::Context.3 \
+ Dancer2::Core::Cookie.3 \
+ Dancer2::Core::DSL.3 \
+ Dancer2::Core::Dispatcher.3 \
+ Dancer2::Core::Error.3 \
+ Dancer2::Core::Factory.3 \
+ Dancer2::Core::HTTP.3 \
+ Dancer2::Core::Hook.3 \
+ Dancer2::Core::MIME.3 \
+ Dancer2::Core::Request.3 \
+ Dancer2::Core::Request::Upload.3 \
+ Dancer2::Core::Response.3 \
+ Dancer2::Core::Role::Config.3 \
+ Dancer2::Core::Role::DSL.3 \
+ Dancer2::Core::Role::Engine.3 \
+ Dancer2::Core::Role::Handler.3 \
+ Dancer2::Core::Role::Headers.3 \
+ Dancer2::Core::Role::Hookable.3 \
+ Dancer2::Core::Role::Logger.3 \
+ Dancer2::Core::Role::Serializer.3 \
+ Dancer2::Core::Role::Server.3 \
+ Dancer2::Core::Role::SessionFactory.3 \
+ Dancer2::Core::Role::SessionFactory::File.3 \
+ Dancer2::Core::Role::StandardResponses.3 \
+ Dancer2::Core::Role::Template.3 \
+ Dancer2::Core::Route.3 \
+ Dancer2::Core::Runner.3 \
+ Dancer2::Core::Server::PSGI.3 \
+ Dancer2::Core::Server::Standalone.3 \
+ Dancer2::Core::Session.3 \
+ Dancer2::Core::Time.3 \
+ Dancer2::Core::Types.3 \
+ Dancer2::FileUtils.3 \
+ Dancer2::Handler::AutoPage.3 \
+ Dancer2::Handler::File.3 \
+ Dancer2::Logger::Capture.3 \
+ Dancer2::Logger::Capture::Trap.3 \
+ Dancer2::Logger::Console.3 \
+ Dancer2::Logger::Diag.3 \
+ Dancer2::Logger::File.3 \
+ Dancer2::Logger::Note.3 \
+ Dancer2::Logger::Null.3 \
+ Dancer2::Manual.3 \
+ Dancer2::ModuleLoader.3 \
+ Dancer2::Plugin.3 \
+ Dancer2::Plugin::Ajax.3 \
+ Dancer2::Plugins.3 \
+ Dancer2::Serializer::Dumper.3 \
+ Dancer2::Serializer::JSON.3 \
+ Dancer2::Serializer::YAML.3 \
+ Dancer2::Session::Simple.3 \
+ Dancer2::Session::YAML.3 \
+ Dancer2::Template::Implementation::ForkedTiny.3 \
+ Dancer2::Template::Simple.3 \
+ Dancer2::Template::TemplateToolkit.3 \
+ Dancer2::Template::Tiny.3 \
+ Dancer2::Test.3 \
+ Dancer2::Tutorial.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer2/distinfo b/www/p5-Dancer2/distinfo
new file mode 100644
index 000000000000..9f1086440e07
--- /dev/null
+++ b/www/p5-Dancer2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer2-0.07.tar.gz) = bd0abff18484827a02aaf9ab950a1c0d96a3b78428cd7f3ce954ba885983a23b
+SIZE (Dancer2-0.07.tar.gz) = 229557
diff --git a/www/p5-Dancer2/pkg-descr b/www/p5-Dancer2/pkg-descr
new file mode 100644
index 000000000000..f2704653bf0a
--- /dev/null
+++ b/www/p5-Dancer2/pkg-descr
@@ -0,0 +1,4 @@
+Dancer2 is the new generation of Dancer, the lightweight web-framework for
+Perl. Dancer2 is a complete rewrite based on Moo.
+
+WWW: http://search.cpan.org/dist/Dancer2/
diff --git a/www/p5-Dancer2/pkg-plist b/www/p5-Dancer2/pkg-plist
new file mode 100644
index 000000000000..94bee64dcaad
--- /dev/null
+++ b/www/p5-Dancer2/pkg-plist
@@ -0,0 +1,80 @@
+bin/dancer2
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer2/.packlist
+%%SITE_PERL%%/Dancer2.pm
+%%SITE_PERL%%/Dancer2/Config.pod
+%%SITE_PERL%%/Dancer2/Cookbook.pod
+%%SITE_PERL%%/Dancer2/Core.pm
+%%SITE_PERL%%/Dancer2/Core/App.pm
+%%SITE_PERL%%/Dancer2/Core/Context.pm
+%%SITE_PERL%%/Dancer2/Core/Cookie.pm
+%%SITE_PERL%%/Dancer2/Core/DSL.pm
+%%SITE_PERL%%/Dancer2/Core/Dispatcher.pm
+%%SITE_PERL%%/Dancer2/Core/Error.pm
+%%SITE_PERL%%/Dancer2/Core/Factory.pm
+%%SITE_PERL%%/Dancer2/Core/HTTP.pm
+%%SITE_PERL%%/Dancer2/Core/Hook.pm
+%%SITE_PERL%%/Dancer2/Core/MIME.pm
+%%SITE_PERL%%/Dancer2/Core/Request.pm
+%%SITE_PERL%%/Dancer2/Core/Request/Upload.pm
+%%SITE_PERL%%/Dancer2/Core/Response.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Config.pm
+%%SITE_PERL%%/Dancer2/Core/Role/DSL.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Engine.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Handler.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Headers.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Hookable.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Logger.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Serializer.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Server.pm
+%%SITE_PERL%%/Dancer2/Core/Role/SessionFactory.pm
+%%SITE_PERL%%/Dancer2/Core/Role/SessionFactory/File.pm
+%%SITE_PERL%%/Dancer2/Core/Role/StandardResponses.pm
+%%SITE_PERL%%/Dancer2/Core/Role/Template.pm
+%%SITE_PERL%%/Dancer2/Core/Route.pm
+%%SITE_PERL%%/Dancer2/Core/Runner.pm
+%%SITE_PERL%%/Dancer2/Core/Server/PSGI.pm
+%%SITE_PERL%%/Dancer2/Core/Server/Standalone.pm
+%%SITE_PERL%%/Dancer2/Core/Session.pm
+%%SITE_PERL%%/Dancer2/Core/Time.pm
+%%SITE_PERL%%/Dancer2/Core/Types.pm
+%%SITE_PERL%%/Dancer2/FileUtils.pm
+%%SITE_PERL%%/Dancer2/Handler/AutoPage.pm
+%%SITE_PERL%%/Dancer2/Handler/File.pm
+%%SITE_PERL%%/Dancer2/Logger/Capture.pm
+%%SITE_PERL%%/Dancer2/Logger/Capture/Trap.pm
+%%SITE_PERL%%/Dancer2/Logger/Console.pm
+%%SITE_PERL%%/Dancer2/Logger/Diag.pm
+%%SITE_PERL%%/Dancer2/Logger/File.pm
+%%SITE_PERL%%/Dancer2/Logger/Note.pm
+%%SITE_PERL%%/Dancer2/Logger/Null.pm
+%%SITE_PERL%%/Dancer2/Manual.pod
+%%SITE_PERL%%/Dancer2/ModuleLoader.pm
+%%SITE_PERL%%/Dancer2/Plugin.pm
+%%SITE_PERL%%/Dancer2/Plugin/Ajax.pm
+%%SITE_PERL%%/Dancer2/Plugins.pod
+%%SITE_PERL%%/Dancer2/Serializer/Dumper.pm
+%%SITE_PERL%%/Dancer2/Serializer/JSON.pm
+%%SITE_PERL%%/Dancer2/Serializer/YAML.pm
+%%SITE_PERL%%/Dancer2/Session/Simple.pm
+%%SITE_PERL%%/Dancer2/Session/YAML.pm
+%%SITE_PERL%%/Dancer2/Template/Implementation/ForkedTiny.pm
+%%SITE_PERL%%/Dancer2/Template/Simple.pm
+%%SITE_PERL%%/Dancer2/Template/TemplateToolkit.pm
+%%SITE_PERL%%/Dancer2/Template/Tiny.pm
+%%SITE_PERL%%/Dancer2/Test.pm
+%%SITE_PERL%%/Dancer2/Tutorial.pod
+@dirrm %%SITE_PERL%%/Dancer2/Core/Role/SessionFactory
+@dirrm %%SITE_PERL%%/Dancer2/Core/Role
+@dirrm %%SITE_PERL%%/Dancer2/Core/Request
+@dirrm %%SITE_PERL%%/Dancer2/Core/Server
+@dirrm %%SITE_PERL%%/Dancer2/Core
+@dirrm %%SITE_PERL%%/Dancer2/Handler
+@dirrm %%SITE_PERL%%/Dancer2/Logger/Capture
+@dirrm %%SITE_PERL%%/Dancer2/Logger
+@dirrm %%SITE_PERL%%/Dancer2/Plugin
+@dirrm %%SITE_PERL%%/Dancer2/Serializer
+@dirrm %%SITE_PERL%%/Dancer2/Session
+@dirrm %%SITE_PERL%%/Dancer2/Template/Implementation
+@dirrm %%SITE_PERL%%/Dancer2/Template
+@dirrm %%SITE_PERL%%/Dancer2
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer2