aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-27 21:40:51 +0800
committermiwi <miwi@FreeBSD.org>2007-03-27 21:40:51 +0800
commit90d2292cff7bf7c87e855937fca2972b6bf58b61 (patch)
treef1ac7413b918b068cb063439ae47a384566d742b /www
parent957bca0f1b317c2a7e67b83aded2438f793e0830 (diff)
downloadfreebsd-ports-gnome-90d2292cff7bf7c87e855937fca2972b6bf58b61.tar.gz
freebsd-ports-gnome-90d2292cff7bf7c87e855937fca2972b6bf58b61.tar.zst
freebsd-ports-gnome-90d2292cff7bf7c87e855937fca2972b6bf58b61.zip
TinyMCE is a platform independent web based Javascript HTML WYSIWYG editor
control released as Open Source under LGPL by Moxiecode Systems AB. It has the ability to convert HTML TEXTAREA fields or other HTML elements to editor instances. TinyMCE is very easy to integrate into other Content Management Systems. This module integrates the TinyMCE WYSIWYG editor into a Drupal site for editing advanced site content. WWW: http://drupal.org/project/tinymce PR: ports/110867 Submitted by: Nick Hilliard <nick at foobar.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/drupal5-tinymce/Makefile49
-rw-r--r--www/drupal5-tinymce/distinfo3
-rw-r--r--www/drupal5-tinymce/files/pkg-message.in10
-rw-r--r--www/drupal5-tinymce/pkg-descr10
5 files changed, 73 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 443503ac2eb0..24101d1bed58 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -117,6 +117,7 @@
SUBDIR += drupal4-taxonomy_access
SUBDIR += drupal4-textile
SUBDIR += drupal5
+ SUBDIR += drupal5-tinymce
SUBDIR += dtse
SUBDIR += dummyflash
SUBDIR += eaccelerator
diff --git a/www/drupal5-tinymce/Makefile b/www/drupal5-tinymce/Makefile
new file mode 100644
index 000000000000..d5912133d47d
--- /dev/null
+++ b/www/drupal5-tinymce/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: drupal5-gsitemap
+# Date created: 26 Mar 2007
+# Whom: Nick Hilliard <nick@foobar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinymce
+DISTVERSION= 5.x-1.x-dev
+PORTREVISION= 20070306
+CATEGORIES= www
+MASTER_SITE_SUBDIR= pav/drupal
+
+MAINTAINER= nick@foobar.org
+COMMENT= A Drupal module which implements the TinyMCE WYSIWYG editor for content editing
+
+TINYMCEDIR= www/tinymce
+TINYMCE_MODDIR= ${PORTNAME:C|^|${DRUPAL_MODDIR}/|}
+
+RUN_DEPENDS+= ${PREFIX}/${TINYMCEDIR}/jscripts/tiny_mce/tiny_mce.js:${PORTSDIR}/www/tinymce
+
+SUB_FILES+= pkg-message
+SUB_LIST+= TINYMCEDIR="${PREFIX}/${TINYMCEDIR}" \
+ TINYMCE_MODDIR="${TINYMCE_MODDIR:C|^|${PREFIX}/|}"
+
+DRUPAL5_MODULE= yes
+
+MODULE_DIRS= plugins/drupalbreak/images plugins/drupalbreak/langs \
+ plugins/drupalbreak plugins themes
+
+MODULE_FILES= plugins/drupalbreak/images/drupalbreak.gif \
+ plugins/drupalbreak/images/drupalbreaktext.gif \
+ plugins/drupalbreak/images/drupalpagebreak.gif \
+ plugins/drupalbreak/images/drupalpagebreaktext.gif \
+ plugins/drupalbreak/README.txt \
+ plugins/drupalbreak/drupalbreak.css \
+ plugins/drupalbreak/editor_plugin.js \
+ plugins/drupalbreak/editor_plugin_src.js \
+ plugins/drupalbreak/langs/en.js themes/tinymce_compact.js \
+ themes/tinymce_full.js themes/tinymce_simple.js \
+ plugin_reg.php tinymce.info tinymce.install tinymce.module
+DOC_FILES= CHANGELOG.TXT INSTALL.txt LICENSE.txt README.TXT
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/drupal5/bsd.drupal.mk"
+.include <bsd.port.post.mk>
diff --git a/www/drupal5-tinymce/distinfo b/www/drupal5-tinymce/distinfo
new file mode 100644
index 000000000000..7773c33cbea0
--- /dev/null
+++ b/www/drupal5-tinymce/distinfo
@@ -0,0 +1,3 @@
+MD5 (drupal/tinymce-5.x-1.x-dev.tar.gz) = 463823a73a718accf35d899759773650
+SHA256 (drupal/tinymce-5.x-1.x-dev.tar.gz) = 365aa6b89b7214b370b5a1d273e0bc5e3f4148785b04b1af8d1f078146d09841
+SIZE (drupal/tinymce-5.x-1.x-dev.tar.gz) = 29082
diff --git a/www/drupal5-tinymce/files/pkg-message.in b/www/drupal5-tinymce/files/pkg-message.in
new file mode 100644
index 000000000000..34f9d08ab27e
--- /dev/null
+++ b/www/drupal5-tinymce/files/pkg-message.in
@@ -0,0 +1,10 @@
+You now need to create a WWW alias in your web server configuration to allow
+the Drupal module to use the TinyMCE code. For Apache based systems, the
+following directive will work:
+
+ Alias %%TINYMCE_MODDIR%% %%TINYMCEDIR%%
+
+Please see the TinyMCE Wiki for more information on how to get the most out
+of this package:
+
+ http://wiki.moxiecode.com/index.php/TinyMCE:Index
diff --git a/www/drupal5-tinymce/pkg-descr b/www/drupal5-tinymce/pkg-descr
new file mode 100644
index 000000000000..f100b2b16d21
--- /dev/null
+++ b/www/drupal5-tinymce/pkg-descr
@@ -0,0 +1,10 @@
+TinyMCE is a platform independent web based Javascript HTML WYSIWYG editor
+control released as Open Source under LGPL by Moxiecode Systems AB. It has
+the ability to convert HTML TEXTAREA fields or other HTML elements to editor
+instances. TinyMCE is very easy to integrate into other Content Management
+Systems.
+
+This module integrates the TinyMCE WYSIWYG editor into a Drupal site for
+editing advanced site content.
+
+WWW: http://drupal.org/project/tinymce