aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-16 04:52:21 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-16 04:52:21 +0800
commit91fa37f3743507acd3f8c5e98e2bfa4f38f38c16 (patch)
tree03edbc9da8265aed6fa3f01679b34dc79a58e710 /www
parent61ec24616b4214e052a8520cc80826cbefafce03 (diff)
downloadfreebsd-ports-gnome-91fa37f3743507acd3f8c5e98e2bfa4f38f38c16.tar.gz
freebsd-ports-gnome-91fa37f3743507acd3f8c5e98e2bfa4f38f38c16.tar.zst
freebsd-ports-gnome-91fa37f3743507acd3f8c5e98e2bfa4f38f38c16.zip
- Fix *_DEPENDS:
- p5-Class-ISA is a build/runtime dependency - p5-Test-Simple is already in all supported Perl releases - Add TEST_DEPENDS - Bump PORTREVISION for dependency change
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-Application/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/p5-CGI-Application/Makefile b/www/p5-CGI-Application/Makefile
index 1ca57e32b931..2450fb0d2ba1 100644
--- a/www/p5-CGI-Application/Makefile
+++ b/www/p5-CGI-Application/Makefile
@@ -3,6 +3,7 @@
PORTNAME= CGI-Application
PORTVERSION= 4.50
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,10 +14,11 @@ COMMENT= Perl module intended to make it easier to create reusable web apps
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template
+BUILD_DEPENDS= p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA \
+ p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>0:${PORTSDIR}/devel/p5-Test-Simple \
- p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA
+TEST_DEPENDS= p5-CGI-PSGI>=0:${PORTSDIR}/www/p5-CGI-PSGI \
+ p5-CGI-Simple>=0:${PORTSDIR}/www/p5-CGI-Simple
USES= perl5
USE_PERL5= configure