aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-07-14 19:48:43 +0800
committersem <sem@FreeBSD.org>2005-07-14 19:48:43 +0800
commit96cc0400933e437cbba7ba204e0369561d5afdcd (patch)
tree66cfa6b4db876d544286420c15b5dec5291877ec /www
parent63265a9d545b5fba49f569ad11b133162629660c (diff)
downloadfreebsd-ports-gnome-96cc0400933e437cbba7ba204e0369561d5afdcd.tar.gz
freebsd-ports-gnome-96cc0400933e437cbba7ba204e0369561d5afdcd.tar.zst
freebsd-ports-gnome-96cc0400933e437cbba7ba204e0369561d5afdcd.zip
Xaraya delivers the requisite infrastructure and tools
to create custom web applications that include fully dynamic multi-platform Content Mangement Solutions (CMS). PR: ports/83235 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/xaraya/Makefile79
-rw-r--r--www/xaraya/distinfo2
-rw-r--r--www/xaraya/pkg-descr10
4 files changed, 92 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 99bc09670827..2bd72ce74117 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -811,6 +811,7 @@
SUBDIR += wwwoffle
SUBDIR += wwwstat
SUBDIR += wyvern
+ SUBDIR += xaraya
SUBDIR += xist
SUBDIR += xitami
SUBDIR += xpath2rss
diff --git a/www/xaraya/Makefile b/www/xaraya/Makefile
new file mode 100644
index 000000000000..30d78234ceb1
--- /dev/null
+++ b/www/xaraya/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: xaraya
+# Date created: 2005-07-10
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+# Try to specify WITH_PGSQL to use pgsql php extension. Mysql
+# extension would be used by default.
+
+PORTNAME= xaraya
+PORTVERSION= 1.0.0r3
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-1.0.0-rc3-base
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Framework to create fully dynamic Content Mangement Solutions
+
+.if defined(WITH_PGSQL)
+USE_PHP= pgsql
+.else
+USE_PHP= mysql
+.endif
+BROKEN_WITH_PHP= 5
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.0-rc3
+
+# May user to override this
+XARAYADIR?= www/xaraya
+
+pre-install:
+ @${RM} -f ${TMPPLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${XARAYADIR}
+ ${CP} -r ${WRKSRC}/html/* ${PREFIX}/${XARAYADIR}
+.if !defined(NOTOOLS)
+ ${MKDIR} ${DATADIR}
+ ${CP} -r ${WRKSRC}/tools ${DATADIR}
+.endif
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${XARAYADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -r ${WRKSRC}/docs/* ${DOCSDIR}
+ ${CP} ${WRKSRC}/INSTALL.txt ${WRKSRC}/LICENSE.txt \
+ ${WRKSRC}/CREDITS.txt ${DOCSDIR}
+.endif
+
+# Create plist
+post-install:
+ @${FIND} ${PREFIX}/${XARAYADIR} ! -type d -and ! -name install.php \
+ -and ! -name upgrade.php | ${SED} -e \
+ 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${XARAYADIR} -type f -and '(' -name install.php \
+ -or -name upgrade.php ')' | ${SED} -e \
+ 's,^${PREFIX}/\(.*\),@unexec rm -f %D/\1 >/dev/null 2>\&1 || true,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${XARAYADIR} -type d -and -path "*var*" | \
+ ${SED} -e 's,^${PREFIX}/\(.*\),@unexec rmdir %D/\1 >/dev/null 2>\&1 || true,' | \
+ ${SORT} -r >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${XARAYADIR} -type d -and ! -path "*var*" | \
+ ${SED} -e 's,^${PREFIX}/,@dirrm ,' | \
+ ${SORT} -r >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${FIND} ${DOCSDIR} ! -type d | ${SED} -e \
+ 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SED} -e \
+ 's,^${PREFIX}/,@dirrm ,' | \
+ ${SORT} -r >> ${TMPPLIST}
+.endif
+.if !defined(NOTOOLS)
+ @${FIND} ${DATADIR} ! -type d | ${SED} -e \
+ 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SED} -e \
+ 's,^${PREFIX}/,@dirrm ,' | \
+ ${SORT} -r >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/xaraya/distinfo b/www/xaraya/distinfo
new file mode 100644
index 000000000000..90990f997787
--- /dev/null
+++ b/www/xaraya/distinfo
@@ -0,0 +1,2 @@
+MD5 (xaraya-1.0.0-rc3-base.tar.gz) = 8c5c68588972c0738e6ec717b04dabd9
+SIZE (xaraya-1.0.0-rc3-base.tar.gz) = 4283144
diff --git a/www/xaraya/pkg-descr b/www/xaraya/pkg-descr
new file mode 100644
index 000000000000..859a8a2a88ca
--- /dev/null
+++ b/www/xaraya/pkg-descr
@@ -0,0 +1,10 @@
+Xaraya is an extensible, Open Source web application framework written in PHP
+and licensed under the GNU General Public License. Xaraya delivers the
+requisite infrastructure and tools to create custom web applications that
+include fully dynamic multi-platform Content Mangement Solutions (CMS).
+
+Xaraya's modular, database independent architecture introduces tools that
+separate form, function, content, and design with on-the-fly extensions
+allowing greater control and versatility.
+
+WWW: http://www.xaraya.com/