aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-03 00:07:56 +0800
committeraz <az@FreeBSD.org>2013-09-03 00:07:56 +0800
commit9715d03b9401cc71e73bef1d6feb9f51e41a92e1 (patch)
tree6a52660fa683999bdf5894f17b375993be27b7a3 /www
parentec361e51c266e3fd6d1e9f46dd6f77b1b4c8fa17 (diff)
downloadfreebsd-ports-gnome-9715d03b9401cc71e73bef1d6feb9f51e41a92e1.tar.gz
freebsd-ports-gnome-9715d03b9401cc71e73bef1d6feb9f51e41a92e1.tar.zst
freebsd-ports-gnome-9715d03b9401cc71e73bef1d6feb9f51e41a92e1.zip
- convert to the new perl5 framework
Reviewed by: portmgr (bapt@, blanket)
Diffstat (limited to 'www')
-rw-r--r--www/checkbot/Makefile3
-rw-r--r--www/p5-Apache-Gallery/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-ConfigAuto/Makefile3
-rw-r--r--www/p5-Catalyst-View-HTML-Template/Makefile3
-rw-r--r--www/p5-Dancer-Plugin-Feed/Makefile3
-rw-r--r--www/p5-HTML-ContentExtractor/Makefile3
-rw-r--r--www/p5-HTTP-Engine-Middleware/Makefile3
-rw-r--r--www/p5-LWP-Authen-OAuth/Makefile3
-rw-r--r--www/p5-Mojolicious-Plugin-YamlConfig/Makefile3
-rw-r--r--www/p5-Net-Flickr-RDF/Makefile3
-rw-r--r--www/p5-Plack-Handler-SCGI/Makefile3
-rw-r--r--www/p5-Plack-Middleware-Debug/Makefile3
-rw-r--r--www/p5-Plack-Middleware-InteractiveDebugger/Makefile3
-rw-r--r--www/p5-Plack-Middleware-XForwardedFor/Makefile3
-rw-r--r--www/p5-RT-Client-REST/Makefile3
-rw-r--r--www/p5-URI-Encode/Makefile3
-rw-r--r--www/p5-WWW-Google-Calculator/Makefile3
-rw-r--r--www/p5-WWW-Scripter-Plugin-Ajax/Makefile3
-rw-r--r--www/photo_gallery/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/www/checkbot/Makefile b/www/checkbot/Makefile
index c94a55aa673d..c73815e9152f 100644
--- a/www/checkbot/Makefile
+++ b/www/checkbot/Makefile
@@ -26,7 +26,8 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Time-Duration>=0:${PORTSDIR}/devel/p5-Time-Duration
MAN1= checkbot.1
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
PLIST_FILES= bin/checkbot ${SITE_PERL:S!${LOCALBASE}/!!}/${PERL_ARCH}/auto/checkbot/.packlist
PLIST_DIRS= ${SITE_PERL:S!${LOCALBASE}/!!}/${PERL_ARCH}/auto/checkbot
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index 1d58b3c66842..69d9935c9aa0 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -28,7 +28,8 @@ BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_APACHE= 22+
PLIST_DIRSTRY+= www/icons
diff --git a/www/p5-CGI-Application-Plugin-ConfigAuto/Makefile b/www/p5-CGI-Application-Plugin-ConfigAuto/Makefile
index e35cdc601547..37dbc882bbd1 100644
--- a/www/p5-CGI-Application-Plugin-ConfigAuto/Makefile
+++ b/www/p5-CGI-Application-Plugin-ConfigAuto/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-Config-Auto>=0:${PORTSDIR}/devel/p5-Config-Auto
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::ConfigAuto.3
diff --git a/www/p5-Catalyst-View-HTML-Template/Makefile b/www/p5-Catalyst-View-HTML-Template/Makefile
index 51a4890ebcd6..9dfd65a43beb 100644
--- a/www/p5-Catalyst-View-HTML-Template/Makefile
+++ b/www/p5-Catalyst-View-HTML-Template/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-HTML-Template>0:${PORTSDIR}/www/p5-HTML-Template
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Catalyst::Helper::View::HTML::Template.3 \
Catalyst::View::HTML::Template.3
diff --git a/www/p5-Dancer-Plugin-Feed/Makefile b/www/p5-Dancer-Plugin-Feed/Makefile
index be6ce546e1db..52ee85778c4e 100644
--- a/www/p5-Dancer-Plugin-Feed/Makefile
+++ b/www/p5-Dancer-Plugin-Feed/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Dancer>=1.2001:${PORTSDIR}/www/p5-Dancer \
p5-XML-Feed>=0:${PORTSDIR}/textproc/p5-XML-Feed
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Plugin::Feed.3
diff --git a/www/p5-HTML-ContentExtractor/Makefile b/www/p5-HTML-ContentExtractor/Makefile
index a3e7ccf0bbf3..6aad7ad52f57 100644
--- a/www/p5-HTML-ContentExtractor/Makefile
+++ b/www/p5-HTML-ContentExtractor/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-HTML-Tree>=3.13:${PORTSDIR}/www/p5-HTML-Tree \
p5-HTML-TableExtract>=2.10:${PORTSDIR}/www/p5-HTML-TableExtract
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::ContentExtractor.3
diff --git a/www/p5-HTTP-Engine-Middleware/Makefile b/www/p5-HTTP-Engine-Middleware/Makefile
index 1b6b92fa4655..f7ea22314d72 100644
--- a/www/p5-HTTP-Engine-Middleware/Makefile
+++ b/www/p5-HTTP-Engine-Middleware/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= \
p5-libwww>0:${PORTSDIR}/www/p5-libwww \
p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Engine::Middleware.3 \
HTTP::Engine::Middleware::AccessLog.3 \
diff --git a/www/p5-LWP-Authen-OAuth/Makefile b/www/p5-LWP-Authen-OAuth/Makefile
index 8cf9449ec713..9b5ae3319685 100644
--- a/www/p5-LWP-Authen-OAuth/Makefile
+++ b/www/p5-LWP-Authen-OAuth/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= \
p5-URI>0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= LWP::Authen::OAuth.3
diff --git a/www/p5-Mojolicious-Plugin-YamlConfig/Makefile b/www/p5-Mojolicious-Plugin-YamlConfig/Makefile
index a7ad258f3cc5..f6131ed1db16 100644
--- a/www/p5-Mojolicious-Plugin-YamlConfig/Makefile
+++ b/www/p5-Mojolicious-Plugin-YamlConfig/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Mojolicious>=1.80:${PORTSDIR}/www/p5-Mojolicious \
p5-YAML-Tiny>=1.51:${PORTSDIR}/textproc/p5-YAML-Tiny
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mojolicious::Plugin::YamlConfig.3
diff --git a/www/p5-Net-Flickr-RDF/Makefile b/www/p5-Net-Flickr-RDF/Makefile
index 77192a43a9f5..a7f04949b219 100644
--- a/www/p5-Net-Flickr-RDF/Makefile
+++ b/www/p5-Net-Flickr-RDF/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Net-Flickr-API>=1.7:${PORTSDIR}/www/p5-Net-Flickr-API \
p5-TimeDate>=1.16:${PORTSDIR}/devel/p5-TimeDate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Flickr::RDF.3
diff --git a/www/p5-Plack-Handler-SCGI/Makefile b/www/p5-Plack-Handler-SCGI/Makefile
index 6b89c6a72774..d29ea5300943 100644
--- a/www/p5-Plack-Handler-SCGI/Makefile
+++ b/www/p5-Plack-Handler-SCGI/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
p5-Try-Tiny>=0.04:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Handler::SCGI.3
diff --git a/www/p5-Plack-Middleware-Debug/Makefile b/www/p5-Plack-Middleware-Debug/Makefile
index ca6f99a1d8e1..0b68dac94971 100644
--- a/www/p5-Plack-Middleware-Debug/Makefile
+++ b/www/p5-Plack-Middleware-Debug/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::Debug.3 \
Plack::Middleware::Debug::Base.3 \
diff --git a/www/p5-Plack-Middleware-InteractiveDebugger/Makefile b/www/p5-Plack-Middleware-InteractiveDebugger/Makefile
index 850869b1e8ef..a7aa778685b2 100644
--- a/www/p5-Plack-Middleware-InteractiveDebugger/Makefile
+++ b/www/p5-Plack-Middleware-InteractiveDebugger/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= \
p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::InteractiveDebugger.3
diff --git a/www/p5-Plack-Middleware-XForwardedFor/Makefile b/www/p5-Plack-Middleware-XForwardedFor/Makefile
index 6667a32d04fa..b3402e5a7a0d 100644
--- a/www/p5-Plack-Middleware-XForwardedFor/Makefile
+++ b/www/p5-Plack-Middleware-XForwardedFor/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Net-Netmask>=1.9015:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
p5-Regexp-Common>=2010010201:${PORTSDIR}/textproc/p5-Regexp-Common
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::XForwardedFor.3
diff --git a/www/p5-RT-Client-REST/Makefile b/www/p5-RT-Client-REST/Makefile
index 292aa89c4cb1..da862e2623b3 100644
--- a/www/p5-RT-Client-REST/Makefile
+++ b/www/p5-RT-Client-REST/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= RT::Client::REST.3 \
RT::Client::REST::Attachment.3 \
diff --git a/www/p5-URI-Encode/Makefile b/www/p5-URI-Encode/Makefile
index b27d260dea5f..33c481a3a6ff 100644
--- a/www/p5-URI-Encode/Makefile
+++ b/www/p5-URI-Encode/Makefile
@@ -14,7 +14,8 @@ COMMENT= Simple URI Encoding/Decoding
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::Encode.3
diff --git a/www/p5-WWW-Google-Calculator/Makefile b/www/p5-WWW-Google-Calculator/Makefile
index 60bc590111b7..f60531253757 100644
--- a/www/p5-WWW-Google-Calculator/Makefile
+++ b/www/p5-WWW-Google-Calculator/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Google::Calculator.3
diff --git a/www/p5-WWW-Scripter-Plugin-Ajax/Makefile b/www/p5-WWW-Scripter-Plugin-Ajax/Makefile
index a129e6765115..3d68b2492e0e 100644
--- a/www/p5-WWW-Scripter-Plugin-Ajax/Makefile
+++ b/www/p5-WWW-Scripter-Plugin-Ajax/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-WWW-Scripter-Plugin-JavaScript>0:${PORTSDIR}/www/p5-WWW-Scripter
p5-XML-DOM-Lite>0:${PORTSDIR}/textproc/p5-XML-DOM-Lite
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Scripter::Plugin::Ajax.3
diff --git a/www/photo_gallery/Makefile b/www/photo_gallery/Makefile
index 4334aecac0bf..759dc5da1469 100644
--- a/www/photo_gallery/Makefile
+++ b/www/photo_gallery/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= anytopnm:${PORTSDIR}/graphics/netpbm\
p5-URI>=0:${PORTSDIR}/net/p5-URI
USE_APACHE_RUN= 22+
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
do-install: