aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-11-14 01:27:22 +0800
committersobomax <sobomax@FreeBSD.org>2000-11-14 01:27:22 +0800
commit98571c1d843ea9317beaa4c964cfdae83507d858 (patch)
tree6f7271df28fff77421a9d4b210eb7acb6f9fc32f /www
parent8bd25df4ce952676b246a8acd2d35bc43cd82aca (diff)
downloadfreebsd-ports-gnome-98571c1d843ea9317beaa4c964cfdae83507d858.tar.gz
freebsd-ports-gnome-98571c1d843ea9317beaa4c964cfdae83507d858.tar.zst
freebsd-ports-gnome-98571c1d843ea9317beaa4c964cfdae83507d858.zip
Add junkbuster-zlib, a modified version of Internet Junkbuster Proxy, which in
addition to ads zapping can authomatically compress html pages being sent to the client. Port has been repo-copied from www/junkbuster.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/junkbuster-zlib/Makefile51
-rw-r--r--www/junkbuster-zlib/distinfo2
-rw-r--r--www/junkbuster-zlib/files/junkbuster.sh.in6
-rw-r--r--www/junkbuster-zlib/files/patch-aa27
-rw-r--r--www/junkbuster-zlib/files/patch-ag14
-rw-r--r--www/junkbuster-zlib/files/patch-al18
-rw-r--r--www/junkbuster-zlib/files/patch-an11
-rw-r--r--www/junkbuster-zlib/pkg-comment2
-rw-r--r--www/junkbuster-zlib/pkg-descr11
-rw-r--r--www/junkbuster-zlib/pkg-message5
-rw-r--r--www/junkbuster-zlib/pkg-plist18
12 files changed, 97 insertions, 69 deletions
diff --git a/www/Makefile b/www/Makefile
index ca2638ecc67a..b466d575fe6e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -68,6 +68,7 @@
SUBDIR += jesred
SUBDIR += jetty
SUBDIR += junkbuster
+ SUBDIR += junkbuster-zlib
SUBDIR += kannel
SUBDIR += kdreamsite
SUBDIR += knowledgekit
diff --git a/www/junkbuster-zlib/Makefile b/www/junkbuster-zlib/Makefile
index 225194d1af4b..9f92657556d3 100644
--- a/www/junkbuster-zlib/Makefile
+++ b/www/junkbuster-zlib/Makefile
@@ -1,46 +1,43 @@
-# New ports collection makefile for: junkbuster
+# New ports collection makefile for: junkbuster-zlib
# Date created: 2 May 1998
# Whom: Ian Struble <ian@broken.net>
#
# $FreeBSD$
+#
-# You need to delete the old distfile if you are upgrading, as the tar ball
-# for ijb has not been changing names between minor revisions(ie 2.0->2.0.1).
-# I have contacted the author about this though so we may see something new
-# in the next revision.
-
-PORTNAME= junkbuster
-PORTVERSION= 2.0.2
+PORTNAME= junkbuster-zlib
+PORTVERSION= 1.0
CATEGORIES= www
-MASTER_SITES= http://www.junkbusters.com/ht/en/
-DISTNAME= ijb20
+MASTER_SITES= http://f2.org/download/
+DISTNAME= ijb-zlib-${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .tgz
-MAINTAINER= ian@broken.net
+MAINTAINER= sobomax@altavista.net
-USE_ZIP= yes
ALL_TARGET= # yes, an empty target.
-JDIR= ${PREFIX}/etc/junkbuster
-MAN1= junkbuster.1
+JDIR= ${PREFIX}/etc/junkbuster-zlib
+MAN1= junkbuster-zlib.1
post-patch:
@${PERL} -pi -e 's:\r::' ${WRKSRC}/*
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/junkbuster ${PREFIX}/sbin/junkbuster
- ${MKDIR} -m 755 ${PREFIX}/etc/junkbuster
- ${INSTALL_DATA} ${WRKSRC}/junkbstr.ini ${PREFIX}/etc/junkbuster/configfile.sample
- ${INSTALL_DATA} ${WRKSRC}/sblock.ini ${PREFIX}/etc/junkbuster/blockfile.sample
- ${INSTALL_DATA} ${WRKSRC}/saclfile.ini ${PREFIX}/etc/junkbuster/aclfile.sample
- ${INSTALL_DATA} ${WRKSRC}/scookie.ini ${PREFIX}/etc/junkbuster/cookiefile.sample
- ${INSTALL_DATA} ${WRKSRC}/sforward.ini ${PREFIX}/etc/junkbuster/forwardfile.sample
- ${INSTALL_DATA} ${WRKSRC}/strust.ini ${PREFIX}/etc/junkbuster/trustfile.sample
- $(INSTALL_MAN) ${WRKSRC}/junkbuster.1 $(PREFIX)/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/junkbuster ${PREFIX}/sbin/junkbuster-zlib
+ ${MKDIR} -m 755 ${JDIR}
+ ${INSTALL_DATA} ${WRKSRC}/junkbstr.ini ${JDIR}/configfile.sample
+ ${INSTALL_DATA} ${WRKSRC}/sblock.ini ${JDIR}/blockfile.sample
+ ${INSTALL_DATA} ${WRKSRC}/saclfile.ini ${JDIR}/aclfile.sample
+ ${INSTALL_DATA} ${WRKSRC}/scookie.ini ${JDIR}/cookiefile.sample
+ ${INSTALL_DATA} ${WRKSRC}/sforward.ini ${JDIR}/forwardfile.sample
+ ${INSTALL_DATA} ${WRKSRC}/strust.ini ${JDIR}/trustfile.sample
+ $(INSTALL_MAN) ${WRKSRC}/junkbuster.1 $(PREFIX)/man/man1/junkbuster-zlib.1
# Create the startup script. JB will run as user nobody.
- @${SED} -e 's%JDIR%${JDIR}%g' -e 's%PREFIX%${PREFIX}%g' \
- ${FILESDIR}/junkbuster.sh.in > ${PREFIX}/etc/rc.d/junkbuster.sh
- ${CHMOD} 755 ${PREFIX}/etc/rc.d/junkbuster.sh
+ @${SED} 's|%%JDIR%%|${JDIR}|g ; s|%%PREFIX%%|${PREFIX}|g' \
+ ${FILESDIR}/junkbuster.sh.in > ${WRKDIR}/junkbuster-zlib.sh
+ ${INSTALL_SCRIPT} ${WRKDIR}/junkbuster-zlib.sh \
+ ${PREFIX}/etc/rc.d/junkbuster-zlib.sh
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/junkbuster-zlib/distinfo b/www/junkbuster-zlib/distinfo
index e5e9b38da8de..dbf6bc9daa01 100644
--- a/www/junkbuster-zlib/distinfo
+++ b/www/junkbuster-zlib/distinfo
@@ -1 +1 @@
-MD5 (ijb20.zip) = 4a384a649bf7bda12e5c3f8e0b809d08
+MD5 (ijb-zlib-10.tgz) = 3c410f61eeb7e24641fc7eaf3dc5063e
diff --git a/www/junkbuster-zlib/files/junkbuster.sh.in b/www/junkbuster-zlib/files/junkbuster.sh.in
index 9f3e639a9494..b30cb43d308b 100644
--- a/www/junkbuster-zlib/files/junkbuster.sh.in
+++ b/www/junkbuster-zlib/files/junkbuster.sh.in
@@ -2,9 +2,9 @@
case $1 in
start)
- test -d JDIR -a -x PREFIX/sbin/junkbuster -a -f JDIR/configfile || exit 1
- cd JDIR
- su -m nobody -c "PREFIX/sbin/junkbuster configfile &"
+ test -d %%JDIR%% -a -x %%PREFIX%%/sbin/junkbuster -a -f %%JDIR%%/configfile || exit 1
+ cd %%JDIR%%
+ su -m nobody -c "%%PREFIX%%/sbin/junkbuster configfile &"
echo -n " junkbuster"
;;
stop)
diff --git a/www/junkbuster-zlib/files/patch-aa b/www/junkbuster-zlib/files/patch-aa
index 08cddfae34e0..59a1478d4e9d 100644
--- a/www/junkbuster-zlib/files/patch-aa
+++ b/www/junkbuster-zlib/files/patch-aa
@@ -1,20 +1,31 @@
-diff -ruN /usr/ports/www/ijb/work/ijb20/Makefile ./Makefile
---- /usr/ports/www/ijb/work/ijb20/Makefile Mon Feb 28 02:35:10 2000
-+++ ./Makefile Mon Feb 28 02:37:39 2000
-@@ -8,10 +8,11 @@
+--- Makefile.orig Fri Aug 4 15:40:15 2000
++++ Makefile Fri Nov 3 12:23:48 2000
+@@ -5,20 +5,20 @@
+
+ # set include and library paths for the zlib compression library
+ #
+-ZLIB_INC_FLAGS=-I../zlib
+-ZLIB_LIB_FLAGS=-L ../zlib
++#ZLIB_INC_FLAGS=-I../zlib
++#ZLIB_LIB_FLAGS=-L ../zlib
+
+ DEFAULT_CFLAGS = -I. $(ZLIB_INC_FLAGS) $(REGEX) -DSTDC_HEADERS -DHAVE_STRING
+
PROG = junkbuster
O = o
RM = rm -f
-MORE_CFLAGS = -g
+MORE_CFLAGS =
+ LD = $(CC) $(CFLAGS) $(ZLIB_LIB)
+ LDFLAGS = -lz
# use this for Solaris 2.x
- #LDFLAGS = -lnsl -lsocket
+-#LDFLAGS = -lnsl -lsocket -lz
+LDFLAGS += -lgnuregex
# use these for SunOS 4.x
- #LDFLAGS = -nsl
-@@ -47,10 +48,10 @@
+ #LDFLAGS = -nsl -lz
+@@ -63,10 +63,10 @@
#MORE_CFLAGS = -relax_pointers
#LDFLAGS = -map junkbuster.xMAP
@@ -26,4 +37,4 @@ diff -ruN /usr/ports/www/ijb/work/ijb20/Makefile ./Makefile
+ encode.$(O) ssplit.$(O) socks4.$(O) acl.$(O) win32.$(O)
$(PROG): $(OBJS)
- $(CC) $(CFLAGS) -o $(PROG) $(OBJS) $(LDFLAGS)
+ $(LD) -o $(PROG) $(ZLIB_LIB_FLAGS) $(OBJS) $(LDFLAGS)
diff --git a/www/junkbuster-zlib/files/patch-ag b/www/junkbuster-zlib/files/patch-ag
index 7850ba53c513..c8e942b32401 100644
--- a/www/junkbuster-zlib/files/patch-ag
+++ b/www/junkbuster-zlib/files/patch-ag
@@ -1,7 +1,6 @@
-diff -ruN /usr/ports/www/ijb/work/ijb20/jcc.c ./jcc.c
---- /usr/ports/www/ijb/work/ijb20/jcc.c Mon Feb 28 02:35:10 2000
-+++ ./jcc.c Mon Feb 28 02:31:06 2000
-@@ -39,7 +39,7 @@
+--- jcc.c.orig Fri Nov 3 12:28:39 2000
++++ jcc.c Fri Nov 3 12:31:58 2000
+@@ -39,11 +39,12 @@
#endif
#ifdef REGEX
@@ -10,4 +9,9 @@ diff -ruN /usr/ports/www/ijb/work/ijb20/jcc.c ./jcc.c
#endif
#include "jcc.h"
-Binary files /usr/ports/www/ijb/work/ijb20/junkbuster and ./junkbuster differ
+-#include "zutil.h"
++#include "zlib.h"
++#define DEF_MEM_LEVEL 8
+
+ char *prog;
+
diff --git a/www/junkbuster-zlib/files/patch-al b/www/junkbuster-zlib/files/patch-al
index 6b78b5f1a731..98010e51f392 100644
--- a/www/junkbuster-zlib/files/patch-al
+++ b/www/junkbuster-zlib/files/patch-al
@@ -1,12 +1,14 @@
-diff -ruN /usr/ports/www/ijb/work/ijb20/ssplit.c ./ssplit.c
---- /usr/ports/www/ijb/work/ijb20/ssplit.c Mon Feb 28 02:35:10 2000
-+++ ./ssplit.c Mon Feb 28 02:31:06 2000
-@@ -18,6 +18,8 @@
+--- ssplit.c.orig Fri Aug 4 09:39:24 2000
++++ ssplit.c Fri Nov 3 12:24:59 2000
+@@ -22,9 +22,10 @@
* l = flag indicating whether to ignore leading field separators
*/
+#include "loaders.h"
-+#include <stdlib.h>
- #include <string.h>
-
- int ssplit(char *s, char *c, char *v[], int n, int m, int l)
+ #include <stdlib.h> /* For free() */
+ #include <stdio.h> /* Required by jcc.h */
+-#include "gnu_regex.h"
++#include "gnuregex.h"
+ #include "jcc.h" /* For zalloc() */
+ #undef DEBUG /* DEBUG macro use in this file is not */
+ /* consistent with use in jcc.h */
diff --git a/www/junkbuster-zlib/files/patch-an b/www/junkbuster-zlib/files/patch-an
new file mode 100644
index 000000000000..cc89552a1df2
--- /dev/null
+++ b/www/junkbuster-zlib/files/patch-an
@@ -0,0 +1,11 @@
+--- bind.c 2000/11/03 10:27:18 1.1
++++ bind.c 2000/11/03 10:27:22
+@@ -37,7 +37,7 @@
+ #endif
+
+ #ifdef REGEX
+-#include <gnu_regex.h>
++#include <gnuregex.h>
+ #endif
+
+ #include "jcc.h" /* For atoip() */
diff --git a/www/junkbuster-zlib/pkg-comment b/www/junkbuster-zlib/pkg-comment
index 356bd17673bb..5a2d708d68d8 100644
--- a/www/junkbuster-zlib/pkg-comment
+++ b/www/junkbuster-zlib/pkg-comment
@@ -1 +1 @@
-An HTTP proxy server that eliminates ads
+An HTTP proxy server that eliminates ads and can compress pages on the fly
diff --git a/www/junkbuster-zlib/pkg-descr b/www/junkbuster-zlib/pkg-descr
index 25b2c53d58c9..75c9d6224971 100644
--- a/www/junkbuster-zlib/pkg-descr
+++ b/www/junkbuster-zlib/pkg-descr
@@ -1,6 +1,7 @@
-This is a port of The Internet Junkbuster Proxy(TM). An excelent way
-to enhance your privacy while browsing the web. And it also happens
-to do a great job of filtering out all those annoying banner ads!
+Junkbuster-zlib is a modified version of the Internet Junkbuster Proxy v2.0.2
+which can automatically compress text/html and text/plain documents for clients
+which support Accept-Encoding: gzip (e.g. Netscape 4.7, Internet Explorer 5,
+Lynx 2.8.3) to save downstream modem/network bandwidth. It uses the zlib
+compression library to perform on-the-fly compression of HTML documents.
-- Ian Struble
-ian@broken.net
+WWW: http://f2.org/products/ijb-zlib/
diff --git a/www/junkbuster-zlib/pkg-message b/www/junkbuster-zlib/pkg-message
index 7daab941caed..943ca50d9c4c 100644
--- a/www/junkbuster-zlib/pkg-message
+++ b/www/junkbuster-zlib/pkg-message
@@ -1,3 +1,4 @@
Please, review the samples of the configuration files (somewhere in
-/usr/local/etc/junkbuster/*.sample) and create your own config files.
-Read the junkbuster man-page (man junkbuster) for even more information.
+%%PREFIX%%/etc/junkbuster-zlib/*.sample) and create your own config files.
+Read the junkbuster-zlib man-page (man junkbuster-zlib) for even more
+information.
diff --git a/www/junkbuster-zlib/pkg-plist b/www/junkbuster-zlib/pkg-plist
index 790a60a2eb8d..5567be8d5a67 100644
--- a/www/junkbuster-zlib/pkg-plist
+++ b/www/junkbuster-zlib/pkg-plist
@@ -1,9 +1,9 @@
-sbin/junkbuster
-etc/junkbuster/aclfile.sample
-etc/junkbuster/blockfile.sample
-etc/junkbuster/cookiefile.sample
-etc/junkbuster/configfile.sample
-etc/junkbuster/forwardfile.sample
-etc/junkbuster/trustfile.sample
-etc/rc.d/junkbuster.sh
-@dirrm etc/junkbuster
+sbin/junkbuster-zlib
+etc/junkbuster-zlib/aclfile.sample
+etc/junkbuster-zlib/blockfile.sample
+etc/junkbuster-zlib/cookiefile.sample
+etc/junkbuster-zlib/configfile.sample
+etc/junkbuster-zlib/forwardfile.sample
+etc/junkbuster-zlib/trustfile.sample
+etc/rc.d/junkbuster-zlib.sh
+@dirrm etc/junkbuster-zlib