aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2016-10-28 11:27:30 +0800
committervanilla <vanilla@FreeBSD.org>2016-10-28 11:27:30 +0800
commit9913b578aa7742c622feddf7c15d124ac2c9bd79 (patch)
treee2ef2c3f61f72ee521b6c03794b1e18875ea143d /www
parent846d9b4186974d7e001c322b71c9dd3d69ea4bc6 (diff)
downloadfreebsd-ports-gnome-9913b578aa7742c622feddf7c15d124ac2c9bd79.tar.gz
freebsd-ports-gnome-9913b578aa7742c622feddf7c15d124ac2c9bd79.tar.zst
freebsd-ports-gnome-9913b578aa7742c622feddf7c15d124ac2c9bd79.zip
Add varnish-libvmod-awsrest.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/varnish-libvmod-awsrest/Makefile27
-rw-r--r--www/varnish-libvmod-awsrest/distinfo3
-rw-r--r--www/varnish-libvmod-awsrest/files/patch-Makefile.am8
-rw-r--r--www/varnish-libvmod-awsrest/files/patch-src_vmod__awsrest.c13
-rw-r--r--www/varnish-libvmod-awsrest/pkg-descr3
-rw-r--r--www/varnish-libvmod-awsrest/pkg-plist4
7 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7d550648fcce..0282a17dbd2e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2269,6 +2269,7 @@
SUBDIR += uwsgitop
SUBDIR += uzbl
SUBDIR += validator
+ SUBDIR += varnish-libvmod-awsrest
SUBDIR += varnish-libvmod-digest
SUBDIR += varnish-libvmod-maxminddb
SUBDIR += varnish-modules
diff --git a/www/varnish-libvmod-awsrest/Makefile b/www/varnish-libvmod-awsrest/Makefile
new file mode 100644
index 000000000000..8935d3e5eae5
--- /dev/null
+++ b/www/varnish-libvmod-awsrest/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= libvmod-awsrest
+DISTVERSIONPREFIX=${PORTNAME}-
+DISTVERSION= 0.4
+CATEGORIES= www
+PKGNAMEPREFIX= varnish-
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Varnish Module (vmod) for generating headers for AWS REST API
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= rst2man:textproc/py-docutils
+LIB_DEPENDS= libmhash.so:security/mhash
+
+USES= autoreconf gmake libtool pkgconfig python:2,build varnish
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+INSTALL_TARGET= install-strip
+
+USE_GITHUB= yes
+GH_ACCOUNT= xcir
+GH_TAGNAME= v${DISTVERSION}-varnish40
+
+.include <bsd.port.mk>
diff --git a/www/varnish-libvmod-awsrest/distinfo b/www/varnish-libvmod-awsrest/distinfo
new file mode 100644
index 000000000000..db9c16be0423
--- /dev/null
+++ b/www/varnish-libvmod-awsrest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1477523902
+SHA256 (xcir-libvmod-awsrest-libvmod-awsrest-0.4-v0.4-varnish40_GH0.tar.gz) = d5804479765c8e8be81d87fc48f736ab84aa9c7893b616ad30c2856a279006d7
+SIZE (xcir-libvmod-awsrest-libvmod-awsrest-0.4-v0.4-varnish40_GH0.tar.gz) = 9658
diff --git a/www/varnish-libvmod-awsrest/files/patch-Makefile.am b/www/varnish-libvmod-awsrest/files/patch-Makefile.am
new file mode 100644
index 000000000000..54d6d1b61a25
--- /dev/null
+++ b/www/varnish-libvmod-awsrest/files/patch-Makefile.am
@@ -0,0 +1,8 @@
+--- Makefile.am.orig 2015-07-04 13:33:43 UTC
++++ Makefile.am
+@@ -1,4 +1,4 @@
+-ACLOCAL_AMFLAGS = -I m4 -I ${LIBVARNISHAPI_DATAROOTDIR}/aclocal
++ACLOCAL_AMFLAGS = -I m4
+
+ SUBDIRS = src
+
diff --git a/www/varnish-libvmod-awsrest/files/patch-src_vmod__awsrest.c b/www/varnish-libvmod-awsrest/files/patch-src_vmod__awsrest.c
new file mode 100644
index 000000000000..f68f0181dbd6
--- /dev/null
+++ b/www/varnish-libvmod-awsrest/files/patch-src_vmod__awsrest.c
@@ -0,0 +1,13 @@
+--- src/vmod_awsrest.c.orig 2016-10-26 23:24:27 UTC
++++ src/vmod_awsrest.c
+@@ -116,8 +116,8 @@ void vmod_v4_generic(const struct vrt_ct
+
+ ////////////////
+ //get data
+- char *method;
+- char *requrl;
++ const char *method;
++ const char *requrl;
+ struct http *hp;
+ struct gethdr_s gs;
+
diff --git a/www/varnish-libvmod-awsrest/pkg-descr b/www/varnish-libvmod-awsrest/pkg-descr
new file mode 100644
index 000000000000..0e697f4b96e5
--- /dev/null
+++ b/www/varnish-libvmod-awsrest/pkg-descr
@@ -0,0 +1,3 @@
+Varnish Module (vmod) for generating Authorization header for AWS REST API.
+
+WWW: https://github.com/xcir/libvmod-awsrest
diff --git a/www/varnish-libvmod-awsrest/pkg-plist b/www/varnish-libvmod-awsrest/pkg-plist
new file mode 100644
index 000000000000..6c2f4e0656f4
--- /dev/null
+++ b/www/varnish-libvmod-awsrest/pkg-plist
@@ -0,0 +1,4 @@
+lib/varnish/vmods/libvmod_awsrest.so
+man/man3/vmod_awsrest.3.gz
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.rst