aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-12 21:32:48 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-12 21:32:48 +0800
commit9927a9dcd10780227f2266a5d37561ee8b572965 (patch)
treeb4738ad44737a073581a29040d182e5b985b72ac /www
parent49dc12ca0fab3a20b7cf67c3ef955e5504cdf9ee (diff)
downloadfreebsd-ports-gnome-9927a9dcd10780227f2266a5d37561ee8b572965.tar.gz
freebsd-ports-gnome-9927a9dcd10780227f2266a5d37561ee8b572965.tar.zst
freebsd-ports-gnome-9927a9dcd10780227f2266a5d37561ee8b572965.zip
Add rubygem-http2 2.2.2 (copied from rubygem-http)
- Update RUN_DEPENDS - Add PORTSCOUT
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-http2/Makefile27
-rw-r--r--www/rubygem-http2/distinfo3
-rw-r--r--www/rubygem-http2/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9c466cd5a650..cb3724ce1ab4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2034,6 +2034,7 @@
SUBDIR += rubygem-http-cookie
SUBDIR += rubygem-http-form_data
SUBDIR += rubygem-http-form_data1
+ SUBDIR += rubygem-http2
SUBDIR += rubygem-http_router
SUBDIR += rubygem-httparty
SUBDIR += rubygem-httpclient
diff --git a/www/rubygem-http2/Makefile b/www/rubygem-http2/Makefile
new file mode 100644
index 000000000000..f8603e2d7744
--- /dev/null
+++ b/www/rubygem-http2/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= http
+PORTVERSION= 2.2.2
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 2
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple Ruby DSL for making HTTP requests
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-addressable>=2.3:www/rubygem-addressable \
+ rubygem-http-cookie>=1.0:www/rubygem-http-cookie \
+ rubygem-http-form_data1>=1.0.1:www/rubygem-http-form_data1 \
+ rubygem-http_parser.rb>=0.6.0:net/rubygem-http_parser.rb
+
+PORTSCOUT= limit:^2\.
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-http2/distinfo b/www/rubygem-http2/distinfo
new file mode 100644
index 000000000000..5e1b3c858335
--- /dev/null
+++ b/www/rubygem-http2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1493366903
+SHA256 (rubygem/http-2.2.2.gem) = 391515043d4a37cdd6856b8bbf4f8af70fba1a9008ba77ae9f39d48d2e4e8dcd
+SIZE (rubygem/http-2.2.2.gem) = 67072
diff --git a/www/rubygem-http2/pkg-descr b/www/rubygem-http2/pkg-descr
new file mode 100644
index 000000000000..e40347d24567
--- /dev/null
+++ b/www/rubygem-http2/pkg-descr
@@ -0,0 +1,8 @@
+The HTTP Gem is an easy-to-use client library for making requests from Ruby. It
+uses a simple method chaining system for building requests, similar to Python's
+Requests
+
+Under the hood, The HTTP Gem uses http_parser.rb, a fast HTTP parsing native
+extension based on the Node.js parser and a Java port thereof.
+
+WWW: https://github.com/httprb/http