aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-03-17 00:07:59 +0800
committerohauer <ohauer@FreeBSD.org>2014-03-17 00:07:59 +0800
commit9cf1815a59f35bab1d02daf28f28608c14f24fbe (patch)
tree088bc2aa2ca8c45fd65985e581892f863f926ba7 /www
parent71045f73d4318397bb9281de594ccfd7328fbf58 (diff)
downloadfreebsd-ports-gnome-9cf1815a59f35bab1d02daf28f28608c14f24fbe.tar.gz
freebsd-ports-gnome-9cf1815a59f35bab1d02daf28f28608c14f24fbe.tar.zst
freebsd-ports-gnome-9cf1815a59f35bab1d02daf28f28608c14f24fbe.zip
ports in cat www where MAINTAINER=ports
- USE_BZIP2 -> USES= tar:bzip2 - LICENSE=BSD -> BSD[n]CLAUSE
Diffstat (limited to 'www')
-rw-r--r--www/apache22/Makefile3
-rw-r--r--www/aria2fe/Makefile3
-rw-r--r--www/bins/Makefile3
-rw-r--r--www/bozohttpd/Makefile2
-rw-r--r--www/cakephp11/Makefile5
-rw-r--r--www/diamanda/Makefile3
-rw-r--r--www/firefox-remote/Makefile3
-rw-r--r--www/harvest/Makefile3
-rw-r--r--www/ismail/Makefile3
-rw-r--r--www/kannel/Makefile3
-rw-r--r--www/mod_authn_sasl/Makefile2
-rw-r--r--www/mod_proctitle/Makefile4
-rw-r--r--www/mod_proxy_html/Makefile2
-rw-r--r--www/script4rss/Makefile3
-rw-r--r--www/serf/Makefile2
-rw-r--r--www/srg/Makefile4
-rw-r--r--www/trac-tags/Makefile2
-rw-r--r--www/trac-themeengine/Makefile4
-rw-r--r--www/trac-wysiwyg/Makefile2
-rw-r--r--www/twiki/bsd.twiki.mk2
-rw-r--r--www/ump/Makefile3
21 files changed, 25 insertions, 36 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 63c6571f1ac1..bf8fdce8c805 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -20,8 +20,7 @@ CONFLICTS_INSTALL= caudium14-1.* \
apache-*-2.4.* apache24-*-2.4.*
USE_APACHE= common22
-USE_BZIP2= yes
-USES= iconv perl5
+USES= tar:bzip2 iconv perl5
USE_PERL5= run
USE_AUTOTOOLS= autoconf libtool
USE_RC_SUBR= apache22 htcacheclean
diff --git a/www/aria2fe/Makefile b/www/aria2fe/Makefile
index 92973b608f89..890cfa0e5a11 100644
--- a/www/aria2fe/Makefile
+++ b/www/aria2fe/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv3 # (or later)
RUN_DEPENDS= aria2c:${PORTSDIR}/www/aria2 \
xterm:${PORTSDIR}/x11/xterm
-USES= qmake
-USE_BZIP2= yes
+USES= tar:bzip2 qmake
USE_QT4= gui moc_build rcc_build uic_build
PLIST_FILES= bin/${PORTNAME}
diff --git a/www/bins/Makefile b/www/bins/Makefile
index ef166b26e2c3..6ce0f2218a51 100644
--- a/www/bins/Makefile
+++ b/www/bins/Makefile
@@ -26,9 +26,8 @@ RUN_DEPENDS= \
p5-XML-Handler-YAWriter>=0:${PORTSDIR}/textproc/p5-XML-Handler-YAWriter \
p5-libxml>=0:${PORTSDIR}/textproc/p5-libxml
-USES= perl5
+USES= tar:bzip2 perl5
USE_PERL5= run
-USE_BZIP2= yes
NO_BUILD= yes
NO_STAGE= yes
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index 1522ac674c17..4a5799bb5cd5 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.eterna.com.au/bozohttpd/ \
MAINTAINER= jmohacsi@bsd.hu
COMMENT= The bozotic HTTP server
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
USE_BZIP2= YES
USE_RC_SUBR= bozohttpd
diff --git a/www/cakephp11/Makefile b/www/cakephp11/Makefile
index 3c8d21a3cc5d..9515c3c2071f 100644
--- a/www/cakephp11/Makefile
+++ b/www/cakephp11/Makefile
@@ -11,10 +11,9 @@ PKGNAMESUFFIX= 11
DISTNAME= cake_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A framework for developing PHP web applications
-
-USE_BZIP2= yes
+COMMENT= Framework for developing PHP web applications
+USES= tar:bzip2
USE_APACHE_RUN= 22+
SLAVE_PORT_MODULES= REWRITE
diff --git a/www/diamanda/Makefile b/www/diamanda/Makefile
index 6c2047dd27b5..ec2e18da0734 100644
--- a/www/diamanda/Makefile
+++ b/www/diamanda/Makefile
@@ -20,10 +20,9 @@ SNAPSHOT= 2007.04.26
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_BZIP2= yes
NO_BUILD= yes
USE_PYTHON= yes
-USES= gettext
+USES= tar:bzip2 gettext
SUB_FILES= pkg-message
NO_STAGE= yes
diff --git a/www/firefox-remote/Makefile b/www/firefox-remote/Makefile
index 46c2b9ff14d7..b8d7aaebaa36 100644
--- a/www/firefox-remote/Makefile
+++ b/www/firefox-remote/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://www.webonaut.com/distfiles/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Wrapper scripts for firefox web browser
-USE_BZIP2= yes
-
+USES= tar:bzip2
UTF8_HACK= no
FIREFOX_REMOTE= firefox-remote
THUNDERBIRD_REMOTE= thunderbird-remote
diff --git a/www/harvest/Makefile b/www/harvest/Makefile
index 5b91d8f361c4..bf60e67dd8dc 100644
--- a/www/harvest/Makefile
+++ b/www/harvest/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20devel/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Collect information from all over the Internet
-USES= perl5
-USE_BZIP2= yes
+USES= tar:bzip2 perl5
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure src/gatherer/curl/configure
USE_LDCONFIG= yes
diff --git a/www/ismail/Makefile b/www/ismail/Makefile
index f7070b085e0c..5f80c2d60269 100644
--- a/www/ismail/Makefile
+++ b/www/ismail/Makefile
@@ -10,11 +10,10 @@ MASTER_SITES= http://az.semmy.ru/ISMail/
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP-based webmail client
-USE_BZIP2= yes
-
WRKSRC= ${WRKDIR}
NO_BUILD= yes
+USES= tar:bzip2
USE_PHP= imap
WANT_PHP_WEB= yes
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index 90d437d3b2ea..73967428ae95 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -14,8 +14,7 @@ COMMENT= WAP/SMS gateway
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= gmake
-USE_BZIP2= yes
+USES= tar:bzip2 gmake
USE_GNOME= libxml2
USE_OPENSSL= yes
USE_RC_SUBR= ${PORTNAME}
diff --git a/www/mod_authn_sasl/Makefile b/www/mod_authn_sasl/Makefile
index c7ee3cd7d8f5..d2221687c744 100644
--- a/www/mod_authn_sasl/Makefile
+++ b/www/mod_authn_sasl/Makefile
@@ -21,7 +21,7 @@ SASLAUTHD_DESC= cyrus-sasl2-saslauthd support
SASLAUTHD_RUN_DEPENDS= saslauthd:${PORTSDIR}/security/cyrus-sasl2-saslauthd
.include <bsd.port.options.mk>
-USE_BZIP2= yes
+USES= tar:bzip2
USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_proctitle/Makefile b/www/mod_proctitle/Makefile
index 31e6f8cde755..22e627b7dd31 100644
--- a/www/mod_proctitle/Makefile
+++ b/www/mod_proctitle/Makefile
@@ -10,11 +10,11 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Set httpd process titles to reflect currently processed request
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
USE_APACHE= 22+
GNU_CONFIGURE= yes
-USE_BZIP2= yes
+USES= tar:bzip2
CFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/apr-1
diff --git a/www/mod_proxy_html/Makefile b/www/mod_proxy_html/Makefile
index 09530e062dc7..da699de1a61a 100644
--- a/www/mod_proxy_html/Makefile
+++ b/www/mod_proxy_html/Makefile
@@ -21,7 +21,7 @@ USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SHORTMODNAME= proxy_html
-USE_BZIP2= yes
+USES= tar:bzip2
USE_GNOME= libxml2
AP_INC+= ${LOCALBASE}/include/libxml2 -I${WRKSRC}
diff --git a/www/script4rss/Makefile b/www/script4rss/Makefile
index ad1243e330a4..28bdbace2764 100644
--- a/www/script4rss/Makefile
+++ b/www/script4rss/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Easily create scripts to convert HTML pages to RSS feeds
-USES= perl5 shebangfix
-USE_BZIP2= yes
+USES= tar:bzip2 perl5 shebangfix
USE_PERL5= run
NO_BUILD= yes
diff --git a/www/serf/Makefile b/www/serf/Makefile
index f8caf5a43f83..5a494d5623f4 100644
--- a/www/serf/Makefile
+++ b/www/serf/Makefile
@@ -14,7 +14,7 @@ LICENSE= APACHE20
LIB_DEPENDS+= libapr-1.so:${PORTSDIR}/devel/apr1
USE_SCONS= yes
-USE_BZIP2= yes
+USES= tar:bzip2
USE_OPENSSL= yes
USE_LDCONFIG= yes
diff --git a/www/srg/Makefile b/www/srg/Makefile
index 8dbcb679cc5c..d5ba6e2a421f 100644
--- a/www/srg/Makefile
+++ b/www/srg/Makefile
@@ -8,12 +8,12 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
http://mirror.crc.net.nz/pub/srg/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Squid Report Generator
+COMMENT= Squid Report Generator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_BZIP2= yes
+USES= tar:bzip2
GNU_CONFIGURE= yes
OPTIONS_DEFINE= EXAMPLES
diff --git a/www/trac-tags/Makefile b/www/trac-tags/Makefile
index a2f59bb0fd5b..4d5db46f8ace 100644
--- a/www/trac-tags/Makefile
+++ b/www/trac-tags/Makefile
@@ -15,7 +15,7 @@ COMMENT= Generic tags frontend for trac
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
-USE_BZIP2= yes
+USES= tar:bzip2
USE_PYTHON= 2
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= TracTags
diff --git a/www/trac-themeengine/Makefile b/www/trac-themeengine/Makefile
index cbc1cb09fa3c..566de5d037e4 100644
--- a/www/trac-themeengine/Makefile
+++ b/www/trac-themeengine/Makefile
@@ -10,11 +10,11 @@ DISTNAME= ${PYDISTUTILS_PKGNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Plugin to simplify distributing and deploying themes and styles
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
-USE_BZIP2= yes
+USES= tar:bzip2
USE_PYTHON= 2
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= TracThemeEngine
diff --git a/www/trac-wysiwyg/Makefile b/www/trac-wysiwyg/Makefile
index 04b51216f11b..4c0625fbfec6 100644
--- a/www/trac-wysiwyg/Makefile
+++ b/www/trac-wysiwyg/Makefile
@@ -15,7 +15,7 @@ COMMENT= WYSIWYG editor for Trac wiki
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
-USE_BZIP2= yes
+USES= tar:bzip2
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
diff --git a/www/twiki/bsd.twiki.mk b/www/twiki/bsd.twiki.mk
index 363abbce33f6..533ec4d7b636 100644
--- a/www/twiki/bsd.twiki.mk
+++ b/www/twiki/bsd.twiki.mk
@@ -10,7 +10,7 @@ PORTVERSION?= 0.0.${SVNREV}
.if ${PORTNAME} == twiki
PNAME= core
.else
-USE_BZIP2= yes
+USES+= tar:bzip2
PKGNAMEPREFIX?= twiki-
PNAME= ${PORTNAME}
FILESDIR?= ${.CURDIR}/../twiki/files
diff --git a/www/ump/Makefile b/www/ump/Makefile
index 73fd755f5708..3098bdee979b 100644
--- a/www/ump/Makefile
+++ b/www/ump/Makefile
@@ -29,8 +29,7 @@ ZDIST= unix-sdk-3.0b5.tar.Z:plugin ump_with_volume.tar.Z:ump timdiffs.tar.Z:ump
TIMIDITY_VERSION= 2.13.2
-USES= gmake webplugin:native
-USE_BZIP2= yes
+USES= tar:bzip2 gmake webplugin:native
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ump --with-default-path=${LOCALBASE}/share/timidity
LDFLAGS+= -export-dynamic