aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-06-08 01:40:54 +0800
committerJason Helfman <jgh@FreeBSD.org>2012-06-08 01:40:54 +0800
commit9de183786dbf8c599cbb9d7c518734348e0ff809 (patch)
tree694319d0f28a47c76332a32a8e741c7468d85782 /www
parent35e57753215a278d99e191f7e671a2eafa2c4151 (diff)
downloadfreebsd-ports-gnome-9de183786dbf8c599cbb9d7c518734348e0ff809.tar.gz
freebsd-ports-gnome-9de183786dbf8c599cbb9d7c518734348e0ff809.tar.zst
freebsd-ports-gnome-9de183786dbf8c599cbb9d7c518734348e0ff809.zip
add new port: www/flot
Flot is a pure Javascript plotting library for jQuery. It produces graphical plots of arbitrary datasets on-the-fly client-side. The focus is on simple usage (all settings are optional), attractive looks and interactive features like zooming and mouse tracking. WWW: http://code.google.com/p/flot/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/flot/Makefile51
-rw-r--r--www/flot/distinfo2
-rw-r--r--www/flot/pkg-descr6
-rw-r--r--www/flot/pkg-plist29
5 files changed, 89 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d6a4faf8e949..d2a533d5b29d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -214,6 +214,7 @@
SUBDIR += flat-frog
SUBDIR += flickcurl
SUBDIR += flood
+ SUBDIR += flot
SUBDIR += fluxbb
SUBDIR += fluxcms
SUBDIR += fnord
diff --git a/www/flot/Makefile b/www/flot/Makefile
new file mode 100644
index 000000000000..1cb2b6222336
--- /dev/null
+++ b/www/flot/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: flot
+# Date created: 06 June 2012
+# Whom: Jason Helfman <jgh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flot
+PORTVERSION= 0.7
+CATEGORIES= www devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Javascript plotting library for jQuery
+
+LICENSE= MIT
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USERS= www
+GROUPS= www
+
+NO_BUILD= YES
+
+PORTDOCS= API.txt \
+ FAQ.txt \
+ NEWS.txt \
+ PLUGINS.txt \
+ README.txt
+PORTEXAMPLES= *
+
+do-install:
+ @${INSTALL} -d -g ${USERS} -o ${GROUPS} ${WWWDIR}
+ ${INSTALL_DATA} -o www -g www ${WRKSRC}/*.js ${WWWDIR}
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/flot/distinfo b/www/flot/distinfo
new file mode 100644
index 000000000000..b8f0f03ee7c5
--- /dev/null
+++ b/www/flot/distinfo
@@ -0,0 +1,2 @@
+SHA256 (flot-0.7.tar.gz) = bc24f661d6de1d38496b93147604174dd82b6c54359824cb1c9c4acd5eb55730
+SIZE (flot-0.7.tar.gz) = 288107
diff --git a/www/flot/pkg-descr b/www/flot/pkg-descr
new file mode 100644
index 000000000000..a86e4880cf90
--- /dev/null
+++ b/www/flot/pkg-descr
@@ -0,0 +1,6 @@
+Flot is a pure Javascript plotting library for jQuery. It produces graphical
+plots of arbitrary datasets on-the-fly client-side. The focus is on simple
+usage (all settings are optional), attractive looks and interactive features
+like zooming and mouse tracking.
+
+WWW: http://code.google.com/p/flot/
diff --git a/www/flot/pkg-plist b/www/flot/pkg-plist
new file mode 100644
index 000000000000..08dd18a963f4
--- /dev/null
+++ b/www/flot/pkg-plist
@@ -0,0 +1,29 @@
+%%WWWDIR%%/excanvas.js
+%%WWWDIR%%/excanvas.min.js
+%%WWWDIR%%/jquery.colorhelpers.js
+%%WWWDIR%%/jquery.colorhelpers.min.js
+%%WWWDIR%%/jquery.flot.crosshair.js
+%%WWWDIR%%/jquery.flot.crosshair.min.js
+%%WWWDIR%%/jquery.flot.fillbetween.js
+%%WWWDIR%%/jquery.flot.fillbetween.min.js
+%%WWWDIR%%/jquery.flot.image.js
+%%WWWDIR%%/jquery.flot.image.min.js
+%%WWWDIR%%/jquery.flot.js
+%%WWWDIR%%/jquery.flot.min.js
+%%WWWDIR%%/jquery.flot.navigate.js
+%%WWWDIR%%/jquery.flot.navigate.min.js
+%%WWWDIR%%/jquery.flot.pie.js
+%%WWWDIR%%/jquery.flot.pie.min.js
+%%WWWDIR%%/jquery.flot.resize.js
+%%WWWDIR%%/jquery.flot.resize.min.js
+%%WWWDIR%%/jquery.flot.selection.js
+%%WWWDIR%%/jquery.flot.selection.min.js
+%%WWWDIR%%/jquery.flot.stack.js
+%%WWWDIR%%/jquery.flot.stack.min.js
+%%WWWDIR%%/jquery.flot.symbol.js
+%%WWWDIR%%/jquery.flot.symbol.min.js
+%%WWWDIR%%/jquery.flot.threshold.js
+%%WWWDIR%%/jquery.flot.threshold.min.js
+%%WWWDIR%%/jquery.js
+%%WWWDIR%%/jquery.min.js
+@dirrmtry %%WWWDIR%%