aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2013-11-17 07:35:39 +0800
committerolgeni <olgeni@FreeBSD.org>2013-11-17 07:35:39 +0800
commit9dead556edf320b1850912b0e487e800e70b4645 (patch)
tree89d6ec1fa7f4627ba88a7ae15e018012b538198e /www
parentfaef8d21e66f89585eda307d176676ba3004a7a5 (diff)
downloadfreebsd-ports-gnome-9dead556edf320b1850912b0e487e800e70b4645.tar.gz
freebsd-ports-gnome-9dead556edf320b1850912b0e487e800e70b4645.tar.zst
freebsd-ports-gnome-9dead556edf320b1850912b0e487e800e70b4645.zip
- Upgrade to version 1.10.5.
- Remove redundant MASTER_SITES. - Disable "warnings_as_errors" for R16 compatibility.
Diffstat (limited to 'www')
-rw-r--r--www/webmachine/Makefile10
-rw-r--r--www/webmachine/distinfo4
-rw-r--r--www/webmachine/files/patch-rebar.config16
-rw-r--r--www/webmachine/pkg-plist8
4 files changed, 24 insertions, 14 deletions
diff --git a/www/webmachine/Makefile b/www/webmachine/Makefile
index 0af62dc1f3d3..60426fba2edc 100644
--- a/www/webmachine/Makefile
+++ b/www/webmachine/Makefile
@@ -1,10 +1,8 @@
# $FreeBSD$
PORTNAME= webmachine
-PORTVERSION= 1.10.1
-PORTREVISION= 1
+PORTVERSION= 1.10.5
CATEGORIES= www devel
-MASTER_SITES= GH
MAINTAINER= olgeni@FreeBSD.org
COMMENT= HTTP semantic awareness on top mochiweb
@@ -21,11 +19,15 @@ PLIST_SUB= VERSION="${PORTVERSION}"
USE_GITHUB= yes
GH_ACCOUNT= basho
GH_PROJECT= webmachine
-GH_COMMIT= d600c0e
+GH_COMMIT= 4e2d89c
GH_TAGNAME= ${PORTVERSION}
PORTDOCS= *
+post-patch:
+ @${REINPLACE_CMD} -e "s/{vsn, git}/{vsn,\"${PORTVERSION}\"}/" ${WRKSRC}/src/webmachine.app.src
+ @${RM} ${WRKSRC}/src/*.bak
+
do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
for FILE in README.org; do \
diff --git a/www/webmachine/distinfo b/www/webmachine/distinfo
index 6c8fc52f7834..f299540220fc 100644
--- a/www/webmachine/distinfo
+++ b/www/webmachine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webmachine-1.10.1.tar.gz) = cb0ce4822dfc4cb2d03c933d6c731a8dcc5d265054240a10b2a3a718bfd3cd3d
-SIZE (webmachine-1.10.1.tar.gz) = 1582684
+SHA256 (webmachine-1.10.5.tar.gz) = 67db129a78838063b7f528fe080b61fcd630399b46708fc0843db63df995ca37
+SIZE (webmachine-1.10.5.tar.gz) = 1625112
diff --git a/www/webmachine/files/patch-rebar.config b/www/webmachine/files/patch-rebar.config
index 968d5d221d17..f1762b21d3f4 100644
--- a/www/webmachine/files/patch-rebar.config
+++ b/www/webmachine/files/patch-rebar.config
@@ -3,11 +3,15 @@ $FreeBSD$
--- rebar.config.orig
+++ rebar.config
-@@ -4,6 +4,5 @@
+@@ -1,10 +1,6 @@
+ %%-*- mode: erlang -*-
+-{erl_opts, [warnings_as_errors]}.
+ {cover_enabled, true}.
{edoc_opts, [{preprocess, true}]}.
- {deps, [
-- {mochiweb, "1.5.1*", {git, "git://github.com/basho/mochiweb",
-- {tag, "1.5.1p5"}}}
-+ {mochiweb, "1.5.1*"}
- ]}.
+ {deps,
+- [{mochiweb, "1.5.1*", {git, "git://github.com/basho/mochiweb.git", {tag, "1.5.1p6"}}},
+- {meck, "0.8.1", {git, "git://github.com/basho/meck.git", {tag, "0.8.1"}}},
+- {ibrowse, "4.0.1", {git, "git://github.com/cmullaparthi/ibrowse.git", {tag, "v4.0.1"}}}
+- ]}.
++ [{mochiweb, "1.5.1*"}]}.
diff --git a/www/webmachine/pkg-plist b/www/webmachine/pkg-plist
index acd52cb81253..242e80ea3826 100644
--- a/www/webmachine/pkg-plist
+++ b/www/webmachine/pkg-plist
@@ -1,12 +1,14 @@
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine.app
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine.beam
+lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_access_log_handler.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_app.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_decision_core.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_deps.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_dispatcher.beam
+lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_error.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_error_handler.beam
+lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_error_log_handler.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_log.beam
-lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_log_handler.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_logger_watcher.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_logger_watcher_sup.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_mochiweb.beam
@@ -41,13 +43,15 @@ lib/erlang/lib/webmachine-%%VERSION%%/priv/trace/wmtrace.js
lib/erlang/lib/webmachine-%%VERSION%%/priv/www/index.html
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine.app.src
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine.erl
+lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_access_log_handler.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_app.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_decision_core.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_deps.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_dispatcher.erl
+lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_error.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_error_handler.erl
+lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_error_log_handler.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_log.erl
-lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_log_handler.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_logger_watcher.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_logger_watcher_sup.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_mochiweb.erl