aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-08-09 05:20:16 +0800
committerdirk <dirk@FreeBSD.org>2001-08-09 05:20:16 +0800
commita0cde34316e3e160d03c9553fa1d678e35bf6c6a (patch)
tree54e669a93f75afd5a599bcce1b2c4364ccf23fb3 /www
parent737ee1d07bdc9fc9fb92c1484d231d093ba6761b (diff)
downloadfreebsd-ports-gnome-a0cde34316e3e160d03c9553fa1d678e35bf6c6a.tar.gz
freebsd-ports-gnome-a0cde34316e3e160d03c9553fa1d678e35bf6c6a.tar.zst
freebsd-ports-gnome-a0cde34316e3e160d03c9553fa1d678e35bf6c6a.zip
Add support for OpenLDAP2.
Note that OpenLDAP1 and OpenLDAP are mutually exclusive, because the corresponding ports install some common files. PR: ports/29118 Submitted by: Chris Knight <chris@aims.com.au>
Diffstat (limited to 'www')
-rw-r--r--www/mod_php4/scripts/configure.php25
-rw-r--r--www/mod_php5/scripts/configure.php25
2 files changed, 46 insertions, 4 deletions
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 40c068fceac4..caaf690fc41a 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -25,7 +25,8 @@ SybaseDB "Sybase/MS-SQL database support (DB-lib)" OFF \
SybaseCT "Sybase/MS-SQL database support (CT-lib)" OFF \
Interbase "Interbase 6 database support (Firebird)" OFF \
dBase "dBase database support" OFF \
-OpenLDAP "OpenLDAP support" OFF \
+OpenLDAP1 "OpenLDAP 1.x support" OFF \
+OpenLDAP2 "OpenLDAP 2.x support" OFF \
OpenSSL "OpenSSL support" OFF \
SNMP "SNMP support" OFF \
XML "XML support" OFF \
@@ -153,13 +154,33 @@ while [ "$1" ]; do
\"dBase\")
echo "CONFIGURE_ARGS+=--with-dbase"
;;
- \"OpenLDAP\")
+ \"OpenLDAP1\")
echo "LIB_DEPENDS+= ldap.1:\${PORTSDIR}/net/openldap"
echo "LIB_DEPENDS+= lber.1:\${PORTSDIR}/net/openldap"
echo "CONFIGURE_ARGS+=--with-ldap=\${PREFIX}"
+ if [ "$OPENLDAP2" ]; then
+ echo "OpenLDAP1 and OpenLDAP2 are mutually exclusive." > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ exit 1
+ fi
+ if [ -f /usr/lib/libkrb.a -a -f /usr/lib/libdes.a -a ! -L /usr/lib/libdes.a ]; then
+ LIBS="${LIBS} -lkrb -ldes -L\${PREFIX}/lib"
+ fi
+ OPENLDAP1=1
+ ;;
+ \"OpenLDAP2\")
+ echo "LIB_DEPENDS+= ldap.2:\${PORTSDIR}/net/openldap2"
+ echo "LIB_DEPENDS+= lber.2:\${PORTSDIR}/net/openldap2"
+ echo "CONFIGURE_ARGS+=--with-ldap=\${PREFIX}"
+ if [ "$OPENLDAP1" ]; then
+ echo "OpenLDAP1 and OpenLDAP2 are mutually exclusive." > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ exit 1
+ fi
if [ -f /usr/lib/libkrb.a -a -f /usr/lib/libdes.a -a ! -L /usr/lib/libdes.a ]; then
LIBS="${LIBS} -lkrb -ldes -L\${PREFIX}/lib"
fi
+ OPENLDAP2=1
;;
\"OpenSSL\")
echo "USE_OPENSSL=yes"
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 40c068fceac4..caaf690fc41a 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -25,7 +25,8 @@ SybaseDB "Sybase/MS-SQL database support (DB-lib)" OFF \
SybaseCT "Sybase/MS-SQL database support (CT-lib)" OFF \
Interbase "Interbase 6 database support (Firebird)" OFF \
dBase "dBase database support" OFF \
-OpenLDAP "OpenLDAP support" OFF \
+OpenLDAP1 "OpenLDAP 1.x support" OFF \
+OpenLDAP2 "OpenLDAP 2.x support" OFF \
OpenSSL "OpenSSL support" OFF \
SNMP "SNMP support" OFF \
XML "XML support" OFF \
@@ -153,13 +154,33 @@ while [ "$1" ]; do
\"dBase\")
echo "CONFIGURE_ARGS+=--with-dbase"
;;
- \"OpenLDAP\")
+ \"OpenLDAP1\")
echo "LIB_DEPENDS+= ldap.1:\${PORTSDIR}/net/openldap"
echo "LIB_DEPENDS+= lber.1:\${PORTSDIR}/net/openldap"
echo "CONFIGURE_ARGS+=--with-ldap=\${PREFIX}"
+ if [ "$OPENLDAP2" ]; then
+ echo "OpenLDAP1 and OpenLDAP2 are mutually exclusive." > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ exit 1
+ fi
+ if [ -f /usr/lib/libkrb.a -a -f /usr/lib/libdes.a -a ! -L /usr/lib/libdes.a ]; then
+ LIBS="${LIBS} -lkrb -ldes -L\${PREFIX}/lib"
+ fi
+ OPENLDAP1=1
+ ;;
+ \"OpenLDAP2\")
+ echo "LIB_DEPENDS+= ldap.2:\${PORTSDIR}/net/openldap2"
+ echo "LIB_DEPENDS+= lber.2:\${PORTSDIR}/net/openldap2"
+ echo "CONFIGURE_ARGS+=--with-ldap=\${PREFIX}"
+ if [ "$OPENLDAP1" ]; then
+ echo "OpenLDAP1 and OpenLDAP2 are mutually exclusive." > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ exit 1
+ fi
if [ -f /usr/lib/libkrb.a -a -f /usr/lib/libdes.a -a ! -L /usr/lib/libdes.a ]; then
LIBS="${LIBS} -lkrb -ldes -L\${PREFIX}/lib"
fi
+ OPENLDAP2=1
;;
\"OpenSSL\")
echo "USE_OPENSSL=yes"