aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-02-20 23:56:32 +0800
committerMartin Wilke <miwi@FreeBSD.org>2016-02-20 23:56:32 +0800
commita43ed4d6bafa8ba4f45564f16a7952c4a468d1e8 (patch)
treeeb736792c590facd362c089b53bbbeec1d7b001d /www
parent0581fbda398c9c443c3edabc69c29b02d1af5d40 (diff)
downloadfreebsd-ports-gnome-a43ed4d6bafa8ba4f45564f16a7952c4a468d1e8.tar.gz
freebsd-ports-gnome-a43ed4d6bafa8ba4f45564f16a7952c4a468d1e8.tar.zst
freebsd-ports-gnome-a43ed4d6bafa8ba4f45564f16a7952c4a468d1e8.zip
- Fix postgres support for redmine2
PR: 207007 Submitted by: Johannes Jost Meixner <johannes@meixner.dk>
Diffstat (limited to 'www')
-rw-r--r--www/redmine/Makefile2
-rw-r--r--www/redmine/files/patch-Gemfile11
2 files changed, 11 insertions, 2 deletions
diff --git a/www/redmine/Makefile b/www/redmine/Makefile
index 8a1a29e8a909..6fb4524574b8 100644
--- a/www/redmine/Makefile
+++ b/www/redmine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= redmine
PORTVERSION= 2.6.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.redmine.org/releases/
diff --git a/www/redmine/files/patch-Gemfile b/www/redmine/files/patch-Gemfile
index db4fed010525..f99634279046 100644
--- a/www/redmine/files/patch-Gemfile
+++ b/www/redmine/files/patch-Gemfile
@@ -1,4 +1,4 @@
---- Gemfile.orig 2015-12-09 23:40:39 UTC
+--- Gemfile.orig 2015-12-05 08:47:22 UTC
+++ Gemfile
@@ -1,37 +1,29 @@
source 'https://rubygems.org'
@@ -44,6 +44,15 @@
# Optional Markdown support, not for JRuby
group :markdown do
gem "redcarpet", (RUBY_VERSION < "1.9" ? "~> 2.3.0" : "~> 3.3.2")
+@@ -62,7 +54,7 @@ if File.exist?(database_file)
+ gem "mysql", "~> 2.8.1", :platforms => [:mri, :mingw]
+ gem "activerecord-jdbcmysql-adapter", :platforms => :jruby
+ when /postgresql/
+- gem "pg", "~> 0.17.1", :platforms => [:mri, :mingw]
++ gem "pg", "~> 0.18.4", :platforms => [:mri, :mingw]
+ gem "activerecord-jdbcpostgresql-adapter", :platforms => :jruby
+ when /sqlite3/
+ gem "sqlite3", :platforms => [:mri, :mingw]
@@ -82,23 +74,6 @@ else
warn("Please configure your config/database.yml first")
end