aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2007-10-15 23:35:25 +0800
committergarga <garga@FreeBSD.org>2007-10-15 23:35:25 +0800
commita45468271c4cc28f07f100719609a750bc911ee5 (patch)
tree46054c7eaaa31a204f5814462977ed5653639ce7 /www
parentf797cd8537dcac8a2eebf2e4e66841e9c4287200 (diff)
downloadfreebsd-ports-gnome-a45468271c4cc28f07f100719609a750bc911ee5.tar.gz
freebsd-ports-gnome-a45468271c4cc28f07f100719609a750bc911ee5.tar.zst
freebsd-ports-gnome-a45468271c4cc28f07f100719609a750bc911ee5.zip
- Unbreak
PR: ports/117135 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/mod_clamav/Makefile2
-rw-r--r--www/mod_clamav/files/patch-mod_clamav.c25
2 files changed, 25 insertions, 2 deletions
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index a4028168096e..7b8ec281b6e0 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -14,8 +14,6 @@ MASTER_SITES= http://software.othello.ch/mod_clamav/
MAINTAINER= tmueko@kommunity.net
COMMENT= Scans content delivered by the Apache2 proxy module for viruses
-BROKEN= doesn't work since cl_buildtrie() and cl_freetrie() where removed from clamlib (upstream problem)
-
LIB_DEPENDS+= clamav:${PORTSDIR}/${CLAMAV_PORT}
USE_AUTOTOOLS= libtool:15
diff --git a/www/mod_clamav/files/patch-mod_clamav.c b/www/mod_clamav/files/patch-mod_clamav.c
new file mode 100644
index 000000000000..c31ed1ff1100
--- /dev/null
+++ b/www/mod_clamav/files/patch-mod_clamav.c
@@ -0,0 +1,25 @@
+--- mod_clamav.c.bak Fri Oct 12 10:03:41 2007
++++ mod_clamav.c Fri Oct 12 10:02:09 2007
+@@ -102,6 +102,22 @@
+ unsigned long reloads; /* number of database reloads (local) */
+ } clamav_stats;
+
++const char *cl_perror(int clerror) /* deprecated */
++{
++ return cl_strerror(clerror);
++}
++
++void cl_freetrie(struct cl_node *root) /* for backward compatibility */
++{
++ cl_free(root);
++}
++
++int cl_buildtrie(struct cl_node *root) /* for backward compatibility */
++{
++ return cl_build(root);
++}
++
++
+ static void clamav_virus_record(clamav_stats *stats, const char *uri,
+ const char *req, const char *virus, off_t size) {
+ /* find the index of the entry we are about to create */