aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-09-18 23:15:39 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-09-18 23:15:39 +0800
commita479d725c0bcbbad5e116bcccb391ede4fddbf61 (patch)
treef3417b65461ab6f62699efc2a4bd08dd73f7c24f /www
parent9041579843ff5c6a45f4ad57f0b196f9310678f0 (diff)
downloadfreebsd-ports-gnome-a479d725c0bcbbad5e116bcccb391ede4fddbf61.tar.gz
freebsd-ports-gnome-a479d725c0bcbbad5e116bcccb391ede4fddbf61.tar.zst
freebsd-ports-gnome-a479d725c0bcbbad5e116bcccb391ede4fddbf61.zip
- Drop .la files, no dependees require them
- Add LICENSE_FILE - Add patches to build with clang, drop USE_GCC (which breaks squid) Approved by: portmgr blanket
Diffstat (limited to 'www')
-rw-r--r--www/libecap/Makefile6
-rw-r--r--www/libecap/files/patch-src__libecap__common__area.cc13
-rw-r--r--www/libecap/files/patch-src__libecap__common__area.h25
-rw-r--r--www/libecap/files/patch-src__libecap__common__memory.h26
-rw-r--r--www/libecap/pkg-plist1
5 files changed, 67 insertions, 4 deletions
diff --git a/www/libecap/Makefile b/www/libecap/Makefile
index b78f113885ca..f574a7047388 100644
--- a/www/libecap/Makefile
+++ b/www/libecap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libecap
PORTVERSION= 0.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www security
MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/
@@ -11,14 +11,14 @@ MAINTAINER= tmseck@FreeBSD.org
COMMENT= Library for module based network content analysis
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= DOCS
-USES= libtool:keepla
+USES= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GCC= any
INSTALL_TARGET= install-strip
PORTDOCS= CREDITS LICENSE NOTICE README
diff --git a/www/libecap/files/patch-src__libecap__common__area.cc b/www/libecap/files/patch-src__libecap__common__area.cc
new file mode 100644
index 000000000000..70787542f046
--- /dev/null
+++ b/www/libecap/files/patch-src__libecap__common__area.cc
@@ -0,0 +1,13 @@
+--- src/libecap/common/area.cc.orig 2010-12-17 21:08:50.000000000 +0300
++++ src/libecap/common/area.cc 2014-09-12 15:11:20.000000000 +0400
+@@ -14,8 +14,8 @@
+
+
+ libecap::Area libecap::Area::FromTempString(const std::string &tmp) {
+- shared_ptr<StdStringAreaDetails> details(new StdStringAreaDetails(tmp));
+- return Area(details->owner_.data(), details->owner_.size(), details);
++ shared_ptr<StdStringAreaDetails> detls(new StdStringAreaDetails(tmp));
++ return Area(detls->owner_.data(), detls->owner_.size(), detls);
+ }
+
+ libecap::Area libecap::Area::FromTempBuffer(const char *start, libecap::size_type size) {
diff --git a/www/libecap/files/patch-src__libecap__common__area.h b/www/libecap/files/patch-src__libecap__common__area.h
new file mode 100644
index 000000000000..f9d0ba224d70
--- /dev/null
+++ b/www/libecap/files/patch-src__libecap__common__area.h
@@ -0,0 +1,25 @@
+--- src/libecap/common/area.h.orig 2011-02-17 21:04:23.000000000 +0300
++++ src/libecap/common/area.h 2014-09-12 15:16:00.000000000 +0400
+@@ -45,7 +45,8 @@
+ Details details; // creator-defined
+
+ private:
+- bool does_not_support_comparisons() const; // not implemented
++ template<typename T> bool operator==(const T&) {}
++ template<typename T> bool operator!=(const T&) {}
+ };
+
+ // this stub can be enhanced by area creators to optimize area operations
+@@ -57,10 +58,8 @@
+ std::ostream &operator <<(std::ostream &os, const Area &area);
+
+ /* make Area comparisons illegal by default */
+-template <typename T> bool operator ==(const Area &a, const T &) { return a.does_not_support_comparisons(); }
+-template <typename T> bool operator !=(const Area &a, const T &) { return a.does_not_support_comparisons(); }
+-template <typename T> bool operator ==(const T &, const Area &a) { return a.does_not_support_comparisons(); }
+-template <typename T> bool operator !=(const T &, const Area &a) { return a.does_not_support_comparisons(); }
++template <typename T> bool operator ==(const T &t, const Area &a) { return a == t; }
++template <typename T> bool operator !=(const T &t, const Area &a) { return a != t; }
+
+ } // namespace libecap
+
diff --git a/www/libecap/files/patch-src__libecap__common__memory.h b/www/libecap/files/patch-src__libecap__common__memory.h
new file mode 100644
index 000000000000..ef85435a65d9
--- /dev/null
+++ b/www/libecap/files/patch-src__libecap__common__memory.h
@@ -0,0 +1,26 @@
+--- src/libecap/common/memory.h.orig 2010-05-26 01:27:41.000000000 +0400
++++ src/libecap/common/memory.h 2014-09-12 15:06:36.000000000 +0400
+@@ -4,14 +4,23 @@
+ #define LIBECAP__COMMON_MEMORY_H
+
+ #include <libecap/common/libecap.h>
++#if defined(_LIBCPP_VERSION)
++#include <memory>
++#else
+ #include <tr1/memory>
++#endif
+
+ // TODO: add support for boost pointers if std::tr1 is not available
+
+ namespace libecap {
+
++#if defined(_LIBCPP_VERSION)
++using std::weak_ptr;
++using std::shared_ptr;
++#else
+ using std::tr1::weak_ptr;
+ using std::tr1::shared_ptr;
++#endif
+
+ } // namespace libecap
+
diff --git a/www/libecap/pkg-plist b/www/libecap/pkg-plist
index 8c201dcd6eb5..f62604360ac9 100644
--- a/www/libecap/pkg-plist
+++ b/www/libecap/pkg-plist
@@ -22,7 +22,6 @@ include/libecap/common/version.h
include/libecap/host/host.h
include/libecap/host/xaction.h
lib/libecap.a
-lib/libecap.la
lib/libecap.so
lib/libecap.so.2
lib/libecap.so.2.0.0