aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2014-01-21 23:54:33 +0800
committerlwhsu <lwhsu@FreeBSD.org>2014-01-21 23:54:33 +0800
commita491dfa66f33a66bdce12260f8d5b7a55cfce30f (patch)
tree3db1bca3d9fd31f3a235e5017fb031450e49f4de /www
parentf7cc96dcf22648d5788d47106607e1d04a5eb069 (diff)
downloadfreebsd-ports-gnome-a491dfa66f33a66bdce12260f8d5b7a55cfce30f.tar.gz
freebsd-ports-gnome-a491dfa66f33a66bdce12260f8d5b7a55cfce30f.tar.zst
freebsd-ports-gnome-a491dfa66f33a66bdce12260f8d5b7a55cfce30f.zip
Add devel/pear-channel-twig, www/pecl-twig, www/pear-twig:
TWIG: The flexible, fast, and secure template engine for PHP PR: ports/181848 Submitted by: Joe Horn <joehorn@gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/pear-twig/Makefile26
-rw-r--r--www/pear-twig/distinfo2
-rw-r--r--www/pear-twig/pkg-descr15
-rw-r--r--www/pecl-twig/Makefile21
-rw-r--r--www/pecl-twig/distinfo2
-rw-r--r--www/pecl-twig/pkg-descr5
7 files changed, 73 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 53adcd92d66f..17b3ec538e71 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1401,6 +1401,7 @@
SUBDIR += pear-Text_Wiki
SUBDIR += pear-UDDI
SUBDIR += pear-XML_GRDDL
+ SUBDIR += pear-twig
SUBDIR += pebble
SUBDIR += pecl-APC
SUBDIR += pecl-amfext
@@ -1408,6 +1409,7 @@
SUBDIR += pecl-solr
SUBDIR += pecl-sphinx
SUBDIR += pecl-swish
+ SUBDIR += pecl-twig
SUBDIR += pecl-yaf
SUBDIR += pecl-yar
SUBDIR += pecl-zendopcache
diff --git a/www/pear-twig/Makefile b/www/pear-twig/Makefile
new file mode 100644
index 000000000000..2ab384ff53f6
--- /dev/null
+++ b/www/pear-twig/Makefile
@@ -0,0 +1,26 @@
+# Created by: Joe Horn <joehorn@gmail.com>
+# $FreeBSD$
+
+PORTNAME= twig
+PORTVERSION= 1.15.0
+CATEGORIES= www pear
+MASTER_SITES= http://pear.twig-project.org/get/
+DISTNAME= Twig-${PORTVERSION}
+
+MAINTAINER= joehorn@gmail.com
+COMMENT= The flexible, fast, and secure template engine for PHP
+
+LICENSE= BSD
+
+BUILD_DEPENDS= ${PEARDIR}/.channels/pear.twig-project.org.reg:${PORTSDIR}/devel/pear-channel-twig
+RUN_DEPENDS= ${PEARDIR}/.channels/pear.twig-project.org.reg:${PORTSDIR}/devel/pear-channel-twig
+
+PEAR_CHANNEL= twig
+PEAR_AUTOINSTALL= yes
+
+USE_PHP= ctype hash
+WANT_PHP_CLI= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-twig/distinfo b/www/pear-twig/distinfo
new file mode 100644
index 000000000000..adbd676dafbd
--- /dev/null
+++ b/www/pear-twig/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/Twig-1.15.0.tgz) = b5a1ae1be5fd3541f9dcf9f3f516e29262f3db18042b67a1af07bfaa26eb61ed
+SIZE (PEAR/Twig-1.15.0.tgz) = 85352
diff --git a/www/pear-twig/pkg-descr b/www/pear-twig/pkg-descr
new file mode 100644
index 000000000000..7057deb96ef6
--- /dev/null
+++ b/www/pear-twig/pkg-descr
@@ -0,0 +1,15 @@
+Twig is a modern template engine for PHP.
+
+ * Fast: Twig compiles templates down to plain optimized PHP code. The
+ overhead compared to regular PHP code was reduced to the very
+ minimum.
+
+ * Secure: Twig has a sandbox mode to evaluate untrusted template code.
+ This allows Twig to be used as a template language for
+ applications where users may modify the template design.
+
+ * Flexible: Twig is powered by a flexible lexer and parser. This allows
+ the developer to define its own custom tags and filters, and
+ create its own DSL.
+
+WWW: http://twig.sensiolabs.org/
diff --git a/www/pecl-twig/Makefile b/www/pecl-twig/Makefile
new file mode 100644
index 000000000000..0282abc285bd
--- /dev/null
+++ b/www/pecl-twig/Makefile
@@ -0,0 +1,21 @@
+# Created by: Joe Horn <joehorn@gmail.com>
+# $FreeBSD$
+
+PORTNAME= twig
+PORTVERSION= 1.15.0
+CATEGORIES= www
+MASTER_SITES= http://pear.twig-project.org/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= CTwig-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= joehorn@gmail.com
+COMMENT= Twig C extension to improve performance of the Twig template language
+
+LICENSE= BSD
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/www/pecl-twig/distinfo b/www/pecl-twig/distinfo
new file mode 100644
index 000000000000..b1247b19d252
--- /dev/null
+++ b/www/pecl-twig/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CTwig-1.15.0.tgz) = dda8f01c24c2d2ed51916668f7bc66782a7aac211a3752a80b35159bda85dfd4
+SIZE (CTwig-1.15.0.tgz) = 8835
diff --git a/www/pecl-twig/pkg-descr b/www/pecl-twig/pkg-descr
new file mode 100644
index 000000000000..6dd80eabce16
--- /dev/null
+++ b/www/pecl-twig/pkg-descr
@@ -0,0 +1,5 @@
+Twig is a flexible, fast, and secure template engine for PHP.
+
+This C extension to improve performance of the Twig template language.
+
+WWW: http://twig.sensiolabs.org/