aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
committermat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
commita4af234af8f51d40eb998ed6d368ccea401a3302 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /www
parent56be8553fe553c4526347278fbdd90ec4156eb14 (diff)
downloadfreebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.gz
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.zst
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Diffstat (limited to 'www')
-rw-r--r--www/libmicrohttpd/Makefile2
-rw-r--r--www/spdylay/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/www/libmicrohttpd/Makefile b/www/libmicrohttpd/Makefile
index df0c583c6568..c137fee20cae 100644
--- a/www/libmicrohttpd/Makefile
+++ b/www/libmicrohttpd/Makefile
@@ -41,7 +41,7 @@ PLIST_FILES= include/microhttpd.h \
.include <bsd.port.pre.mk>
-.if !(defined(WITH_OPENSSL_BASE) && ${OPSYS} == FreeBSD && ${OSVERSION} < 1000015)
+.if !(${SSL_DEFAULT} == base && ${OPSYS} == FreeBSD && ${OSVERSION} < 1000015)
PLIST_FILES+= include/microspdy.h \
lib/libmicrospdy.a \
lib/libmicrospdy.so \
diff --git a/www/spdylay/Makefile b/www/spdylay/Makefile
index bc535ba7035c..6a27e5e1b23f 100644
--- a/www/spdylay/Makefile
+++ b/www/spdylay/Makefile
@@ -37,7 +37,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000000 && !defined(WITH_OPENSSL_PORT)
+.if ${OSVERSION} < 1000000 && ${SSL_DEFAULT} == base
IGNORE= spdylay requires OpenSSL 1.0.1+
.endif