aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-04 01:35:59 +0800
committergarga <garga@FreeBSD.org>2005-10-04 01:35:59 +0800
commita4f06e153bcfe0cf05c20abb26b9717cbb3e2a56 (patch)
tree869df73e7eae6c62c8b39fa3ce2138a1fcd87292 /www
parentfff6677ba6d673cc7fbdd31faaa97106eb4f92a3 (diff)
downloadfreebsd-ports-gnome-a4f06e153bcfe0cf05c20abb26b9717cbb3e2a56.tar.gz
freebsd-ports-gnome-a4f06e153bcfe0cf05c20abb26b9717cbb3e2a56.tar.zst
freebsd-ports-gnome-a4f06e153bcfe0cf05c20abb26b9717cbb3e2a56.zip
Add moodle 1.5.2, course management system based on social
constructionism. PR: ports/86764 Submitted by: Javier Martin Rueda <jmrueda@diatel.upm.es>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/moodle/Makefile61
-rw-r--r--www/moodle/distinfo2
-rw-r--r--www/moodle/pkg-descr7
-rw-r--r--www/moodle/pkg-message36
-rw-r--r--www/moodle2/Makefile61
-rw-r--r--www/moodle2/distinfo2
-rw-r--r--www/moodle2/pkg-descr7
-rw-r--r--www/moodle2/pkg-message36
9 files changed, 213 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 20dcd7effc51..fb8200a82dc8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -367,6 +367,7 @@
SUBDIR += moinmoin
SUBDIR += momspider
SUBDIR += monkey
+ SUBDIR += moodle
SUBDIR += mozex
SUBDIR += mozex-firefox
SUBDIR += mozilla
diff --git a/www/moodle/Makefile b/www/moodle/Makefile
new file mode 100644
index 000000000000..2ed2dff5641b
--- /dev/null
+++ b/www/moodle/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: moodle
+# Date created: 30 September 2005
+# Whom: Javier Martin Rueda <jmrueda@diatel.upm.es>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moodle
+PORTVERSION= 1.5.2
+CATEGORIES= www
+MASTER_SITES= http://download.moodle.org/stable15/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jmrueda@diatel.upm.es
+COMMENT= Course management system based on social constructionism
+
+WRKSRC= ${WRKDIR}/moodle
+
+USE_PHP= session gd pcre
+
+.if defined(WITH_MYSQL)
+USE_PHP+= mysql
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.include <bsd.port.pre.mk>
+
+NO_BUILD= yes
+
+MOODLEDIR?= www/data/moodle
+MOODLEDATADIR?= www/data/moodledata
+
+pre-everything::
+ @${ECHO_CMD} "===> You can use the following options:"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "o WITH_MYSQL - Use a MySQL database"
+ @${ECHO_CMD} "o WITH_PGSQL - Use a pgSQL database"
+ @${ECHO_CMD} ""
+
+post-patch:
+####This is an old patched file.
+ @${RM} -f ${WRKSRC}/lang/es_es/moodle.php.orig
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
+ @${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}
+
+do-install:
+ ${INSTALL_DATA} -d ${PREFIX}/${MOODLEDIR}
+ ${CP} -Rn ${WRKSRC}/* ${PREFIX}/${MOODLEDIR}
+ ${FIND} ${PREFIX}/${MOODLEDIR} -type d -exec ${CHMOD} a+x {} \;
+ ${MKDIR} ${PREFIX}/${MOODLEDATADIR}
+ ${CHOWN} www ${PREFIX}/${MOODLEDATADIR}
+ ${CHMOD} 755 ${PREFIX}/${MOODLEDATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/moodle/distinfo b/www/moodle/distinfo
new file mode 100644
index 000000000000..adc02c46415b
--- /dev/null
+++ b/www/moodle/distinfo
@@ -0,0 +1,2 @@
+MD5 (moodle-1.5.2.tgz) = 43d484170cc7e364df68239f352528bc
+SIZE (moodle-1.5.2.tgz) = 14222897
diff --git a/www/moodle/pkg-descr b/www/moodle/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/
diff --git a/www/moodle/pkg-message b/www/moodle/pkg-message
new file mode 100644
index 000000000000..b92b9ad6a89e
--- /dev/null
+++ b/www/moodle/pkg-message
@@ -0,0 +1,36 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ NOTE: this package assumes that either the php4-pgsql
+ or php4-mysql packages are installed, as needed.
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ AcceptPathInfo On
+ <Directory ${PREFIX}/www/data/moodledata>
+ AllowOverride None
+ Order Deny,Allow
+ Deny from all
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account etc.
+
+4) Set up a cron task to call the file admin/cron.php
+ every five minutes or so. You can do so by using wget,
+ links or something similar to open the web page
+ http://your.server.com/moodle/admin/cron.php.
+
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://moodle.org/doc
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle2/Makefile b/www/moodle2/Makefile
new file mode 100644
index 000000000000..2ed2dff5641b
--- /dev/null
+++ b/www/moodle2/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: moodle
+# Date created: 30 September 2005
+# Whom: Javier Martin Rueda <jmrueda@diatel.upm.es>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moodle
+PORTVERSION= 1.5.2
+CATEGORIES= www
+MASTER_SITES= http://download.moodle.org/stable15/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jmrueda@diatel.upm.es
+COMMENT= Course management system based on social constructionism
+
+WRKSRC= ${WRKDIR}/moodle
+
+USE_PHP= session gd pcre
+
+.if defined(WITH_MYSQL)
+USE_PHP+= mysql
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.include <bsd.port.pre.mk>
+
+NO_BUILD= yes
+
+MOODLEDIR?= www/data/moodle
+MOODLEDATADIR?= www/data/moodledata
+
+pre-everything::
+ @${ECHO_CMD} "===> You can use the following options:"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "o WITH_MYSQL - Use a MySQL database"
+ @${ECHO_CMD} "o WITH_PGSQL - Use a pgSQL database"
+ @${ECHO_CMD} ""
+
+post-patch:
+####This is an old patched file.
+ @${RM} -f ${WRKSRC}/lang/es_es/moodle.php.orig
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
+ @${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}
+
+do-install:
+ ${INSTALL_DATA} -d ${PREFIX}/${MOODLEDIR}
+ ${CP} -Rn ${WRKSRC}/* ${PREFIX}/${MOODLEDIR}
+ ${FIND} ${PREFIX}/${MOODLEDIR} -type d -exec ${CHMOD} a+x {} \;
+ ${MKDIR} ${PREFIX}/${MOODLEDATADIR}
+ ${CHOWN} www ${PREFIX}/${MOODLEDATADIR}
+ ${CHMOD} 755 ${PREFIX}/${MOODLEDATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/moodle2/distinfo b/www/moodle2/distinfo
new file mode 100644
index 000000000000..adc02c46415b
--- /dev/null
+++ b/www/moodle2/distinfo
@@ -0,0 +1,2 @@
+MD5 (moodle-1.5.2.tgz) = 43d484170cc7e364df68239f352528bc
+SIZE (moodle-1.5.2.tgz) = 14222897
diff --git a/www/moodle2/pkg-descr b/www/moodle2/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle2/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/
diff --git a/www/moodle2/pkg-message b/www/moodle2/pkg-message
new file mode 100644
index 000000000000..b92b9ad6a89e
--- /dev/null
+++ b/www/moodle2/pkg-message
@@ -0,0 +1,36 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ NOTE: this package assumes that either the php4-pgsql
+ or php4-mysql packages are installed, as needed.
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ AcceptPathInfo On
+ <Directory ${PREFIX}/www/data/moodledata>
+ AllowOverride None
+ Order Deny,Allow
+ Deny from all
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account etc.
+
+4) Set up a cron task to call the file admin/cron.php
+ every five minutes or so. You can do so by using wget,
+ links or something similar to open the web page
+ http://your.server.com/moodle/admin/cron.php.
+
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://moodle.org/doc
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.