aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2007-04-06 16:22:49 +0800
committerlbr <lbr@FreeBSD.org>2007-04-06 16:22:49 +0800
commita5c4c1ccfb5337733819c31f8bc9236dbfa56562 (patch)
tree106499589ee2ee6ddac6ed05489434825bf61de1 /www
parent401df3c0502fbdb664834f6b244f2df6d528c18d (diff)
downloadfreebsd-ports-gnome-a5c4c1ccfb5337733819c31f8bc9236dbfa56562.tar.gz
freebsd-ports-gnome-a5c4c1ccfb5337733819c31f8bc9236dbfa56562.tar.zst
freebsd-ports-gnome-a5c4c1ccfb5337733819c31f8bc9236dbfa56562.zip
New port: www/p5-Catalyst-Plugin-Cache, Flexible caching support for Catalyst
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Cache/Makefile39
-rw-r--r--www/p5-Catalyst-Plugin-Cache/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Cache/pkg-descr9
-rw-r--r--www/p5-Catalyst-Plugin-Cache/pkg-plist17
5 files changed, 69 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 02f37e00568d..62ce09ea928c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -589,6 +589,7 @@
SUBDIR += p5-Catalyst-Plugin-Authorization-ACL
SUBDIR += p5-Catalyst-Plugin-Authorization-Roles
SUBDIR += p5-Catalyst-Plugin-C3
+ SUBDIR += p5-Catalyst-Plugin-Cache
SUBDIR += p5-Catalyst-Plugin-Cache-FastMmap
SUBDIR += p5-Catalyst-Plugin-Cache-FileCache
SUBDIR += p5-Catalyst-Plugin-Cache-Memcached
diff --git a/www/p5-Catalyst-Plugin-Cache/Makefile b/www/p5-Catalyst-Plugin-Cache/Makefile
new file mode 100644
index 000000000000..06e3a2c97819
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Cache
+# Date created: Apr 5, 2007
+# Whom: lbr@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Cache
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Flexible caching support for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Cache.3 \
+ Catalyst::Plugin::Cache::Backend.3 \
+ Catalyst::Plugin::Cache::Backend::Memory.3 \
+ Catalyst::Plugin::Cache::Choose::KeyRegexes.3 \
+ Catalyst::Plugin::Cache::Curried.3 \
+ Catalyst::Plugin::Cache::Store.3 \
+ Catalyst::Plugin::Cache::Store::Memory.3
+
+post-extract:
+ @${PERL} -i.bak -ne 'print unless m,Test::,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Cache/distinfo b/www/p5-Catalyst-Plugin-Cache/distinfo
new file mode 100644
index 000000000000..0820087e770b
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Cache-0.02.tar.gz) = ad6faaa16d91f7bdb2cdb1fb9a07716a
+SHA256 (Catalyst-Plugin-Cache-0.02.tar.gz) = d42fe22494e2b4c93d0363447e6b945c2332783a3589fa3a18dcff498cf58808
+SIZE (Catalyst-Plugin-Cache-0.02.tar.gz) = 12204
diff --git a/www/p5-Catalyst-Plugin-Cache/pkg-descr b/www/p5-Catalyst-Plugin-Cache/pkg-descr
new file mode 100644
index 000000000000..8dfb8493dfd4
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache/pkg-descr
@@ -0,0 +1,9 @@
+This plugin gives you access to a variety of systems for caching
+data. It allows you to use a very simple configuration API, while
+maintaining the possibility of flexibility when you need it later.
+
+Among its features are support for multiple backends, segmentation based
+on component or controller, keyspace partitioning, and so more, in
+various subsidiary plugins.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Cache/
diff --git a/www/p5-Catalyst-Plugin-Cache/pkg-plist b/www/p5-Catalyst-Plugin-Cache/pkg-plist
new file mode 100644
index 000000000000..b0d2889a9a21
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/Catalyst/Plugin/Cache.pm
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Backend.pm
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Backend/Memory.pm
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Choose/KeyRegexes.pm
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Curried.pm
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Store.pod
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Store/Memory.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Cache/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Cache
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Cache/Store
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Cache/Choose
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Cache/Backend
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Cache
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst