aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-04-28 02:25:24 +0800
committermva <mva@FreeBSD.org>2013-04-28 02:25:24 +0800
commita99e7e687dd8959b456b245eeaafe101878e92d8 (patch)
tree05c37dd385b99b953046290a1ad749042e2d1c51 /www
parente43c5466309ee34db1fde989beb22aa3f35d27ec (diff)
downloadfreebsd-ports-gnome-a99e7e687dd8959b456b245eeaafe101878e92d8.tar.gz
freebsd-ports-gnome-a99e7e687dd8959b456b245eeaafe101878e92d8.tar.zst
freebsd-ports-gnome-a99e7e687dd8959b456b245eeaafe101878e92d8.zip
- Convert USE_ICONV=yes to USES=iconv
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig and USE_GETTEXT=yes to USES=gettext while here
Diffstat (limited to 'www')
-rw-r--r--www/anyterm/Makefile2
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache24/Makefile2
-rw-r--r--www/awffull/Makefile3
-rw-r--r--www/cadaver/Makefile3
-rw-r--r--www/cas/Makefile3
-rw-r--r--www/dansguardian-devel/Makefile2
-rw-r--r--www/dansguardian/Makefile2
-rw-r--r--www/dillo-i18n/Makefile2
-rw-r--r--www/elinks/Makefile2
-rw-r--r--www/flood/Makefile2
-rw-r--r--www/gatling/Makefile2
-rw-r--r--www/htmlcxx/Makefile2
-rw-r--r--www/httest/Makefile2
-rw-r--r--www/httrack/Makefile2
-rw-r--r--www/lynx-current/Makefile2
-rw-r--r--www/lynx/Makefile3
-rw-r--r--www/mod_encoding/Makefile2
-rw-r--r--www/rsstool/Makefile2
-rw-r--r--www/sarg/Makefile2
-rw-r--r--www/tntnet/Makefile2
-rw-r--r--www/trafficserver/Makefile2
-rw-r--r--www/webalizer/Makefile2
-rw-r--r--www/xapian-omega/Makefile2
-rw-r--r--www/xapian-omega10/Makefile2
25 files changed, 25 insertions, 29 deletions
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index 7d8661bcd863..6453a945a401 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -20,7 +20,7 @@ MAN1= anytermd.1
USE_RC_SUBR= anytermd
USE_BZIP2= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_GCC= any
ALL_TARGET= default_target
PLIST_FILES= sbin/anytermd
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index f6282369db3d..4023f6379543 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -25,7 +25,7 @@ CONFLICTS_INSTALL= caudium14-1.* \
USE_APACHE= common22
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_AUTOTOOLS= autoconf libtool
USE_PERL5= yes
USE_RC_SUBR= apache22 htcacheclean
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index 144f83f29b09..007dd172e3ff 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -23,7 +23,7 @@ CONFLICTS_INSTALL= caudium14-1.* \
apache-*-2.2.* apache22-*
USE_APACHE= common24
-USE_ICONV= yes
+USES= iconv
USE_AUTOTOOLS= autoconf libtool
USE_PERL5= yes
USE_RC_SUBR= apache24 htcacheclean
diff --git a/www/awffull/Makefile b/www/awffull/Makefile
index f779590d3c91..c66fd58e1b86 100644
--- a/www/awffull/Makefile
+++ b/www/awffull/Makefile
@@ -23,8 +23,7 @@ FONTLABEL?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf
OPTIONS_DEFINE= GEOIP
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-font-default=${FONTDEFAULT} \
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 2060fd6c038a..d48948f479ac 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -51,8 +51,7 @@ post-install:
.endif
.if !defined(WITHOUT_NLS)
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE}
LANGS=en@quot es it
diff --git a/www/cas/Makefile b/www/cas/Makefile
index b9dfe472dc06..cc07cfa3910e 100644
--- a/www/cas/Makefile
+++ b/www/cas/Makefile
@@ -13,9 +13,8 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
pcre:${PORTSDIR}/devel/pcre \
ctpp2:${PORTSDIR}/textproc/ctpp2
-USES= cmake
+USES= cmake iconv
USE_LDCONFIG= yes
-USE_ICONV= yes
WITHOUT_NLS= yes
MAKE_JOBS_SAFE= yes
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index cb5b03df71c6..44458aa9f065 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -97,7 +97,7 @@ PLIST_SUB+= SCANNERS="@comment "
.if ${PORT_OPTIONS:MNTLM}
CONFIGURE_ARGS+= --enable-ntlm --with-libiconv=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
PLIST_SUB+= NTLMCONF=""
.else
PLIST_SUB+= NTLMCONF="@comment "
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index 9c89802e80bf..22a66943f814 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -97,7 +97,7 @@ PLIST_SUB+= SCANNERS="@comment "
.if ${PORT_OPTIONS:MNTLM}
CONFIGURE_ARGS+= --enable-ntlm --with-libiconv=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
PLIST_SUB+= NTLMCONF=""
.else
PLIST_SUB+= NTLMCONF="@comment "
diff --git a/www/dillo-i18n/Makefile b/www/dillo-i18n/Makefile
index 317f7e3560bd..af4bc28e837c 100644
--- a/www/dillo-i18n/Makefile
+++ b/www/dillo-i18n/Makefile
@@ -33,7 +33,7 @@ I18NVERSION= 20060709
USE_BZIP2= yes
USE_GNOME= gtk12
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index e428d08db376..4de52607d229 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -190,7 +190,7 @@ CONFIGURE_ARGS+= --disable-sm-scripting --without-spidermonkey
.endif
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
.endif
diff --git a/www/flood/Makefile b/www/flood/Makefile
index 9b18c7538a2b..b1ff4c5c1854 100644
--- a/www/flood/Makefile
+++ b/www/flood/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --disable-shared \
--with-apr-util=${LOCALBASE}/bin/apu-1-config
LDFLAGS+= -L${PREFIX}/lib
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
EX_SCRIPTS= analyze-relative analyze-relative-ramp
EX_DATA= flood.dtd relative-averages-time.awk round-robin-dynamic.xml \
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index c0c7529370c2..f2eca1af6e88 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -58,7 +58,7 @@ CFLAGS+= -O2 -fomit-frame-pointer
.endif
.if defined(WITH_GATLING_SMB)
-USE_ICONV= yes
+USES+= iconv
CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= ICONV=1
.else
diff --git a/www/htmlcxx/Makefile b/www/htmlcxx/Makefile
index d5da34246762..d7fef6d3d429 100644
--- a/www/htmlcxx/Makefile
+++ b/www/htmlcxx/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LGPL_V2
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
-USE_ICONV= yes
+USES= iconv
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/www/httest/Makefile b/www/httest/Makefile
index 3008d24f5ce0..07fc42024d83 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --enable-lua-module \
CPPFLAGS+= -I${LUA_INCDIR}
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-USE_ICONV= yes
+USES= iconv
USE_LUA= yes
USE_OPENSSL= yes
diff --git a/www/httrack/Makefile b/www/httrack/Makefile
index 1d171dd31851..8d0827ebd2c7 100644
--- a/www/httrack/Makefile
+++ b/www/httrack/Makefile
@@ -21,7 +21,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/${PORTNAME}
MAN1= htsserver.1 httrack.1 proxytrack.1 webhttrack.1
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 399d21573c46..239c0a73625f 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -22,7 +22,7 @@ CONFLICTS_INSTALL= lynx-2.8.[0-7].* ja-lynx-[0-9]*
WRKSRC= ${WRKDIR}/${PORTNAME}2-8-8
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_OPENSSL= yes
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index 675fe98ce257..8303d6bdbc49 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -34,8 +34,7 @@ DEFAULT_COLORS_DESC= Colors support
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS='@comment '
.else
-USES+= gettext
-USE_ICONV= yes
+USES+= gettext iconv
CONFIGURE_ARGS+=--enable-nls --with-libiconv-prefix="${LOCALBASE}"
PLIST_SUB+= NLS=''
.endif
diff --git a/www/mod_encoding/Makefile b/www/mod_encoding/Makefile
index 2adb809499ab..8059124adab5 100644
--- a/www/mod_encoding/Makefile
+++ b/www/mod_encoding/Makefile
@@ -22,7 +22,7 @@ MAKE_JOBS_SAFE= yes
#APACHE_VERSION= 1.3.6
USE_APACHE= 22+
-USE_ICONV= yes
+USES= iconv
HAS_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/www/rsstool/Makefile b/www/rsstool/Makefile
index bc1cf68f1fe9..6161dcb64397 100644
--- a/www/rsstool/Makefile
+++ b/www/rsstool/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= BERLIOS
MAINTAINER= miwi@FreeBSD.org
COMMENT= Read, parse, merge and write RSS and Atom feeds
-USE_ICONV= yes
+USES= iconv
USE_GNOME= libxml2
USE_GMAKE= yes
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 3e652ab53441..12a7012daa02 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_ARGS+=--without-ldap
.if ${PORT_OPTIONS:MICONV}
CONFIGURE_ARGS+=--with-iconv
-USE_ICONV= yes
+USES+= iconv
.else
CONFIGURE_ARGS+=--without-iconv
.endif
diff --git a/www/tntnet/Makefile b/www/tntnet/Makefile
index eb54cc2917e8..320e74bacf58 100644
--- a/www/tntnet/Makefile
+++ b/www/tntnet/Makefile
@@ -17,7 +17,7 @@ COMMENT= Webapplicationserver for C++
LIB_DEPENDS= cxxtools:${PORTSDIR}/devel/cxxtools
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
-USE_ICONV= yes
+USES= iconv
USE_CSTD= gnu89
PATCH_STRIP= -p1
GNU_CONFIGURE= yes
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index f0d06d3d9a87..a8096377dd0b 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -23,7 +23,7 @@ MAN1= traffic_shell.1
USE_AUTOTOOLS= autoconf automake libtool
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_OPENSSL= yes
USE_SQLITE= yes
USE_TCL= yes
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 265a27112312..f58d31c470e5 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -124,7 +124,7 @@ EXTRA_PATCHES+= ${FILESDIR}/ja-webalizer.conf-dist.patch
.endif
.if ${PORT_OPTIONS:MWEBALIZER_CONV}
-USE_ICONV=yes
+USES+= iconv
# The patch file is written by URASHIMA Akira
# see http://tyche.pu-toyama.ac.jp/~a-urasim/webalizer/
EXTRA_PATCHES+= ${FILESDIR}/webalizer-a-urasim_2.patch
diff --git a/www/xapian-omega/Makefile b/www/xapian-omega/Makefile
index a51236df0901..7eb672c6784b 100644
--- a/www/xapian-omega/Makefile
+++ b/www/xapian-omega/Makefile
@@ -39,7 +39,7 @@ PORTEXAMPLES= omega.conf
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS+=--with-iconv
.else
CONFIGURE_ARGS+=--without-iconv
diff --git a/www/xapian-omega10/Makefile b/www/xapian-omega10/Makefile
index 2ac8033da30c..4fa995ed43d4 100644
--- a/www/xapian-omega10/Makefile
+++ b/www/xapian-omega10/Makefile
@@ -40,7 +40,7 @@ PORTSCOUT= limit:^1\.0\.
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS+= --with-iconv
.else
CONFIGURE_ARGS+= --without-iconv