aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-12-29 20:31:35 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-12-29 20:31:35 +0800
commitaaf029acc0509872fd786396c46cfdaeb934444c (patch)
treec12b9e06b1a08fd91fdb1e83fe27295677e0b82d /www
parent9967631a73ad1e07ca80a4a61637962c605e0652 (diff)
downloadfreebsd-ports-gnome-aaf029acc0509872fd786396c46cfdaeb934444c.tar.gz
freebsd-ports-gnome-aaf029acc0509872fd786396c46cfdaeb934444c.tar.zst
freebsd-ports-gnome-aaf029acc0509872fd786396c46cfdaeb934444c.zip
- Remove bogus (in presence of USE_GITHUB) USES=tar*
- Fix stripping from non-root, also fix executable files permissins Approved by: portmgr blanket
Diffstat (limited to 'www')
-rw-r--r--www/aws-demos/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
index 1a82aae726bb..7ea5c61d1fb8 100644
--- a/www/aws-demos/Makefile
+++ b/www/aws-demos/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= gprbuild:devel/gprbuild \
xmlada>=4.4:textproc/xmlada \
aws>=3.1:www/aws
-USES= ada gmake python tar:bzip2
+USES= ada gmake python
USE_GITHUB= yes
GH_ACCOUNT= AdaCore
GH_TAGNAME= 17.0
@@ -156,7 +156,9 @@ do-install:
${STAGEDIR}${EXAMPLESDIR}/demos)
.endfor
.for prog in ${PROGS}
- ${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/demos/${prog}
+ @${CHMOD} 755 ${STAGEDIR}${EXAMPLESDIR}/demos/${prog}
+ @${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/demos/${prog}
+ @${CHMOD} ${BINMODE} ${STAGEDIR}${EXAMPLESDIR}/demos/${prog}
.endfor
.include <bsd.port.post.mk>