aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-03-07 13:47:20 +0800
committerkoobs <koobs@FreeBSD.org>2016-03-07 13:47:20 +0800
commitac386528750927f3f4f3ddc33ccbc136bac447bd (patch)
treeba623abe9355101b171e34af5a9077e6d160f9b9 /www
parentf86f93d18e8147f1e5e299bfcc80ddc184725b4a (diff)
downloadfreebsd-ports-gnome-ac386528750927f3f4f3ddc33ccbc136bac447bd.tar.gz
freebsd-ports-gnome-ac386528750927f3f4f3ddc33ccbc136bac447bd.tar.zst
freebsd-ports-gnome-ac386528750927f3f4f3ddc33ccbc136bac447bd.zip
www/py-rackspace-monitoring: Update to 0.6.5
- Update PORTVERSION and distinfo checksum (0.6.5) - Update test target - Enable NO_ARCH (architecture independent) - Patch setup.py, relax dependency versions
Diffstat (limited to 'www')
-rw-r--r--www/py-rackspace-monitoring/Makefile10
-rw-r--r--www/py-rackspace-monitoring/distinfo4
-rw-r--r--www/py-rackspace-monitoring/files/patch-setup.py11
3 files changed, 20 insertions, 5 deletions
diff --git a/www/py-rackspace-monitoring/Makefile b/www/py-rackspace-monitoring/Makefile
index 52d8c5ad62ab..4f466ad7e849 100644
--- a/www/py-rackspace-monitoring/Makefile
+++ b/www/py-rackspace-monitoring/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rackspace-monitoring
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.5
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +18,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libcloud>=0.14:${PORTSDIR}/net/py-libcloud
USES= python
USE_PYTHON= distutils autoplist
-regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && \
+ ${CP} test/secrets.py-dist test/secrets.py && \
+ ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/www/py-rackspace-monitoring/distinfo b/www/py-rackspace-monitoring/distinfo
index 2f5124d9ad6c..7aae60335cc3 100644
--- a/www/py-rackspace-monitoring/distinfo
+++ b/www/py-rackspace-monitoring/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rackspace-monitoring-0.6.2.tar.gz) = ec89968b52ec851a517858cb7ad9e1449b2f59331ea978290ee7df03e0bdae99
-SIZE (rackspace-monitoring-0.6.2.tar.gz) = 31488
+SHA256 (rackspace-monitoring-0.6.5.tar.gz) = 28e91f1054a9fe3b130c9d4fd65cb007e8efdaa89e9d8a8e99479aec73e298c4
+SIZE (rackspace-monitoring-0.6.5.tar.gz) = 31397
diff --git a/www/py-rackspace-monitoring/files/patch-setup.py b/www/py-rackspace-monitoring/files/patch-setup.py
new file mode 100644
index 000000000000..e957fb09a22f
--- /dev/null
+++ b/www/py-rackspace-monitoring/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2016-03-07 05:34:43 UTC
++++ setup.py
+@@ -171,7 +171,7 @@ setup(
+ description='Client library for Rackspace Cloud Monitoring',
+ author='Rackspace, Inc.',
+ author_email='monitoring@rackspace.com',
+- install_requires=['apache-libcloud >= 0.14, <0.16'],
++ install_requires=['apache-libcloud >= 0.14'],
+ packages=[
+ 'rackspace_monitoring',
+ 'rackspace_monitoring.drivers',