aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2000-08-09 10:16:31 +0800
committerJun Kuriyama <kuriyama@FreeBSD.org>2000-08-09 10:16:31 +0800
commitac5728bf109605f6b5b83d681443a42a65ed22e5 (patch)
treeee8eb30a6408fa4e8163ce37ea7ba4824d46bc12 /www
parent6771be2cc967738b3ba5dd6fa324cb86816f0815 (diff)
downloadfreebsd-ports-gnome-ac5728bf109605f6b5b83d681443a42a65ed22e5.tar.gz
freebsd-ports-gnome-ac5728bf109605f6b5b83d681443a42a65ed22e5.tar.zst
freebsd-ports-gnome-ac5728bf109605f6b5b83d681443a42a65ed22e5.zip
Use files/apache.sh instead of making in Makefile.
No response from: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/apache13+ipv6/Makefile4
-rw-r--r--www/apache13+ipv6/files/apache.sh2
2 files changed, 2 insertions, 4 deletions
diff --git a/www/apache13+ipv6/Makefile b/www/apache13+ipv6/Makefile
index 2c0133b529f0..22d85c92cc40 100644
--- a/www/apache13+ipv6/Makefile
+++ b/www/apache13+ipv6/Makefile
@@ -77,9 +77,7 @@ pre-configure:
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/apache.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/apachectl ] && ${PREFIX}/sbin/apachectl start > /dev/null && ${ECHO} -n ' apache'" >> ${PREFIX}/etc/rc.d/apache.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/apache.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/apache.sh ${PREFIX}/etc/rc.d/apache.sh; \
fi
.include <bsd.port.post.mk>
diff --git a/www/apache13+ipv6/files/apache.sh b/www/apache13+ipv6/files/apache.sh
index 619918254852..ca4321814e5a 100644
--- a/www/apache13+ipv6/files/apache.sh
+++ b/www/apache13+ipv6/files/apache.sh
@@ -10,7 +10,7 @@ start)
[ -x ${PREFIX}/sbin/apachectl ] && ${PREFIX}/sbin/apachectl start > /dev/null && echo -n ' apache'
;;
stop)
- [ -r /var/run/httpd.pid ] && ${PREFIX}/apachectl stop > /dev/null && echo -n ' apache'
+ [ -r /var/run/httpd.pid ] && ${PREFIX}/sbin/apachectl stop > /dev/null && echo -n ' apache'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2