aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-01-02 04:15:53 +0800
committerohauer <ohauer@FreeBSD.org>2012-01-02 04:15:53 +0800
commitac8d1f93b5feda3caf3b9da77d88c274d9b4fb68 (patch)
tree1e08a66b47b3d686ba9e45842c2a815f9f17afcf /www
parentbcfe29b21f4eb92285e76c767ac5e37abbb268bc (diff)
downloadfreebsd-ports-gnome-ac8d1f93b5feda3caf3b9da77d88c274d9b4fb68.tar.gz
freebsd-ports-gnome-ac8d1f93b5feda3caf3b9da77d88c274d9b4fb68.tar.zst
freebsd-ports-gnome-ac8d1f93b5feda3caf3b9da77d88c274d9b4fb68.zip
- remove apache13 and ports depending on apache13 from portstree
( EXPIRATION_DATE=2012-01-01 ) with hat apache@
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-DBI/Makefile23
2 files changed, 5 insertions, 19 deletions
diff --git a/www/Makefile b/www/Makefile
index 61f662eee88d..dba9cd31a447 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -579,7 +579,6 @@
SUBDIR += p5-Apache-Session-Wrapper
SUBDIR += p5-Apache-SessionX
SUBDIR += p5-Apache-Singleton
- SUBDIR += p5-Apache-Test
SUBDIR += p5-Apache2-Scoreboard
SUBDIR += p5-Apache2-SiteControl
SUBDIR += p5-ApacheBench
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index 578548c83ccb..40a09621d83b 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -14,17 +14,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT?= DBI persistent connection, authentication and authorization
-SLAVEDIRS= www/p5-Apache-DBI-mp1 www/p5-Apache-DBI-mp2
+SLAVEDIRS= www/p5-Apache-DBI-mp2
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_SAFE= yes
MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
-USE_APACHE?= 13+
+USE_APACHE?= 20+
.include <bsd.port.pre.mk>
@@ -34,20 +35,6 @@ USE_APACHE?= 13+
IGNORE= use ${SLAVEDIRS} instead
.endif
-.if defined(WITH_MODPERL) && ${APACHE_VERSION} > 13
-IGNORE= mod_perl require apache13 but ${APACHE_PORT} is installed
-.elif defined(WITH_MODPERL2) && ${APACHE_VERSION} < 20
-IGNORE= mod_perl2 require at last apache20 but ${APACHE_PORT} is installed
-.endif
-
-.if defined(WITH_MODPERL2)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
-.else
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
-.endif
-
PLIST_FILES= %%SITE_PERL%%/Apache/DBI.pm \
%%SITE_PERL%%/Apache/AuthDBI.pm \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist