aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2016-12-11 02:45:04 +0800
committerosa <osa@FreeBSD.org>2016-12-11 02:45:04 +0800
commitae9dc64d6117612029e73b31ad0dd0a79aef0c77 (patch)
treeefce9c39be0f34bf6527c78daff8443efa269530 /www
parent430830a0fb1ce667963b4876efe3b7af55eed24f (diff)
downloadfreebsd-ports-gnome-ae9dc64d6117612029e73b31ad0dd0a79aef0c77.tar.gz
freebsd-ports-gnome-ae9dc64d6117612029e73b31ad0dd0a79aef0c77.tar.zst
freebsd-ports-gnome-ae9dc64d6117612029e73b31ad0dd0a79aef0c77.zip
Fix the build issues when:
o) the drizzle module can't find the libdrizzle headers; o) the geoip2 can't find the libmaxminddb. Do not bump PORTREVISION, those third-party modules are disabled by default.
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile3
-rw-r--r--www/nginx/Makefile3
2 files changed, 6 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index ba13e062b49f..78ac8eb066f1 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -540,6 +540,7 @@ NGINX_HTTP_GEOIP2_VERSION= 2.0
GH_ACCOUNT+= leev:geoip2
GH_PROJECT+= ngx_http_geoip2_module:geoip2
GH_TAGNAME+= ${NGINX_HTTP_GEOIP2_VERSION}:geoip2
+CFLAGS+= "-I${LOCALBASE}/include"
.if !empty(PORT_OPTIONS:MDSO)
CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_geoip2}
.else
@@ -788,6 +789,8 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_VERSION}
.if ${PORT_OPTIONS:MDRIZZLE}
LIB_DEPENDS+= libdrizzle.so:databases/libdrizzle
+CONFIGURE_ENV+= "LIBDRIZZLE_INC=${LOCALBASE}/include"
+CONFIGURE_ENV+= "LIBDRIZZLE_LIB=${LOCALBASE}/lib"
NGINX_DRIZZLE_VERSION= 0.1.9
GH_ACCOUNT+= openresty:drizzle
GH_PROJECT+= drizzle-nginx-module:drizzle
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 4ae5706bb76f..4b84d0e512cb 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -535,6 +535,7 @@ NGINX_HTTP_GEOIP2_VERSION= 2.0
GH_ACCOUNT+= leev:geoip2
GH_PROJECT+= ngx_http_geoip2_module:geoip2
GH_TAGNAME+= ${NGINX_HTTP_GEOIP2_VERSION}:geoip2
+CFLAGS+= "-I${LOCALBASE}/include"
.if !empty(PORT_OPTIONS:MDSO)
CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_geoip2}
.else
@@ -780,6 +781,8 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_VERSION}
.if ${PORT_OPTIONS:MDRIZZLE}
LIB_DEPENDS+= libdrizzle.so:databases/libdrizzle
+CONFIGURE_ENV+= "LIBDRIZZLE_INC=${LOCALBASE}/include"
+CONFIGURE_ENV+= "LIBDRIZZLE_LIB=${LOCALBASE}/lib"
NGINX_DRIZZLE_VERSION= 0.1.9
GH_ACCOUNT+= openresty:drizzle
GH_PROJECT+= drizzle-nginx-module:drizzle