aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
committerrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
commitb028b113ef13fa7972bb45d681d7a0abe47c40a6 (patch)
treea76a27ca09341f754b493c264ee71c912a553d89 /www
parent855b1df39bc3a6f03abf878d9c99b5ba0838ba35 (diff)
downloadfreebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.gz
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.zst
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Diffstat (limited to 'www')
-rw-r--r--www/aria2/Makefile2
-rw-r--r--www/bluefish/Makefile3
-rw-r--r--www/castget/Makefile2
-rw-r--r--www/cherokee-devel/Makefile3
-rw-r--r--www/cherokee/Makefile3
-rw-r--r--www/dansguardian-devel/Makefile1
-rw-r--r--www/dansguardian/Makefile5
-rw-r--r--www/epiphany/Makefile2
-rw-r--r--www/hiawatha/Makefile2
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/mod_dav/Makefile1
-rw-r--r--www/mod_encoding/Makefile1
-rw-r--r--www/netrik/Makefile1
-rw-r--r--www/pound/Makefile1
-rw-r--r--www/sarg/Makefile3
-rw-r--r--www/varnish/Makefile1
-rw-r--r--www/varnish2/Makefile1
-rw-r--r--www/w3m/Makefile2
-rw-r--r--www/xshttpd-devel/Makefile2
-rw-r--r--www/xshttpd/Makefile2
20 files changed, 16 insertions, 24 deletions
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index da0db092de9f..1114657a0ef6 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -17,7 +17,7 @@ COMMENT= Yet another download tool
#DONTSTRIP= yes
#CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
#MAKE_ENV= DONTSTRIP=
-CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} --mandir=${MANPREFIX}/man --with-openssl \
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} --with-openssl \
--with-libxml2 --without-gnutls --without-libares --without-libcares
USE_GCC= 3.4+
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 31c679e75595..7d180a9fb107 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -37,8 +37,7 @@ CONFIGURE_ARGS= --with-freedesktop_org-menu=${PREFIX}/share/gnome/applications \
--with-freedesktop_org-mime=${PREFIX}/share/mime \
--without-gnome2_4-mime \
--without-gnome2_4-appreg \
- --with-icon-path=${PREFIX}/share/gnome/pixmaps \
- --mandir=${MANPREFIX}/man
+ --with-icon-path=${PREFIX}/share/gnome/pixmaps
# Turns debugging output on
.if defined(WITH_DEBUG)
diff --git a/www/castget/Makefile b/www/castget/Makefile
index f4219b6a4000..fb44e189918b 100644
--- a/www/castget/Makefile
+++ b/www/castget/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= glib20 libxml2
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --disable-static
+CONFIGURE_ARGS= --disable-static
GNU_CONFIGURE= yes
PLIST_FILES= bin/castget include/libcastget.h lib/libcastget.la lib/libcastget.so lib/libcastget.so.0
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index 7bacce02ceca..79dad87ba9b5 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -30,8 +30,7 @@ GNU_CONFIGURE= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
- --with-wwwroot=${PREFIX}/www/cherokee \
+CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www/cherokee \
--enable-readdir_r \
--disable-static
DEFCONFS= cherokee.conf mime.compression.types mime.types
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 6a61636bab04..430f04e0cdf2 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -27,8 +27,7 @@ GNU_CONFIGURE= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
- --with-wwwroot=${PREFIX}/www/cherokee \
+CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www/cherokee \
--enable-readdir_r \
--disable-static
DEFCONFS= advanced.conf cherokee.conf icons.conf mime.compression.types mime.types
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index b357bc7d59b7..ee510132907a 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -27,7 +27,6 @@ LATEST_LINK= dansguardian-devel
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
- --mandir=/usr/local/man \
--with-logdir=/var/log \
--with-piddir=/var/run
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index 198890c42af3..f52381dbf2d0 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -27,7 +27,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir=/sbin/ \
--sysconfdir=/etc/dansguardian/ \
--sysvdir=/etc/rc.d/ \
- --mandir=/man/ \
--logdir=/var/log/ \
--cgidir=/www/cgi-bin/ \
--piddir=/var/run/ \
@@ -55,6 +54,10 @@ USE_APACHE= 1.3+
IGNORE="Commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make"
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's,^MANUALFILES = .*,MANUALFILES = ${MANPREFIX}/man/,' \
+ ${WRKSRC}/Makefile
+
pre-install:
# Configure pkg-plist based on whether phraselists are to be installed or not
.if defined(WITH_DG_PHRASELISTS)
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 4bf3edde4e0f..7ec7bb1671b6 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -32,7 +32,7 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-CONFIGURE_ARGS= --with-mozilla=${GECKO} --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS= --with-mozilla=${GECKO}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 00f1ba14fd81..a23a4e33de39 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -20,7 +20,7 @@ USE_RC_SUBR= hiawatha
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --mandir=${MANPREFIX}/man webrootdir=${PREFIX}/www/hiawatha
+CONFIGURE_ARGS= --localstatedir=/var webrootdir=${PREFIX}/www/hiawatha
OPTIONS= SSL "Support for Secure Sockets Layer (SSL)?" On
OPTIONS+= CACHE "Internal file caching support?" On
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 079f0e5b4e80..b96ca2588c2a 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -21,7 +21,7 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GNOME= lthack
USE_RC_SUBR= lighttpd.sh
-CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd --mandir=${PREFIX}/man
+CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/www/mod_dav/Makefile b/www/mod_dav/Makefile
index 463e09b1dad2..6f50613b7ea2 100644
--- a/www/mod_dav/Makefile
+++ b/www/mod_dav/Makefile
@@ -29,7 +29,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--bindir=${PREFIX}/bin \
--sbindir=${PREFIX}/sbin \
--libexecdir=${PREFIX}/libexec/apache \
- --mandir=${PREFIX}/man \
--sysconfdir=${PREFIX}/etc/apache \
--datadir=${PREFIX}/share/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/mod_encoding/Makefile b/www/mod_encoding/Makefile
index 7b53fcb1e686..9efacc3af43c 100644
--- a/www/mod_encoding/Makefile
+++ b/www/mod_encoding/Makefile
@@ -27,7 +27,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--bindir=${PREFIX}/bin \
--sbindir=${PREFIX}/sbin \
--libexecdir=${PREFIX}/libexec/apache \
- --mandir=${PREFIX}/man \
--sysconfdir=${PREFIX}/etc/apache \
--datadir=${PREFIX}/share/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/netrik/Makefile b/www/netrik/Makefile
index 56496278d029..1069c803f7e3 100644
--- a/www/netrik/Makefile
+++ b/www/netrik/Makefile
@@ -22,7 +22,6 @@ USE_GMAKE= yes
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
PLIST_FILES= bin/netrik
diff --git a/www/pound/Makefile b/www/pound/Makefile
index 4a2db50c1b0d..9606bc8c760a 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -25,7 +25,6 @@ SUB_LIST= NAME=${PORTNAME}
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ARGS+= F_CONF=${PREFIX}/etc/pound.cfg
-CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man
MAN8= pound.8 poundctl.8
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 2f0ec6ea53b9..55f1b96323ae 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -24,8 +24,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CC=gcc CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-bindir="${PREFIX}/bin" \
--enable-sysconfdir="${PREFIX}/etc/${PORTNAME}" \
- --enable-htmldir="${PREFIX}/www/${PORTNAME}" \
- --enable-mandir="${MAN1PREFIX}/man/man1"
+ --enable-htmldir="${PREFIX}/www/${PORTNAME}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= sarg.1
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index 6e9b39533d96..6fe3b1320c30 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -17,7 +17,6 @@ COMMENT= The Varnish high-performance HTTP accelerator
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
USE_LDCONFIG= yes
MAN1= varnishd.1 varnishhist.1 varnishlog.1 varnishncsa.1 \
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
index 6e9b39533d96..6fe3b1320c30 100644
--- a/www/varnish2/Makefile
+++ b/www/varnish2/Makefile
@@ -17,7 +17,6 @@ COMMENT= The Varnish high-performance HTTP accelerator
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
USE_LDCONFIG= yes
MAN1= varnishd.1 varnishhist.1 varnishlog.1 varnishncsa.1 \
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 56c5d9c95102..ac9bb4930b4c 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -25,7 +25,7 @@ W3M_VERSION= 0.5.2
CONFLICTS?= ja-w3m-0.5.* ja-w3m-img-0.5.* w3m-m17n-0.5.* w3m-img-0.5.* w3m-m17n-img-0.5.*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gc=${LOCALBASE} --mandir=${PREFIX}/man
+CONFIGURE_ARGS= --with-gc=${LOCALBASE}
MAN1= w3m.1 w3mman.1
MANLANG= "" ja
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index 5ee8e4b26cbc..0192996d9bda 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -43,7 +43,7 @@ PORTDOCS= README COPYING ChangeLog
.include <bsd.port.pre.mk>
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
WWWDIR?= ${PREFIX}/www/${PORTNAME}
-CONFIGURE_ARGS+=--with-rootdir=${WWWDIR} --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
.if !defined(WITHOUT_SSL)
.include <${PORTSDIR}/Mk/bsd.openssl.mk>
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
index ee4767f8e2a2..fdb619ce13ed 100644
--- a/www/xshttpd/Makefile
+++ b/www/xshttpd/Makefile
@@ -39,7 +39,7 @@ PORTDOCS= README BUGS COPYING ChangeLog
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
WWWDIR?= ${PREFIX}/www
-CONFIGURE_ARGS+=--with-rootdir=${WWWDIR} --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
.include <bsd.port.pre.mk>