aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-06-13 14:36:56 +0800
committeredwin <edwin@FreeBSD.org>2008-06-13 14:36:56 +0800
commitb15b246a97c1cb895b1fc40e74da7111e9d150dc (patch)
tree9a371e67591a9da6df6eeea945c2c02e7fc2e721 /www
parent105aa27ec319910b1de6692c243b2549bd5fc176 (diff)
downloadfreebsd-ports-gnome-b15b246a97c1cb895b1fc40e74da7111e9d150dc.tar.gz
freebsd-ports-gnome-b15b246a97c1cb895b1fc40e74da7111e9d150dc.tar.zst
freebsd-ports-gnome-b15b246a97c1cb895b1fc40e74da7111e9d150dc.zip
[NEW PORTS] www/webobjects(+) Apple WebObjects ports bundle
This is a bundle of several ports covering many typical requirements for building an Apple WebObjects deployment environment. Each port is or has a dependancy with some other port in the bundle, and have therefore been lodged collectively. www/mod_webobjects WOAdaptor is a collection of WebObjects WebServer Adaptors. These include an Apache Module, CGI and FastCGI adaptors This is a subproject of Project Wonder and is an effort to pool enhancements and bug fixes for Apple's open source codebase. WWW: http://wonder.sourceforge.net/WOAdaptor.html PR: ports/117299 Submitted by: Quinton Dolan <q@onthenet.com.au>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_webobjects/Makefile22
2 files changed, 23 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a8a0377e6201..546be75c5d7e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -474,6 +474,7 @@
SUBDIR += mod_vhs
SUBDIR += mod_webapp
SUBDIR += mod_webkit
+ SUBDIR += mod_webobjects
SUBDIR += mod_xmlns
SUBDIR += mod_xsendfile
SUBDIR += moinmoin
diff --git a/www/mod_webobjects/Makefile b/www/mod_webobjects/Makefile
new file mode 100644
index 000000000000..5dce215fc715
--- /dev/null
+++ b/www/mod_webobjects/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: mod_webobjects
+# Date created: Mon Apr 16 07:07:22 EST 2007
+# Whom: Quinton Dolan <q@onthenet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webobjects
+PKGNAMEPREFIX= mod_
+
+MAINTAINER?= q@onthenet.com.au
+COMMENT= WebObjects WebServer Adaptor for Apache
+
+MASTERDIR= ${.CURDIR}/../woadaptor
+
+WITH_APACHE?= "yes"
+WITHOUT_CGI= "yes"
+WITHOUT_FASTCGI="yes"
+
+CONFLICTS= woadaptor-[0-9]*
+
+.include "${MASTERDIR}/Makefile"