aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2010-04-22 08:09:12 +0800
committerMarcus Alves Grando <mnag@FreeBSD.org>2010-04-22 08:09:12 +0800
commitb2e8ed26de6411eccf9c1f5aefbf488b20195fb0 (patch)
tree8a07a8ccecf4b486d908f415a56d4ff6d7be2b72 /www
parent007838067da9fa6df41ca2270776d86d1254da25 (diff)
downloadfreebsd-ports-gnome-b2e8ed26de6411eccf9c1f5aefbf488b20195fb0.tar.gz
freebsd-ports-gnome-b2e8ed26de6411eccf9c1f5aefbf488b20195fb0.tar.zst
freebsd-ports-gnome-b2e8ed26de6411eccf9c1f5aefbf488b20195fb0.zip
- Remove support to PHP4 since it's not supported anymore.
- portlint
Diffstat (limited to 'www')
-rw-r--r--www/pecl-APC/Makefile27
1 files changed, 3 insertions, 24 deletions
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index 34730dd64694..ff242f04a396 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= mnag@FreeBSD.org
COMMENT= Alternative PHP Cache
USE_PHP= yes
+IGNORE_WITH_PHP=4
USE_PHPEXT= yes
PHP_MODNAME= apc
@@ -24,13 +25,12 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ARGS= --enable-apc
-CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include"
+CFLAGS= -I${LOCALBASE}/include
OPTIONS= MMAP "Enable mmap memory support (default: IPC shm)" off \
SEMAPHORES "Enable sysv IPC semaphores (default: fcntl())" off \
SPINLOCKS "Enable spinlocks (experimental)" off \
- FILEHITS "Enable per request cache info" off \
- PHP4_OPT "Little optimization to PHP4" off
+ FILEHITS "Enable per request cache info" off
PORTDOCS= *
@@ -52,27 +52,6 @@ CONFIGURE_ARGS+= --enable-apc-spinlocks
CONFIGURE_ARGS+= --enable-apc-filehits
.endif
-.if defined(WITH_PHP4_OPT)
-.if ${PHP_VER} == 4
-.if exists(${LOCALBASE}/include/apache/httpd.h)
-CFLAGS+= -I${LOCALBASE}/include/apache -DAPC_PHP4_STAT
-.elif exists(${LOCALBASE}/include/apache2/httpd.h)
-CFLAGS+= -I${LOCALBASE}/include/apache2 -DAPC_PHP4_STAT
-.elif exists(${LOCALBASE}/include/apache21/httpd.h)
-CFLAGS+= -I${LOCALBASE}/include/apache21 -DAPC_PHP4_STAT
-.elif exists(${LOCALBASE}/include/apache22/httpd.h)
-CFLAGS+= -I${LOCALBASE}/include/apache22 -DAPC_PHP4_STAT
-.endif
-.else
-pre-configure:
- @${ECHO_CMD}
- @${ECHO_CMD} "*** WARNING ***"
- @${ECHO_CMD} "This optimization is only for PHP4. PHP5 or newer does not need it"
- @${ECHO_CMD} "I will continue instalation..."
- @${ECHO_CMD}
-.endif
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}