aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormfechner <mfechner@FreeBSD.org>2018-06-26 23:33:26 +0800
committermfechner <mfechner@FreeBSD.org>2018-06-26 23:33:26 +0800
commitb591c2fd11d5eb8172bcf118e33fb93342aa0246 (patch)
tree6aa63a7779348c887c64bb4ac4223ed01fdbdaf0 /www
parent9800d1eaae96d6d0f0cd9189679210f719d88b73 (diff)
downloadfreebsd-ports-gnome-b591c2fd11d5eb8172bcf118e33fb93342aa0246.tar.gz
freebsd-ports-gnome-b591c2fd11d5eb8172bcf118e33fb93342aa0246.tar.zst
freebsd-ports-gnome-b591c2fd11d5eb8172bcf118e33fb93342aa0246.zip
Added flavors support to drush.
PR: 227741 Submitted by: Jonas Palm Reported by: Jonas Palm Reviewed by: tz (mentor) Approved by: tz (mentor) Differential Revision: https://reviews.freebsd.org/D15990
Diffstat (limited to 'www')
-rw-r--r--www/drush/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/drush/Makefile b/www/drush/Makefile
index 908958cf9f52..a4fc79930146 100644
--- a/www/drush/Makefile
+++ b/www/drush/Makefile
@@ -3,8 +3,10 @@
PORTNAME= drush
DISTVERSION= 8.1.16
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://github.com/drush-ops/drush/releases/download/${DISTVERSION}/
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= drush
EXTRACT_SUFX= .phar
@@ -17,7 +19,7 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
NO_ARCH= yes
-USES= php:cli
+USES= php:cli,flavors
# set php requirements same as drupal itself
USE_PHP= gd pcre session mbstring ctype json hash simplexml dom pdo filter phar