aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-17 23:47:11 +0800
committerMartin Wilke <miwi@FreeBSD.org>2011-03-17 23:47:11 +0800
commitb64ae76c932b14e06355e28b5161c09e95e2b325 (patch)
tree13f8e43a7e90361f9bb92f1936759fb3fbcb83a6 /www
parent6952350f7707db86cbfc4d7248735cf25f40d3a6 (diff)
downloadfreebsd-ports-gnome-b64ae76c932b14e06355e28b5161c09e95e2b325.tar.gz
freebsd-ports-gnome-b64ae76c932b14e06355e28b5161c09e95e2b325.tar.zst
freebsd-ports-gnome-b64ae76c932b14e06355e28b5161c09e95e2b325.zip
- Update to 0.5.1
- Pet Portlint PR: 155580 Submitted by: Ethan Fouts <freebsd.ports@efplace.com>
Diffstat (limited to 'www')
-rw-r--r--www/mod_jail/Makefile10
-rw-r--r--www/mod_jail/distinfo5
-rw-r--r--www/mod_jail/files/patch-mod_jail.c63
-rw-r--r--www/mod_jail/pkg-descr12
4 files changed, 24 insertions, 66 deletions
diff --git a/www/mod_jail/Makefile b/www/mod_jail/Makefile
index 17e4e042eaf8..56a6929dc76c 100644
--- a/www/mod_jail/Makefile
+++ b/www/mod_jail/Makefile
@@ -6,21 +6,21 @@
#
PORTNAME= mod_jail
-PORTVERSION= 0.4
-PORTREVISION= 2
+PORTVERSION= 0.5.1
CATEGORIES= www
-MASTER_SITES= http://igorpopov.newmail.ru/
+MASTER_SITES= http://mod-jail.googlecode.com/files/
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache 1.3.x/2.0.xx module to enable an easy alternative to mod_chroot
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
-WRKSRC= ${WRKDIR}/mod_jail
+WRKSRC= ${WRKDIR}/mod_jail-0.5.1
USE_APACHE= 1.3+
AP_FAST_BUILD= YES
AP_GENPLIST= YES
+NOPORTDOCS= YES
PORTDOCS= changelog.html documentation.html download.html \
index.html
diff --git a/www/mod_jail/distinfo b/www/mod_jail/distinfo
index ebf27d6432ba..29473f0cd11f 100644
--- a/www/mod_jail/distinfo
+++ b/www/mod_jail/distinfo
@@ -1,3 +1,2 @@
-MD5 (mod_jail-0.4.tar.gz) = 188fb307e67428b05292dd73b9d6db2e
-SHA256 (mod_jail-0.4.tar.gz) = 85291f40c0d5d19a8ac68196c679969c2617858d46839a6400a735e2b4a873eb
-SIZE (mod_jail-0.4.tar.gz) = 14624
+SHA256 (mod_jail-0.5.1.tar.gz) = 752822e2a512a7cf2d374cd4e7a0675c744248094b0392cc20fde969828cdd58
+SIZE (mod_jail-0.5.1.tar.gz) = 12000
diff --git a/www/mod_jail/files/patch-mod_jail.c b/www/mod_jail/files/patch-mod_jail.c
index 786b1e153f7f..87dd134b6d36 100644
--- a/www/mod_jail/files/patch-mod_jail.c
+++ b/www/mod_jail/files/patch-mod_jail.c
@@ -1,54 +1,11 @@
---- ./mod_jail.c.orig 2007-02-15 12:37:06.000000000 +0000
-+++ ./mod_jail.c 2008-12-28 15:39:43.000000000 +0000
-@@ -130,7 +130,11 @@
- p_jail_cfg_t cfg = (p_jail_cfg_t) ap_pcalloc(p, sizeof(jail_cfg_t));
-
- cfg->jail_scrlevel = 3; /* good default value */
-+#if ((__FreeBSD_version >= 800000 && __FreeBSD_version < 800056) || __FreeBSD_version < 701103)
- cfg->jail.version = 0;
-+#else
-+ cfg->jail.version = JAIL_API_VERSION;
-+#endif
- return (void *)cfg;
- }
-
-@@ -190,7 +194,13 @@
- if (!inet_aton(arg, &in)) {
- return "could not make sense of jail ip address";
+--- mod_jail.c.orig 2009-09-24 02:05:27.000000000 -0700
++++ mod_jail.c 2010-10-20 15:16:31.000000000 -0700
+@@ -391,7 +391,7 @@
+ if (p_addr == NULL) {
+ return NULL;
}
-+#if ((__FreeBSD_version >= 800000 && __FreeBSD_version < 800056) || __FreeBSD_version < 701103)
- cfg->jail.ip_number = ntohl(in.s_addr);
-+#else
-+ cfg->jail.ip4s = 1;
-+ cfg->jail.ip4 = ap_pcalloc(cmd->pool, sizeof(struct in_addr));
-+ cfg->jail.ip4[0].s_addr = in.s_addr;
-+#endif
-
- return NULL;
- }
-@@ -321,7 +331,11 @@
- return NULL;
- }
- cfg->jail_scrlevel = 3; /* good default value */
-+#if ((__FreeBSD_version >= 800000 && __FreeBSD_version < 800056) || __FreeBSD_version < 701103)
- cfg->jail.version = 0;
-+#else
-+ cfg->jail.version = JAIL_API_VERSION;
-+#endif
- return (void*)cfg;
- }
-
-@@ -378,7 +392,13 @@
- if (!inet_aton(arg, &in)) {
- return "could not make sense of jail ip address";
- }
-+#if ((__FreeBSD_version >= 800000 && __FreeBSD_version < 800056) || __FreeBSD_version < 701103)
- cfg->jail.ip_number = ntohl(in.s_addr);
-+#else
-+ cfg->jail.ip4s = 1;
-+ cfg->jail.ip4 = ap_pcalloc(cmd->pool, sizeof(struct in_addr));
-+ cfg->jail.ip4[0].s_addr = in.s_addr;
-+#endif
-
- return NULL;
- }
+- addr->s_addr = htonl(INADDR_LOOPBACK);
++ p_addr->s_addr = htonl(INADDR_LOOPBACK);
+ cfg->jail = (struct jail) {
+ .version = JAIL_API_VERSION,
+ .path = NULL,
diff --git a/www/mod_jail/pkg-descr b/www/mod_jail/pkg-descr
index cc4f846b8a59..e15cd8965abf 100644
--- a/www/mod_jail/pkg-descr
+++ b/www/mod_jail/pkg-descr
@@ -1,6 +1,8 @@
-mod_jail is Apache 1.3.xx/2.0.xx module, that makes running Apache in a secure jail
-prison easy, so it is intended to run on FreeBSD only. It is similar to
-mod_chroot, but uses FreeBSD's specific system call - jail. Also mod_jail make
-it possible to change securelevel into jail prison.
+mod_jail is Apache 1.3.xx/2.0.xx/2.2.xx module, that makes running Apache
+in a secure jail prison easy, so it is intended to run on FreeBSD only.
+It is similar to mod_chroot, but uses FreeBSD's specific system call -
+jail. Also mod_jail make it possible to change securelevel into jail
+prison.
-WWW: http://igorpopov.newmail.ru/mod_jail/
+WWW: http://code.google.com/p/mod-jail/
+ORIG WWW: http://igorpopov.newmail.ru/mod_jail/