aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2005-09-03 02:13:04 +0800
committerbrooks <brooks@FreeBSD.org>2005-09-03 02:13:04 +0800
commitb70a954010d514c3e327cebc5b5e947d58332680 (patch)
treedf0474a07301ebf8d960ae47f1993629bf7cffa5 /www
parentc934452bc5ca57fb45a84ac40b9fe2178ff8e239 (diff)
downloadfreebsd-ports-gnome-b70a954010d514c3e327cebc5b5e947d58332680.tar.gz
freebsd-ports-gnome-b70a954010d514c3e327cebc5b5e947d58332680.tar.zst
freebsd-ports-gnome-b70a954010d514c3e327cebc5b5e947d58332680.zip
Drop the adhoc checks for php#-pgsql, mod_php, and the PHP cli as well
as the apache selection in favor of bsd.php.mk. The list of extensions in USE_PHP is probaly short, but there doesn't appear to be an easy way to find a list of extensions used by a php application. Approved by: Frank Laszlo <laszlof at tvog dot net> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/gforge/Makefile24
1 files changed, 4 insertions, 20 deletions
diff --git a/www/gforge/Makefile b/www/gforge/Makefile
index 801a836ab9de..3719b4cbab7d 100644
--- a/www/gforge/Makefile
+++ b/www/gforge/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= http://gforge.org/frs/download.php/103/
MAINTAINER= laszlof@vonostingroup.com
COMMENT= Open Source collaborative software development tool
-RUN_DEPENDS= ${LOCALBASE}/bin/php:${PORTSDIR}/lang/php4 \
- ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget \
+RUN_DEPENDS= ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget \
${LOCALBASE}/share/jpgraph/imgdata_balls.inc:${PORTSDIR}/graphics/jpgraph
USE_BZIP2= YES
@@ -24,29 +23,14 @@ HAS_CONFIGURE= YES
USE_APACHE= YES
USE_AUTOCONF_VER= 253
NO_BUILD= YES
-
-.if defined(WITH_APACHE2)
-MOD_DIR= libexec/apache2
-.else
-MOD_DIR= libexec/apache
-.endif
-
-MOD_PHP= ${LOCALBASE}/${MOD_DIR}/libphp4.so
-BIN_PHP= ${LOCALBASE}/bin/php
-PQ_LIB= ${LOCALBASE}/lib/libpq.so
+USE_PHP= pgsql session
+WANT_PHP_CLI= YES
+WANT_PHP_MOD= YES
NO_PACKAGE= "The configure process uses hostname."
.include <bsd.port.pre.mk>
-### Misc checks
-.if !exists(${MOD_PHP}) && !exists(${BIN_PHP})
-IGNORE= You MUST have installed PHP from lang/php4 \(mod_php et php-cli are required\)
-.endif
-.if !exists(${PQ_LIB})
-IGNORE+= PHP needs PostgreSQL support
-.endif
-
.if defined(WITH_JABBER)
CONFIGURE_ARGS+= --enable-jabber
RUN_DEPENDS+= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net/jabber