aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-02-13 06:47:48 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-02-13 06:47:48 +0800
commitb7bbc865ed4ebf8f146bce7c426d3b19f047da91 (patch)
tree39dd7a2f12da422d52e0577f41c5c8d929668256 /www
parent77ea07f0aab0b3331935ae5316b47d4f43a665f8 (diff)
downloadfreebsd-ports-gnome-b7bbc865ed4ebf8f146bce7c426d3b19f047da91.tar.gz
freebsd-ports-gnome-b7bbc865ed4ebf8f146bce7c426d3b19f047da91.tar.zst
freebsd-ports-gnome-b7bbc865ed4ebf8f146bce7c426d3b19f047da91.zip
- Update to 2.6
Remove previously applied compile patch, it was upstreamed (yay!) PR: ports/164498, ports/163320 Submitted by: Anthony Chavez <acc@hexadecagram.org>, Nick Rogers <ncrogers@gmail.com> Approved by: maintainer timeout (anders ; 36 days) [no commit 100 days]
Diffstat (limited to 'www')
-rw-r--r--www/pound/Makefile2
-rw-r--r--www/pound/distinfo4
-rw-r--r--www/pound/files/patch-Makefile.in11
-rw-r--r--www/pound/files/patch-config.c37
-rw-r--r--www/pound/files/patch-pound.h25
-rw-r--r--www/pound/files/patch-svc.c225
6 files changed, 3 insertions, 301 deletions
diff --git a/www/pound/Makefile b/www/pound/Makefile
index 248dba3000b3..63365025ae51 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pound
-PORTVERSION= 2.5
+PORTVERSION= 2.6
CATEGORIES= www net
MASTER_SITES= http://www.apsis.ch/pound/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
diff --git a/www/pound/distinfo b/www/pound/distinfo
index 07a8d80f2f00..616bc3e15572 100644
--- a/www/pound/distinfo
+++ b/www/pound/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Pound-2.5.tgz) = 11dfa7b469636d43aec803455894b30821ba7f6641c1cfd45df53059d3ac4c95
-SIZE (Pound-2.5.tgz) = 172084
+SHA256 (Pound-2.6.tgz) = 0ad25e3652e22117abbc17a70b5d8913e05991318a5506bc7437e662616fdf21
+SIZE (Pound-2.6.tgz) = 180595
diff --git a/www/pound/files/patch-Makefile.in b/www/pound/files/patch-Makefile.in
deleted file mode 100644
index 6a5b9aac4f31..000000000000
--- a/www/pound/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Makefile.in.orig 2010-02-02 11:49:02.000000000 +0000
-+++ ./Makefile.in 2012-02-11 22:51:17.576840137 +0000
-@@ -63,7 +63,7 @@
- $(OBJS): pound.h config.h
-
- svc.o: svc.c dh512.h dh1024.h
-- gcc ${CFLAGS} -c -o svc.o svc.c
-+ ${CC} ${CFLAGS} -c -o svc.o svc.c
-
- install: all
- @INSTALL@ -d ${DESTDIR}@sbindir@
diff --git a/www/pound/files/patch-config.c b/www/pound/files/patch-config.c
deleted file mode 100644
index 14d63155db2e..000000000000
--- a/www/pound/files/patch-config.c
+++ /dev/null
@@ -1,37 +0,0 @@
---- ./config.c.orig 2010-02-02 11:49:02.000000000 +0000
-+++ ./config.c 2012-02-11 22:51:28.219835635 +0000
-@@ -431,14 +431,22 @@
- res = (res ^ *k++) * 16777619;
- return res;
- }
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+static IMPLEMENT_LHASH_HASH_FN(t, TABNODE)
-+#else
- static IMPLEMENT_LHASH_HASH_FN(t_hash, const TABNODE *)
-+#endif
-
- static int
- t_cmp(const TABNODE *d1, const TABNODE *d2)
- {
- return strcmp(d1->key, d2->key);
- }
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+static IMPLEMENT_LHASH_COMP_FN(t, TABNODE)
-+#else
- static IMPLEMENT_LHASH_COMP_FN(t_cmp, const TABNODE *)
-+#endif
-
- /*
- * parse a service
-@@ -460,7 +468,11 @@
- pthread_mutex_init(&res->mut, NULL);
- if(svc_name)
- strncpy(res->name, svc_name, KEY_SIZE);
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ if((res->sessions = LHM_lh_new(TABNODE, t)) == NULL)
-+#else
- if((res->sessions = lh_new(LHASH_HASH_FN(t_hash), LHASH_COMP_FN(t_cmp))) == NULL)
-+#endif
- conf_err("lh_new failed - aborted");
- ign_case = ignore_case;
- while(conf_fgets(lin, MAXBUF)) {
diff --git a/www/pound/files/patch-pound.h b/www/pound/files/patch-pound.h
deleted file mode 100644
index 1ff8820c0a56..000000000000
--- a/www/pound/files/patch-pound.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- ./pound.h.orig 2012-02-11 22:51:17.579834493 +0000
-+++ ./pound.h 2012-02-11 22:51:28.220833901 +0000
-@@ -323,6 +323,10 @@
- /* maximal session key size */
- #define KEY_SIZE 127
-
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+DECLARE_LHASH_OF(TABNODE);
-+#endif
-+
- /* service definition */
- typedef struct _service {
- char name[KEY_SIZE + 1]; /* symbolic name */
-@@ -338,7 +342,11 @@
- int sess_ttl; /* session time-to-live */
- regex_t sess_start; /* pattern to identify the session data */
- regex_t sess_pat; /* pattern to match the session data */
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ LHASH_OF(TABNODE) *sessions; /* currently active sessions */
-+#else
- LHASH *sessions; /* currently active sessions */
-+#endif
- int dynscale; /* true if the back-ends should be dynamically rescaled */
- int disabled; /* true if the service is disabled */
- struct _service *next;
diff --git a/www/pound/files/patch-svc.c b/www/pound/files/patch-svc.c
deleted file mode 100644
index 6b242b810555..000000000000
--- a/www/pound/files/patch-svc.c
+++ /dev/null
@@ -1,225 +0,0 @@
---- ./svc.c.orig 2010-02-02 11:49:02.000000000 +0000
-+++ ./svc.c 2012-02-11 22:51:28.222833621 +0000
-@@ -27,12 +27,17 @@
-
- #include "pound.h"
-
-+#ifndef LHASH_OF
-+#define LHASH_OF(x) LHASH
-+#define CHECKED_LHASH_OF(type, h) h
-+#endif
-+
- /*
- * Add a new key/content pair to a hash table
- * the table should be already locked
- */
- static void
--t_add(LHASH *const tab, const char *key, const void *content, const size_t cont_len)
-+t_add(LHASH_OF(TABNODE) *const tab, const char *key, const void *content, const size_t cont_len)
- {
- TABNODE *t, *old;
-
-@@ -53,7 +58,11 @@
- }
- memcpy(t->content, content, cont_len);
- t->last_acc = time(NULL);
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ if((old = LHM_lh_insert(TABNODE, tab, t)) != NULL) {
-+#else
- if((old = (TABNODE *)lh_insert(tab, t)) != NULL) {
-+#endif
- free(old->key);
- free(old->content);
- free(old);
-@@ -68,12 +77,16 @@
- * side-effect: update the time of last access
- */
- static void *
--t_find(LHASH *const tab, char *const key)
-+t_find(LHASH_OF(TABNODE) *const tab, char *const key)
- {
- TABNODE t, *res;
-
- t.key = key;
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ if((res = LHM_lh_retrieve(TABNODE, tab, &t)) != NULL) {
-+#else
- if((res = (TABNODE *)lh_retrieve(tab, &t)) != NULL) {
-+#endif
- res->last_acc = time(NULL);
- return res->content;
- }
-@@ -84,12 +97,16 @@
- * Delete a key
- */
- static void
--t_remove(LHASH *const tab, char *const key)
-+t_remove(LHASH_OF(TABNODE) *const tab, char *const key)
- {
- TABNODE t, *res;
-
- t.key = key;
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ if((res = LHM_lh_delete(TABNODE, tab, &t)) != NULL) {
-+#else
- if((res = (TABNODE *)lh_delete(tab, &t)) != NULL) {
-+#endif
- free(res->key);
- free(res->content);
- free(res);
-@@ -98,59 +115,75 @@
- }
-
- typedef struct {
-- LHASH *tab;
-+ LHASH_OF(TABNODE) *tab;
- time_t lim;
- void *content;
- int cont_len;
- } ALL_ARG;
-
- static void
--t_old(TABNODE *t, void *arg)
-+t_old_doall_arg(TABNODE *t, ALL_ARG *a)
- {
-- ALL_ARG *a;
--
-- a = (ALL_ARG *)arg;
- if(t->last_acc < a->lim)
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ LHM_lh_delete(TABNODE, a->tab, t);
-+#else
- lh_delete(a->tab, t);
-+#endif
- return;
- }
--IMPLEMENT_LHASH_DOALL_ARG_FN(t_old, TABNODE *, void *)
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+IMPLEMENT_LHASH_DOALL_ARG_FN(t_old, TABNODE, ALL_ARG)
-+#else
-+#define t_old t_old_doall_arg
-+IMPLEMENT_LHASH_DOALL_ARG_FN(t_old, TABNODE *, ALL_ARG *)
-+#endif
-
- /*
- * Expire all old nodes
- */
- static void
--t_expire(LHASH *const tab, const time_t lim)
-+t_expire(LHASH_OF(TABNODE) *const tab, const time_t lim)
- {
- ALL_ARG a;
- int down_load;
-
- a.tab = tab;
- a.lim = lim;
-- down_load = tab->down_load;
-- tab->down_load = 0;
-+ down_load = CHECKED_LHASH_OF(TABNODE, tab)->down_load;
-+ CHECKED_LHASH_OF(TABNODE, tab)->down_load = 0;
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ LHM_lh_doall_arg(TABNODE, tab, LHASH_DOALL_ARG_FN(t_old), ALL_ARG, &a);
-+#else
- lh_doall_arg(tab, LHASH_DOALL_ARG_FN(t_old), &a);
-- tab->down_load = down_load;
-+#endif
-+ CHECKED_LHASH_OF(TABNODE, tab)->down_load = down_load;
- return;
- }
-
- static void
--t_cont(TABNODE *t, void *arg)
-+t_cont_doall_arg(TABNODE *t, ALL_ARG *a)
- {
-- ALL_ARG *a;
--
-- a = (ALL_ARG *)arg;
- if(memcmp(t->content, a->content, a->cont_len) == 0)
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ LHM_lh_delete(TABNODE, a->tab, t);
-+#else
- lh_delete(a->tab, t);
-+#endif
- return;
- }
--IMPLEMENT_LHASH_DOALL_ARG_FN(t_cont, TABNODE *, void *)
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+IMPLEMENT_LHASH_DOALL_ARG_FN(t_cont, TABNODE, ALL_ARG)
-+#else
-+#define t_cont t_cont_doall_arg
-+IMPLEMENT_LHASH_DOALL_ARG_FN(t_cont, TABNODE *, ALL_ARG *)
-+#endif
-
- /*
- * Remove all nodes with the given content
- */
- static void
--t_clean(LHASH *const tab, void *const content, const size_t cont_len)
-+t_clean(LHASH_OF(TABNODE) *const tab, void *const content, const size_t cont_len)
- {
- ALL_ARG a;
- int down_load;
-@@ -158,10 +191,14 @@
- a.tab = tab;
- a.content = content;
- a.cont_len = cont_len;
-- down_load = tab->down_load;
-- tab->down_load = 0;
-+ down_load = CHECKED_LHASH_OF(TABNODE, tab)->down_load;
-+ CHECKED_LHASH_OF(TABNODE, tab)->down_load = 0;
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ LHM_lh_doall_arg(TABNODE, tab, LHASH_DOALL_ARG_FN(t_cont), ALL_ARG, &a);
-+#else
- lh_doall_arg(tab, LHASH_DOALL_ARG_FN(t_cont), &a);
-- tab->down_load = down_load;
-+#endif
-+ CHECKED_LHASH_OF(TABNODE, tab)->down_load = down_load;
- return;
- }
-
-@@ -1410,13 +1447,11 @@
- } DUMP_ARG;
-
- static void
--t_dump(TABNODE *t, void *arg)
-+t_dump_doall_arg(TABNODE *t, DUMP_ARG *a)
- {
-- DUMP_ARG *a;
- BACKEND *be, *bep;
- int n_be, sz;
-
-- a = (DUMP_ARG *)arg;
- memcpy(&bep, t->content, sizeof(bep));
- for(n_be = 0, be = a->backends; be; be = be->next, n_be++)
- if(be == bep)
-@@ -1432,19 +1467,28 @@
- return;
- }
-
--IMPLEMENT_LHASH_DOALL_ARG_FN(t_dump, TABNODE *, void *)
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+IMPLEMENT_LHASH_DOALL_ARG_FN(t_dump, TABNODE, DUMP_ARG)
-+#else
-+#define t_dump t_dump_doall_arg
-+IMPLEMENT_LHASH_DOALL_ARG_FN(t_dump, TABNODE *, DUMP_ARG *)
-+#endif
-
- /*
- * write sessions to the control socket
- */
- static void
--dump_sess(const int control_sock, LHASH *const sess, BACKEND *const backends)
-+dump_sess(const int control_sock, LHASH_OF(TABNODE) *const sess, BACKEND *const backends)
- {
- DUMP_ARG a;
-
- a.control_sock = control_sock;
- a.backends = backends;
-+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
-+ LHM_lh_doall_arg(TABNODE, sess, LHASH_DOALL_ARG_FN(t_dump), DUMP_ARG, &a);
-+#else
- lh_doall_arg(sess, LHASH_DOALL_ARG_FN(t_dump), &a);
-+#endif
- return;
- }
-