aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-07-07 04:40:51 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2017-07-07 04:40:51 +0800
commitb7f2d323ae8ab95682f708ea929fe6e5f53150c4 (patch)
tree3b0e8bcb02552c5add5c6fbd68fbf55008f8af69 /www
parent02c5f4f1eea27bab8266f0b88135e23312bc7cb5 (diff)
downloadfreebsd-ports-gnome-b7f2d323ae8ab95682f708ea929fe6e5f53150c4.tar.gz
freebsd-ports-gnome-b7f2d323ae8ab95682f708ea929fe6e5f53150c4.tar.zst
freebsd-ports-gnome-b7f2d323ae8ab95682f708ea929fe6e5f53150c4.zip
Split part of www/qt5-websockets into new port www/qt5-websockets-qml
This splits qt5-websockets into a qt5-websockets port containing the core parts, and a qt5-websockets-qml port with the QML parts. The QML parts depend on Qt Quick, so on the GUI parts (and hence X11) while the core parts do not. PR: 220045 Submitted by: Adriaan de Groot <groot@kde.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/qt5-websockets-qml/Makefile16
-rw-r--r--www/qt5-websockets-qml/files/patch-src_src.pro12
-rw-r--r--www/qt5-websockets-qml/pkg-plist5
-rw-r--r--www/qt5-websockets/Makefile3
-rw-r--r--www/qt5-websockets/files/patch-src_src.pro11
-rw-r--r--www/qt5-websockets/pkg-plist5
7 files changed, 47 insertions, 6 deletions
diff --git a/www/Makefile b/www/Makefile
index 2ad11a62a903..83a80843a8ad 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1860,6 +1860,7 @@
SUBDIR += qt5-webchannel
SUBDIR += qt5-webkit
SUBDIR += qt5-websockets
+ SUBDIR += qt5-websockets-qml
SUBDIR += quickie
SUBDIR += qupzilla-qt4
SUBDIR += qupzilla-qt5
diff --git a/www/qt5-websockets-qml/Makefile b/www/qt5-websockets-qml/Makefile
new file mode 100644
index 000000000000..3a75f8e41811
--- /dev/null
+++ b/www/qt5-websockets-qml/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= websockets-qml
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= www
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt implementation of WebSocket protocol (QML bindings)
+
+USE_QT5= buildtools_build core network qml quick websockets
+QT_DIST= websockets
+USES= qmake
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+.include <bsd.port.mk>
diff --git a/www/qt5-websockets-qml/files/patch-src_src.pro b/www/qt5-websockets-qml/files/patch-src_src.pro
new file mode 100644
index 000000000000..75d47d8de009
--- /dev/null
+++ b/www/qt5-websockets-qml/files/patch-src_src.pro
@@ -0,0 +1,12 @@
+We only care about the qml bindings in 'imports'.
+The proper part of websockets is built via www/qt5-websockets.
+
+--- src/src.pro.orig 2017-06-16 04:42:03 UTC
++++ src/src.pro
+@@ -1,5 +1,4 @@
+ TEMPLATE = subdirs
+ CONFIG += ordered
+
+-SUBDIRS += websockets
+-qtHaveModule(quick): SUBDIRS += imports
++SUBDIRS += imports
diff --git a/www/qt5-websockets-qml/pkg-plist b/www/qt5-websockets-qml/pkg-plist
new file mode 100644
index 000000000000..b0d479958304
--- /dev/null
+++ b/www/qt5-websockets-qml/pkg-plist
@@ -0,0 +1,5 @@
+%%QT_QMLDIR%%/QtWebSockets/libdeclarative_qmlwebsockets.so
+%%DEBUG%%%%QT_QMLDIR%%/QtWebSockets/libdeclarative_qmlwebsockets.so.debug
+%%QT_QMLDIR%%/QtWebSockets/plugins.qmltypes
+%%QT_QMLDIR%%/QtWebSockets/qmldir
+%%QT_QMLDIR%%/Qt/WebSockets/qmldir
diff --git a/www/qt5-websockets/Makefile b/www/qt5-websockets/Makefile
index b92cc23a1e32..a36312c8613b 100644
--- a/www/qt5-websockets/Makefile
+++ b/www/qt5-websockets/Makefile
@@ -2,13 +2,14 @@
PORTNAME= websockets
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt implementation of WebSocket protocol
-USE_QT5= buildtools_build core network qml quick
+USE_QT5= buildtools_build core network
QT_DIST= ${PORTNAME}
USES= qmake
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/www/qt5-websockets/files/patch-src_src.pro b/www/qt5-websockets/files/patch-src_src.pro
new file mode 100644
index 000000000000..77e1e6486625
--- /dev/null
+++ b/www/qt5-websockets/files/patch-src_src.pro
@@ -0,0 +1,11 @@
+Disable the build of the qml part.
+
+Splitting them out allows us to use websockets in non-gui applications.
+
+--- src/src.pro.orig 2017-06-16 04:39:03 UTC
++++ src/src.pro
+@@ -2,4 +2,3 @@ TEMPLATE = subdirs
+ CONFIG += ordered
+
+ SUBDIRS += websockets
+-qtHaveModule(quick): SUBDIRS += imports
diff --git a/www/qt5-websockets/pkg-plist b/www/qt5-websockets/pkg-plist
index cd0517f99a05..ccf9af5d94dd 100644
--- a/www/qt5-websockets/pkg-plist
+++ b/www/qt5-websockets/pkg-plist
@@ -32,9 +32,4 @@
%%DEBUG%%%%QT_LIBDIR%%/libQt5WebSockets.so.%%FULLVER%%.debug
%%QT_MKSPECDIR%%/modules/qt_lib_websockets.pri
%%QT_MKSPECDIR%%/modules/qt_lib_websockets_private.pri
-%%QT_QMLDIR%%/QtWebSockets/libdeclarative_qmlwebsockets.so
-%%DEBUG%%%%QT_QMLDIR%%/QtWebSockets/libdeclarative_qmlwebsockets.so.debug
-%%QT_QMLDIR%%/QtWebSockets/plugins.qmltypes
-%%QT_QMLDIR%%/QtWebSockets/qmldir
-%%QT_QMLDIR%%/Qt/WebSockets/qmldir
libdata/pkgconfig/Qt5WebSockets.pc