aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2018-08-02 11:18:56 +0800
committerwen <wen@FreeBSD.org>2018-08-02 11:18:56 +0800
commitbac2cee30300e1152d78648922ada0d4e01f8f3d (patch)
treeb262bb6f890ce7b47a34b6fd7906f199890a731a /www
parentda642dd001aeb87467aac2b242486b823b820401 (diff)
downloadfreebsd-ports-gnome-bac2cee30300e1152d78648922ada0d4e01f8f3d.tar.gz
freebsd-ports-gnome-bac2cee30300e1152d78648922ada0d4e01f8f3d.tar.zst
freebsd-ports-gnome-bac2cee30300e1152d78648922ada0d4e01f8f3d.zip
- Repocopy www/py-django20 --> www/py-django21 and update to 2.1
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django21/Makefile65
-rw-r--r--www/py-django21/distinfo3
-rw-r--r--www/py-django21/pkg-descr10
4 files changed, 79 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index babe3e859771..80124f0b0e26 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1633,6 +1633,7 @@
SUBDIR += py-django111
SUBDIR += py-django18
SUBDIR += py-django20
+ SUBDIR += py-django21
SUBDIR += py-django_compressor
SUBDIR += py-django_openstack_auth
SUBDIR += py-django_polymorphic
diff --git a/www/py-django21/Makefile b/www/py-django21/Makefile
new file mode 100644
index 000000000000..462be3eb1a07
--- /dev/null
+++ b/www/py-django21/Makefile
@@ -0,0 +1,65 @@
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+# $FreeBSD$
+
+PORTNAME= django
+PORTVERSION= 2.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP \
+ https://www.djangoproject.com/m/releases/${PORTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 21
+DISTNAME= Django-${PORTVERSION}
+DIST_SUBDIR= python
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= High-level Python Web Framework
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR}
+
+NO_ARCH= yes
+USES= cpe python:3.5+ shebangfix
+USE_PYTHON= autoplist distutils
+SHEBANG_FILES= django/bin/django-admin.py \
+ django/conf/project_template/manage.py-tpl
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}django18 ${PYTHON_PKGNAMEPREFIX}django11[01] \
+ ${PYTHON_PKGNAMEPREFIX}django20
+CPE_VENDOR= djangoproject
+
+DOCSDIR= ${PREFIX}/share/doc/py-django
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS HTMLDOCS
+OPTIONS_DEFAULT= SQLITE
+
+OPTIONS_GROUP= DATABASE
+OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
+
+HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
+
+PLIST_FILES= man/man1/django-admin.1.gz
+
+HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
+HTMLDOCS_IMPLIES= DOCS
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2@${PY_FLAVOR}
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb@${PY_FLAVOR}
+MYSQL_BROKEN= MySQLdb only supports Python 2.
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+
+post-build-HTMLDOCS-on:
+ cd ${WRKSRC}/docs && ${MAKE} html SPHINXBUILD=sphinx-build-${PYTHON_VER}
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
+ @${ECHO_MSG} ""
+
+post-install-HTMLDOCS-on:
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/www/py-django21/distinfo b/www/py-django21/distinfo
new file mode 100644
index 000000000000..d44c2e75f9b5
--- /dev/null
+++ b/www/py-django21/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533172985
+SHA256 (python/Django-2.1.tar.gz) = 7f246078d5a546f63c28fc03ce71f4d7a23677ce42109219c24c9ffb28416137
+SIZE (python/Django-2.1.tar.gz) = 8583964
diff --git a/www/py-django21/pkg-descr b/www/py-django21/pkg-descr
new file mode 100644
index 000000000000..0ea493b87ab6
--- /dev/null
+++ b/www/py-django21/pkg-descr
@@ -0,0 +1,10 @@
+Django is a high-level Python Web framework that encourages rapid development
+and clean, pragmatic design.
+
+Developed and used over the past two years by a fast-moving online-news
+operation, Django was designed from scratch to handle two challenges: the
+intensive deadlines of a newsroom and the stringent requirements of experienced
+Web developers. It has convenient niceties for developing content-management
+systems, but it's an excellent tool for building any Web site.
+
+WWW: https://www.djangoproject.com/